×

Discussion Board

Page 1 of 3 123 LastLast
Results 1 to 15 of 31
  1. #1
    Regular Contributor
    Join Date
    Dec 2010
    Posts
    87

    application in device not able to open

    hi Friends.....
    I created the SIS file for the corresponding application,and i installed it successfully,but i unable to open the application
    I have given the capabilites in .mmp file is WriteUserData.I assure there is no problem in pkg and mmp file ...please give the possible solution as soon as possibl.........
    This is my pkg file:I included DLL file also.DLL file is present regarding Log file cteation.............

    ; Installation file for helloworld1 application
    ;
    ; This is an auto-generated PKG file by Carbide.
    ; This file uses variables specific to Carbide builds that will not work
    ; on command-line builds. If you want to use this generated PKG file from the
    ; command-line tools you will need to modify the variables with the appropriate
    ; values: $(EPOCROOT), $(PLATFORM), $(TARGET)
    ;
    ;Language - standard language definitions
    &EN

    ; standard SIS file header
    #{"helloworld1"},(0xE88EF8DD),1,0,0

    ;Localised Vendor name
    %{"Vendor-EN"}

    ;Unique Vendor name
    :"Vendor"

    ;Supports Series 60 v 3.0
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}

    ;Files to install
    ;You should change the source paths to match that of your environment
    ;<source> <destination>
    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\helloworld1_0xE88EF8DD.exe" -"!:\sys\bin\helloworld1_0xE88EF8DD.exe"
    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\SRMLogger.dll" -"!:\sys\bin\SRMLogger.dll"
    "$(EPOCROOT)Epoc32\data\z\resource\apps\helloworld1_0xE88EF8DD.rsc" -"!:\resource\apps\helloworld1_0xE88EF8DD.rsc"
    "$(EPOCROOT)Epoc32\data\z\private\10003a3f\apps\helloworld1_0xE88EF8DD_reg.rsc" -"!:\private\10003a3f\import\apps\helloworld1_0xE88EF8DD_reg.rsc"
    "$(EPOCROOT)Epoc32\data\z\resource\apps\helloworld1_0xE88EF8DD.mif" -"!:\resource\apps\helloworld1_0xE88EF8DD.mif"
    ;"..\help\helloworld1_0xE88EF8DD.hlp" -"!:\resource\help\helloworld1_0xE88EF8DD.hlp"

    ; Add any installation notes if applicable
    ;"helloworld1.txt" -"!:\private\E88EF8DD\helloworld1.txt"

    ;required for application to be covered by backup/restore facility
    "..\sis\backup_registration.xml" -"!:\private\E88EF8DD\backup_registration.xml"
    Thanks Regards,
    maheskumar.
    Last edited by maheskumar; 2011-01-05 at 06:25.

  2. #2
    Nokia Developer Champion
    Join Date
    Dec 2008
    Posts
    2,355

    Re: application in device not able to open

    1 make sure the mif file is there in the pkg file
    2. if the app needs any supporting file while loading , make sure the file is therein the pkg file.
    3. if its running fine in emulator then prob is in the pkg file.
    4. install ErrRd.SIS in the device and then try to open the app, it will give you some error code (if any)
    5. show me the pkg file

  3. #3
    Regular Contributor
    Join Date
    Dec 2010
    Posts
    87

    Re: application in device not able to open

    emulator is disappeared automatically ....before open the application in the emulator.
    .mif file is present in .pkg.you can see it in the below pkg file content.
    what to do for it?
    Last edited by maheskumar; 2011-01-05 at 06:50.

  4. #4
    Registered User
    Join Date
    Feb 2007
    Location
    India
    Posts
    1,128

    Re: application in device not able to open

    You will need run your application in debug mode......and set some break points in starting line of code .........

  5. #5
    Nokia Developer Champion
    Join Date
    Dec 2008
    Posts
    2,355

    Re: application in device not able to open

    Quote Originally Posted by maheskumar View Post
    emulator is disappeared automatically ....before open the application in the emulator.
    .mif file is present in .pkg.you can see it in the below pkg file content.
    what to do for it?
    tell me the last line of epocwind.out, go to run type %temp% and search for epocwind.out.

  6. #6
    Regular Contributor
    Join Date
    Dec 2010
    Posts
    87

    Re: application in device not able to open

    Now the emulator is opening .for that i made change in debug configuration as epoc.exe , but when i open the application the emulator showing Application Closed kind of error...........

  7. #7
    Nokia Developer Champion
    Join Date
    Dec 2008
    Posts
    2,355

    Re: application in device not able to open

    Quote Originally Posted by maheskumar View Post
    Now the emulator is opening .for that i made change in debug configuration as epoc.exe , but when i open the application the emulator showing Application Closed kind of error...........

    Yes tell me the error. and also go to epocwind.out file and tell me what is mentioned in the last line.

  8. #8
    Regular Contributor
    Join Date
    Oct 2009
    Posts
    314

    Re: application in device not able to open

    Can you share your AppUi ConstructL and the application view file..... and please mention the error that you are recieving. or take a screen shot of the error and let us know

  9. #9
    Regular Contributor
    Join Date
    Dec 2010
    Posts
    87

    Re: application in device not able to open

    i unable to find epocwind.out in my system.....

  10. #10
    Regular Contributor
    Join Date
    Dec 2010
    Posts
    87

    Re: application in device not able to open

    void Chelloworld1AppUi::ConstructL()
    {
    iLogger = CSRMLogger ::Logger(); //this is from my own DLL
    iLogger->Write(_L("Chelloworld1AppUi::ConstructL")); //this also
    // Initialise app UI with standard value.
    BaseConstructL(CAknAppUi::EAknEnableSkin);
    // Create view object
    iAppView = Chelloworld1AppView::NewL(ClientRect());
    //CSRMLogger* iLogger;

    // Create a file to write the text to
    TInt err = CCoeEnv::Static()->FsSession().MkDirAll(KFileName);
    if ((KErrNone != err) && (KErrAlreadyExists != err))
    {
    return;
    }

    RFile file;
    err = file.Replace(CCoeEnv::Static()->FsSession(), KFileName, EFileWrite);
    CleanupClosePushL(file);
    if (KErrNone != err)
    {
    CleanupStack::PopAndDestroy(1); // file
    return;
    }

    RFileWriteStream outputFileStream(file);
    CleanupClosePushL(outputFileStream);
    outputFileStream << KText;

    CleanupStack::PopAndDestroy(2); // outputFileStream, file

    }



    void Chelloworld1AppView::ConstructL(const TRect& aRect)
    {
    // Create a window for this application view
    CreateWindowL();
    //iLogger = CSRMLogger::Logger();
    iLogger->Write(_L("Chelloworld1AppUi::ConstructL"));
    // Set the windows size
    SetRect(aRect);

    // Activate the window, which makes it ready to be drawn
    ActivateL();
    }
    is it ok .....

  11. #11
    Regular Contributor
    Join Date
    Oct 2009
    Posts
    314

    Re: application in device not able to open

    in the AppView where you have initialed iLogger and does the error coming is KERN EXEC 3

  12. #12
    Regular Contributor
    Join Date
    Dec 2010
    Posts
    87

    Re: application in device not able to open

    after initialation also emulator showing "application closed ....helloworld user 23"

  13. #13
    Super Contributor
    Join Date
    Jan 2007
    Location
    Bhubaneswar, India
    Posts
    1,189

    Re: application in device not able to open

    check these resource in .rss file
    RESOURCE RSS_SIGNATURE {}
    RESOURCE TBUF {buf="";}
    RESOURCE EIK_APP_INFO

    you may check .rss and .rsg file name
    -------------------------------------
    Thanks & Regards
    Ram
    Symbian OS 9.2/9.3,S60 3rd FP1/FP2,Carbide.c++v2.0

  14. #14
    Nokia Developer Champion
    Join Date
    Jun 2008
    Location
    Noida,India
    Posts
    3,987

    Re: application in device not able to open

    Quote Originally Posted by maheskumar View Post
    after initialation also emulator showing "application closed ....helloworld user 23"
    Are you copying some data into a TBuf8 type buffer , anywhere while your application starts? You can put debug points in you code & check it on emulator that where it is getting crashed.Also User 23 has nothing to do with device, if its there it must be there in emulator as well.

  15. #15
    Regular Contributor
    Join Date
    Oct 2009
    Posts
    314

    Re: application in device not able to open

    Quote Originally Posted by maheskumar View Post
    after initialation also emulator showing "application closed ....helloworld user 23"
    Can you check in the CLogger file about the use of the descriptor if any. Please check what Vineet is saying

Similar Threads

  1. Replies: 4
    Last Post: 2010-03-01, 09:51
  2. UI application(with Open C) crashes on real device!
    By jeff.jiang in forum Open C/C++
    Replies: 2
    Last Post: 2009-08-24, 14:45
  3. Replies: 0
    Last Post: 2009-05-30, 12:55
  4. Can not open application on device after install the *.sis file
    By darkdisciple in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 2
    Last Post: 2007-06-09, 23:15
  5. Can't open application on the device
    By kaori in forum Symbian
    Replies: 9
    Last Post: 2006-12-20, 10:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×