×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    May 2009
    Posts
    4

    [SOLVED] SIP Call on Symbian - REGISTER works, Proxy authorization not

    Hi,

    I have the following situation:

    I got the following information from my operator:

    username: user@vip.mk
    pass: xxx
    proxy: sip.vip.mk (same as sip.a1.net)
    realm: a1.net


    When I put these settings in Blink or X-Lite everything works as expected.

    I'm wondering how I should put this settings in Nokia. I'm using both N95 8g and 5630 XM without success.

    I'm using wireshark to debug.

    Both phones register successfully, when I try to call a number both issue a command INVITE.

    They both got the response 407 Proxy authorization requested

    and the resend new INVITE, after which they both got 403 Forbidden.

    I had tried lot of settings without success. My current settings are:
    Proxy server:
    address: sip.vip.mk
    realm: a1.net
    username: user
    password: xxx

    Registar server:
    address: vip.mk
    realm: a1.net
    username: user
    password: xxx

    I'm using a SIP for 3years on my Nokia without any problems with other providers. However I'm a beginner in understanding SIP protocol so I did not understand it well and maybe I'm doing some stupid mistake.

    I can provide by PM real user/password if someone is willing to help me with this issue.

    Thanks to all for taking time to read this.
    Last edited by tinodj1; 2011-01-19 at 01:10. Reason: problem resolved

  2. #2
    Nokia Developer Champion
    Join Date
    Mar 2003
    Posts
    4,105

    Re: SIP Call on Symbian - REGISTER works, Proxy authorization not

    In the 407, there is the realm of the server. Make sure it matches your settings. If that does not help, check your IP address in your INVITE. Perhaps you need STUN.

  3. #3
    Registered User
    Join Date
    May 2009
    Posts
    4

    Re: SIP Call on Symbian - REGISTER works, Proxy authorization not

    Problem solved. I found the tip in the following forum:
    http://www2.pbxes.com/forum/thread.p...tid=1267775830

    and here is the tip:
    Some of the SIP messaging is in TCP and some in UDP. The process from the Register to the Invite should be carried out in TCP or UDP, not both alternatively. Verify whether you can restrict the SIP client to use one or the other.

    So changing from Auto to either TCP or UDP works perfectly.

    In meantime I found following blog which also can be very helpful in resolving SIP related problems.

    http://vesakoret.wordpress.com/2010/...rovider-fails/

Similar Threads

  1. Replies: 7
    Last Post: 2009-06-16, 08:18
  2. SIP REGISTER method to Ondo SIP Server
    By jeetu_basai in forum Symbian Networking & Messaging (Closed)
    Replies: 4
    Last Post: 2007-09-17, 12:07
  3. 407 Proxy authorization required
    By pillar in forum VoIP
    Replies: 0
    Last Post: 2007-03-09, 08:26
  4. How to add Authorization header in REGISTER of SIP message
    By quexitao in forum Symbian Networking & Messaging (Closed)
    Replies: 9
    Last Post: 2006-12-01, 11:39
  5. How to Create Class of CSIPProfile which register SIP Server with in SIP Plug-in 4.0?
    By jason-symbian in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2006-03-01, 02:55

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •