×

Discussion Board

Page 1 of 3 123 LastLast
Results 1 to 15 of 45
  1. #1
    (Retired) Nokia Developer Admin.
    Join Date
    Jan 2006
    Location
    Michigan
    Posts
    4,664

    Qt SDK 1.1 Technology Preview

    The Qt SDK 1.1 technology preview [http://www.forum.nokia.com/info/sw.n...f8/Qt_SDK.html] is available. The SDK provides support for Qt Quick, Qt 4.7 APIs, Qt Mobility 1.1 APIs, and the use of native Symbian APIs.

    To report bugs please use the Qt bug tracker [http://bugreports.qt.nokia.com/] following the guidance for reporting Qt bugs [http://developer.qt.nokia.com/wiki/ReportingBugsInQt ]. Please use this thread for other feedback or comments.
    Last edited by jaaura; 2011-01-20 at 19:47. Reason: fixed the broken links

  2. #2
    Registered User
    Join Date
    Dec 2006
    Posts
    2,280

    Re: Qt SDK 1.1 Technology Preview

    Essential FAQs that seem to be missing:

    1) Can I install this tech preview in parallel with a working 1.0.x SDK without conflicts? It seems to want me to shut down Qt Creator during the install process.
    2) If I install the Qt 4.7.x beta to my Symbian device can I successfully revert back to the original 4.6.3? Seem to be people having problems with that too:
    http://discussion.forum.nokia.com/fo....1-to-Qt-4.6.3
    3) The main page says I can't deploy applications developed with this SDK to Ovi. However, is that really just Qt 4.7.x & Mobility 1.1? If I custom install and include 4.6.3 support and only use older mobility APIs, will there be anything "wrong" with the apps it builds?

    Basically it's very hard to test out new betas if they break the current production environment and have to be run on separate PC/VM and device! FAQs and instructions on this should be top of the list and to be frank, should be top of the release testing criteria too.

    Hoping for some positive answers,
    Mark

  3. #3
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: Qt SDK 1.1 Technology Preview

    You can install as many SDKs as you want just specifying different folders, when installing. The only requirement is to have Qt Creator closed during installation process.

  4. #4
    Registered User
    Join Date
    Dec 2006
    Posts
    2,280

    Re: Qt SDK 1.1 Technology Preview

    OK thanks. My SDK is installing now. How about the reverting back to Qt 4.6.3 on Symbian? I don't have a spare N8 hanging around in case it's a non-reversible process, so given the problems another developer has had, I don't want to do it without an official assurance it's doable with clear instructions.

    I have an open bug to verify on Qt 4.7.x for Symbian and have found more to test on that version before reporting. However I'd like to work around those and ship with 4.6.3 before the end of the quarter if at all possible.

  5. #5
    Registered User
    Join Date
    Dec 2006
    Posts
    2,280

    Re: Qt SDK 1.1 Technology Preview

    First feedback from downloaded SDK tech preview:
    Mobility Source isn't included but the documentation references the source.
    Specific example - Location API:
    The Nokia plugin
    Qt Mobility ships with a Maps and Navigation API plugin which accesses the relevant Ovi services provided Nokia. The use of these services is governed by the terms and conditions available in the file plugins/geoservices/nokia/OVI_SERVICES_TERMS_AND_CONDITIONS.txt.
    This important legal terms and condition file doesn't appear to be anywhere in the SDK. Although the important bit of the content does appear to be in a top-level file called NQSDevAgreement.txt.

  6. #6
    Registered User
    Join Date
    Jun 2010
    Posts
    7

    Re: Qt SDK 1.1 Technology Preview

    I should have posted my question in this thread, but here it is:
    http://discussion.forum.nokia.com/fo...symbian-device

  7. #7
    Registered User
    Join Date
    Dec 2006
    Posts
    2,280

    Re: Qt SDK 1.1 Technology Preview

    The 4.6.3 SIS file in the new SDK does allow you to revert from 4.7.1 but although it's in a folder named 4.6.3 it's actually 4.6.4 developer version. I'd like to get some clarification on why and whether this is close enough not to matter. There seems to be quite a bit in the 4.6.4 release note.

  8. #8
    Registered User
    Join Date
    Jun 2010
    Posts
    7

    Re: Qt SDK 1.1 Technology Preview

    It happens I have a phone that only hooks up to my computer via Bluetooth, not USB.
    It seems app_trk doesn't let me do debugging over bluetooth yet.

    Which means for now, i install .sis files onto it via drag-drop on ovi suite.

    I was able to build them before with Nokia SDK 1.0 because the sis signing was done in the build steps.
    Of course, the run would fail before it reached the deploy step, but at least I had a signed .sis file in the end that I could drag and drop.

    Now that signing symbian .sis files has been moved to the run steps, I get

    "Unable to acquire a device for port ''. It appears to be in use.
    Error while building project qmlReader (target: Symbian Device)
    When executing build step 'Deploy'"

    What were the reasons for moving signing steps to "run" instead of "build"? I can't see any good ones.
    Do we need to have the device hooked up by USB in order to make/sign a .sis file now?
    Last edited by aezust; 2011-01-25 at 18:05.

  9. #9
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Qt SDK 1.1 Technology Preview

    Q: Can the Qt SDK v1.1 TP be installed in parallel with the Nokia Qt SDK v1.0.2?
    A: Yes, just ensure that you are not accidentally overlapping the install directories ( not a problem if defaults are used). Also note that Qt Creator uses global settings so you will see the same targets configured on both your Qt Creator instances.

    Q: Can Qt 4.7.x be reverted to Qt 4.6.x on device?
    A: Yes, the SDK provides a downgrade package containing the corresponding Qt 4.6.x package. Just make sure you take it from the SDK directory matching the OS version of your device. See http://discussion.forum.nokia.com/fo...l=1#post813252

    Q: Can Qt Mobility 1.1.x be reverted back to Qt Mobility 1.0.x?
    A: Yes, the SDK provides a downgrade package containing the corresponding Qt Mobility 1.0.x package. Just make sure you take it from the SDK directory matching the OS version of your device. See http://discussion.forum.nokia.com/fo...l=1#post813252

    Q: Can applications built with Qt SDK v1.1 TP be deployed through Ovi Store?
    A: The SDK features Qt 4.7 and Qt Mobility 1.1 and by default these are the only Qt versions installed. However Qt 4.7 and Qt Mobility 1.1 are not yet supported by Ovi so applications generated with this default Qt SDK 1.1 TP configuration cannot be published through Ovi.

    Q: Can I have Qt 4.6.x based targets in the Qt SDK v1.1 TP?
    A: Yes. Although by default the SDK install deploys Qt 4.7 on top of both the Symbian^1 and Symbian^3 kits, you can install 4.6.x based targets either at install time (chose Custom install and make the corresponding module selection) or at any later time, by running the qtsymb-admin.bat tool from c:\QtSDK\Symbian\tools\

    Q: Can I deploy through the Ovi Store applications developed using a Qt 4.6.x based target on the Qt SDK v1.1 TP?
    A: Any application which has and declares dependency to Qt 4.6.0 and Qt Mobility 1.0.2 can be published, regardless of the tool chain used to generate it. Using the Nokia Qt SDK v1.0 would be of course the safest way to achieve this if not 100% confident of understanding the new tool chain.
    Last edited by ltomuta; 2011-01-27 at 08:20. Reason: Typo
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  10. #10
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Qt SDK 1.1 Technology Preview

    Q: Can I use the Smart Installer powered installation packages generated by the Qt SDK v1.1 TP ?
    A: The Smart Installer cannot deliver Qt 4.7.x and Qt Mobility 1.1.x binaries so you have to install these packages manually on your test devices. Once the packages installed you can use the Smart Installer powered installation packages in your test, but they should not trigger any download or otherwise have any impact on the installation.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  11. #11
    Registered User
    Join Date
    Nov 2010
    Location
    Phnom Penh
    Posts
    33

    Re: Qt SDK 1.1 Technology Preview

    Can I write code in Qt Mobility 1.02 but install on device which has Qt Mobility 1.1.? My program need to access Qt Mobility API such as messaging, location, systeminfo

    Thank.

  12. #12
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Qt SDK 1.1 Technology Preview

    Yes, Qt and Qt Mobility are backward compatible within a major release, so applications developed with Qt 1.x will work on all Qt 1.y releases (where y>x).
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  13. #13
    Registered User
    Join Date
    Apr 2009
    Posts
    506

    Re: Qt SDK 1.1 Technology Preview

    Hi

    Why SIS creation moved to Run section of projects settings?
    Symbian & Qt developer. http://vladest.org

  14. #14
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Qt SDK 1.1 Technology Preview

    Quote Originally Posted by vladest View Post
    Hi

    Why SIS creation moved to Run section of projects settings?
    I asked the same thing, with no satisfactory answer. Apparently some don't want to waste time building the SIS when all they want is a quick compile to validate the current code, without a plan to run the application ...
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  15. #15
    Registered User
    Join Date
    Jul 2010
    Posts
    9

    Re: Qt SDK 1.1 Technology Preview

    I did a full install of the QtSDK 1.1 TP on my Windows XP64 machine. Under Development Tools->Maemo toolchain, it says that it's installing Qt 4.7.0 for Maemo. When the installation happens, it creates a folder %TARGET_DIR%\Maemo\4.6.2\...
    However, if I go to %TARGET_DIR%\Maemo\4.6.2\sysroots\fremantle-arm-sysroot-20.2010.36-2-slim\usr\include\QtCoreQtCore/QGlobal.h, I see: QT_VERSION_STR "4.7.0". So presumably it installed right, but with a funny folder name, possibly because I have NokiaQtSDK also installed with that library version?

Similar Threads

  1. Example . New Qt APIs Technology Preview 2 - Mobility Project
    By skumar_rao in forum [Archived] Qt Mobility Project
    Replies: 2
    Last Post: 2009-12-14, 02:13
  2. Qt Mobility project techonology preview updated + Contest with great prizes launched
    By Jack Torrance in forum [Archived] Qt Mobility Project
    Replies: 0
    Last Post: 2009-12-07, 12:50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×