×

Discussion Board

Page 2 of 2 FirstFirst 12
Results 16 to 29 of 29
  1. #16
    Registered User
    Join Date
    Jun 2003
    Posts
    5

    Browser on 6600 S60V2

    Hi,

    Passing a zero UID to SendMessage on the 6600 seems to have no effect; I tried setting the UID to TUidApaMessageSwitchOpenFileValue and that seems to do something on the emulator.

    task.SendMessage( TUid::Uid( TUidApaMessageSwitchOpenFileValue ), *param8 );

    Could someone at Nokia confirm this is the correct procedure to use for the 6600 please?

    Edit: after trying on the device, this seems to have no effect! Can someone post a working example for the 6600 please?

    Thanks,

    Paul
    Last edited by paulrenn; 2004-03-15 at 13:22.

  2. #17
    Registered User
    Join Date
    Jun 2003
    Posts
    5

    BTTT! :-)

    Back to the top

  3. #18
    Registered User
    Join Date
    Oct 2004
    Posts
    19

    can't open specified wap-site

    See next post, sorry for double message
    Last edited by Roald de Vries; 2004-11-02 at 13:47.

  4. #19
    Registered User
    Join Date
    Oct 2004
    Posts
    19
    I have a few questions:
    - does anybody know how to handle exiting the browser
    - the launchwap app opens the bookmarks, not the specified page. How can I change that?
    - is there a possibility to open the wap browser immediately from a non GUI application, in order to speed it up?

  5. #20
    Nokia Developer Champion
    Join Date
    Oct 2006
    Location
    Bangalore, India
    Posts
    1,572

    Re: launching wap browser with URL

    Hi RGUIA

    I too have tried the same earlier and facing the same problem. The browser is freezing and I have to restart the OS. However its happening at times and not happening at times..... so a little confused....

    Did you get any solutions to it...

    Would be great if you could help...

    Thanks in advance

    Amit Kankani
    India

    Quote Originally Posted by rguia
    I tried what was suggested by the "Utilizing External Application Views" for launching WAP but it doesn't seem to work. If it is not currently running, it will launch WAP but it will just freeze and you have to re-boot.

    If WAP is running, I get a "System Error" but it still launches the new URL.

    Any ideas or thoughts? Below is a snippet of code of how I am implementing it.

    if(iSettings->iAppModuleList[iSelectedIndex]->iDisplayName == _L("WAP"))
    {
    HBufC* param = HBufC::NewLC( 20 );
    param->Des().Copy(iSettings->iAppModuleList[iSelectedIndex]->iDocument);
    TUid id(TUid::Uid(AppUid));
    TApaTaskList taskList (CEikonEnv::Static()->WsSession());
    TApaTask task = taskList.FindApp(id);

    if(task.Exists())
    {
    HBufC8* param8 = HBufC8::NewLC(param->Length());
    param8->Des().Append(*param);
    task.SendMessage(TUid::Uid(0), *param8);
    CleanupStack::PopAndDestroy();
    }
    else
    {
    RApaLsSession appArcSession;
    User::LeaveIfError(appArcSession.Connect());
    TThreadId id;
    appArcSession.StartDocument(*param, TUid::Uid(AppUid), id);
    appArcSession.Close();
    }

    CleanupStack::PopAndDestroy();
    }

  6. #21
    Nokia Developer Champion
    Join Date
    Oct 2006
    Location
    Bangalore, India
    Posts
    1,572

    Re: launching wap browser with URL

    Quote Originally Posted by rguia
    I tried what was suggested by the "Utilizing External Application Views" for launching WAP but it doesn't seem to work. If it is not currently running, it will launch WAP but it will just freeze and you have to re-boot.

    If WAP is running, I get a "System Error" but it still launches the new URL.

    Any ideas or thoughts? Below is a snippet of code of how I am implementing it.

    if(iSettings->iAppModuleList[iSelectedIndex]->iDisplayName == _L("WAP"))
    {
    HBufC* param = HBufC::NewLC( 20 );
    param->Des().Copy(iSettings->iAppModuleList[iSelectedIndex]->iDocument);
    TUid id(TUid::Uid(AppUid));
    TApaTaskList taskList (CEikonEnv::Static()->WsSession());
    TApaTask task = taskList.FindApp(id);

    if(task.Exists())
    {
    HBufC8* param8 = HBufC8::NewLC(param->Length());
    param8->Des().Append(*param);
    task.SendMessage(TUid::Uid(0), *param8);
    CleanupStack::PopAndDestroy();
    }
    else
    {
    RApaLsSession appArcSession;
    User::LeaveIfError(appArcSession.Connect());
    TThreadId id;
    appArcSession.StartDocument(*param, TUid::Uid(AppUid), id);
    appArcSession.Close();
    }

    CleanupStack::PopAndDestroy();
    }
    I am too facing the same problem of BROWSER freezing, please help...

  7. #22
    Registered User
    Join Date
    Jul 2008
    Posts
    4

    Smile Re: launching wap browser with URL

    hi there - i am new to this stuff and downloaded the zip file...how do I get it working on the phones. Whats the deployment procedure...thanks a ton....

  8. #23
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,674

    Re: launching wap browser with URL

    Search for getting started in the Wiki as a first try. FN main site also has such section (www.forum.nokia.com Documentation/Symbian C++, Getting started).

  9. #24
    Registered User
    Join Date
    Jul 2008
    Posts
    4

    Re: launching wap browser with URL

    is there not like an exe that you download to your phone that does this all for you or is it a bit more complicated. I just want to install an app on the phone that opens a pre-defined URL...again is this more complicating than it sounds?

  10. #25
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,674

    Re: launching wap browser with URL

    I do not know "the zip file" you have downloaded, it may or may not contain a .sis/.sisx file which is installable on the device.

  11. #26
    Registered User
    Join Date
    Jul 2008
    Posts
    4

    Re: launching wap browser with URL

    no - it was downloaded from the fourm...LaunchWAP.zip. It has a few folders and in the install folder it has a .pkg file. What is confusing is do i upload the directories to the server, connect to the .pkg file with my phone and it all happens automatically...tried it and it just downloaded the file....Sorry for all the questions I am a virgin C++ developer...

  12. #27
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,674

    Re: launching wap browser with URL

    Then LaunchWAP.zip contains only the source code and you have to build it with a properly configured environment. Though some Symbian devices are capable of opening and browsing .zip files, they will not compile and run the source code contained in that.

  13. #28
    Registered User
    Join Date
    Jul 2008
    Posts
    4

    Re: launching wap browser with URL

    ok now that makes sense...u dont perhaps know what app or SDK i need to complie this into a .jar file or whatever file it needs to work?

  14. #29
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,674

    Re: launching wap browser with URL

    You should really check a Getting started guide. SDK selection depends on your device. The example may also contain some information about its SDK-compatibility.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×