×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Apr 2010
    Posts
    28

    Mobile Application

    Hi ,
    I am working on mobile applications using lwuit.
    I am unable to display image.
    i am using pulsar eclipse, wireless toolkit and also sprint toolkit.

    i am using like this :-
    image = Image.createImage("\\photos\flower.png");
    Label imglabel=new Label(image);
    f.addCommand(imglabel);

    The image is stored in the wireless toolkit in folder and path is ==>C:\j2mewtk\2.5.2\appdb\DefaultColorPhone\filesystem\root1\photos.

    In other way i tried the following code:-
    FileConnection fc = (FileConnection) Connector.open(MobilePartt4.DefaultColorPhone+"/img/Duke");

    When i am using the above code i am getting following exception :-

    Running with storage root C:\Documents and Settings\Shanti\j2mewtk\2.5.2\appdb\temp.DefaultColorPhone33
    Running with locale: English_United States.1252
    Running in the identified_third_party security domain
    mageeeeeeeeeeeLabel[x=0 y=0 width=0 height=0, text = , gap = 2]
    java.lang.IllegalArgumentException: no ':' in URL
    at javax.microedition.io.Connector.openPrim(+37)
    at javax.microedition.io.Connector.open(+15)
    at javax.microedition.io.Connector.open(+6)
    at javax.microedition.io.Connector.open(+5)
    at MobilePartt4.startApp(+83)
    at javax.microedition.midlet.MIDletProxy.startApp(+7)
    at com.sun.midp.midlet.Scheduler.schedule(+270)
    at com.sun.midp.main.Main.runLocalClass(+28)
    at com.sun.midp.main.Main.main(+80)



    Can you please help me.

    regards
    shanti
    Last edited by shantisree; 2011-01-20 at 05:17.

  2. #2
    Super Contributor
    Join Date
    Mar 2008
    Location
    The Capital of INDIA
    Posts
    4,328

    Re: Mobile Application

    The way for loading the image should be like this,

    Image image = Image.createImage("/res/baldy.png");
    I wonder if you are following the correct way, try the above one and check,
    Thanks with Regards,

    R a j - The K e r n e l


    Join Delhi-NCR Nokia Developer's Community,

  3. #3
    Registered User
    Join Date
    Apr 2010
    Posts
    28

    Re: Mobile Application

    ya i used above line in my code and stored the image in res folder but it is not working ,and i am using lwuit but not lcdui.
    and i am deploying in eclipse not outside.
    And the above line will not work in lwuit, it is works in lcdui.

  4. #4
    Super Contributor
    Join Date
    Mar 2008
    Location
    The Capital of INDIA
    Posts
    4,328

    Re: Mobile Application

    Quote Originally Posted by shantisree View Post
    ya i used above line in my code and stored the image in res folder but it is not working ,and i am using lwuit but not lcdui.
    and i am deploying in eclipse not outside.
    And the above line will not work in lwuit, it is works in lcdui.
    Can you check the same Here
    Thanks with Regards,

    R a j - The K e r n e l


    Join Delhi-NCR Nokia Developer's Community,

  5. #5
    Registered User
    Join Date
    Apr 2010
    Posts
    28

    Re: Mobile Application

    I have done with that.
    But did not get any solution.
    Please can you send me a sample which can be deployed in eclipse pulsar version.

Similar Threads

  1. Running Mobile application in J2ME WTK via OTA but not in Mobile
    By jayamnkl in forum Mobile Java General
    Replies: 8
    Last Post: 2009-04-21, 08:24
  2. Replies: 34
    Last Post: 2009-04-14, 13:47
  3. Nokia Mobile Application - Block Mobile Number
    By DhavalParikh in forum Mobile Java General
    Replies: 3
    Last Post: 2003-06-12, 02:22

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×