×

Discussion Board

Results 1 to 12 of 12

Thread: Help please!

  1. #1
    Regular Contributor
    Join Date
    Jul 2010
    Posts
    113

    Help please!

    Hello,

    I imported the example project : BCExchanger in to my Eclipse Pulsar ide to get a clear picture of how client-server model works. And the configuration i have selected is S60Emulator.

    But one of the problems i encountered is in importing packages. Almost every import in every class shows that it cannot be resolved. And after selecting the JRE System Library[jre6], all the javax imports in the classes shows it cannot be resolved. What jars should i add? Can anyone please explain me in detail about what caused this and how to solve this problem?

    Thanks in advance!

  2. #2
    Regular Contributor
    Join Date
    Jul 2010
    Posts
    113

    Re: Help please!

    Hello,

    As this project has 3 packages;bcexchanger, bcexchanger.comm, bcexchanger.ui, i faced problems with the import statements as i stated before. So, I added Bluecove jar to this project. This solved the errors with the import statements in all the classes contained in bcexchanger.comm package.

    The remaining two packages bcexchanger, bcexchanger.ui still show import statement errors. All the javax imports are red-lighted.

    Ex: import javax.microedition.pim.Contact;
    import javax.microedition.pim.ContactList;
    import javax.microedition.pim.PIM;
    import javax.microedition.pim.PIMItem;

    This error, i am guessing is because of missing " java ME library [S60 5th Edition sdk v1.0/S60 Emulator]". This particular library is automatically added in all other midlet projects. But in this example project, the added library is JRE System Library[jre6]. I serched for" org.eclipse.mtj.JavaMEContainer", but seems to be missing.


    I am testing this example project in Eclipse pulsar ide integrated with S60 5th edition v1.0 sdk.

    So, can anyone please tell me how to resolve this problem?

    This is the first time i am going to work with Bluetooth application. So, it will be very helpful if somebody gives a correct path!!

    Thanks in advance!

  3. #3
    Super Contributor
    Join Date
    Jun 2003
    Location
    Cheshire, UK
    Posts
    7,395

    Re: Help please!

    You should not have Bluecove or JRE System Library in your class path... these are for Java SE applications, not Java ME. You should use either the library files from the S60 SDK, or from the Java ME SDK.

    Did you create your project as a "MIDlet project"? If you did, it will have an "Application Descriptor" in the project. If not, you have a Java SE project, which is not what you need. In this case, create a new project and start again.

    Graham.

  4. #4
    Regular Contributor
    Join Date
    Jul 2010
    Posts
    113

    Re: Help please!

    Thank you so much for your reply!

    Yes, i created as MIDlet project. But anyway, I will recreate the project and see.

  5. #5
    Regular Contributor
    Join Date
    Jul 2010
    Posts
    113

    Re: Help please!

    Hello,

    I tried creating the project again, and this time i got no errors. Thanks, grahamhughes! But the emulator shows :
    Cannot start inquiry javax.bluetooth.
    BluetoothStateException: Failed to initialise Bluetooth subsystem:Check hardware is present. Error -5 returned.


    Can you please tell what does this mean and how to resolve this?

    Thanks in advance!

  6. #6
    Super Contributor
    Join Date
    Jun 2003
    Location
    Cheshire, UK
    Posts
    7,395

    Re: Help please!

    That means that the emulator does not support bluetooth emulation. Try on a real device.

    Graham.

  7. #7
    Regular Contributor
    Join Date
    Jul 2010
    Posts
    113

    Re: Help please!

    Oh! Thanks for your reply!

    Is there any other way to make it possible? I tried it in S60 Emulator.

    Does sun java wireless toolkit 2.5.2_01 support bluetooth emulation?

  8. #8
    Regular Contributor
    Join Date
    Jul 2010
    Posts
    113

    Re: Help please!

    I checked with S60_5th_Edition_Sdk release notes. They have given, Sending business cards or calendar events via text message
    ("Smart Messaging") is not supported in S60 emulator.


    Does it mean, the emulator will not support only business cards and calender events or no bluetooth emulation at all?

    My requirement is to transfer a text file from mobile to pc. Can you please let me know whether this is possible with S60 Emulator? If not, how about working with sun java wireless toolkit 2.5.2_01?

    Thanks in advance!

  9. #9
    Super Contributor
    Join Date
    Jun 2003
    Location
    Cheshire, UK
    Posts
    7,395

    Re: Help please!

    That phrase relates to sending calendars, etc, by text message (SMS), not bluetooth.

    I forget about WTK 2.5.2 (check the documentation), but Java ME SDK 3.0 does support bluetooth emulation. That is, you can run two emulator sessions, and exchange data between them as if by bluetooth. However, this is emulation; it will not use your bluetooth hardware, and it will not be able to talk to a bluetooth app on your pc.

    If you want to communicate between a mobile app and a desktop app, you will need to put your app on a real device.

    Graham.

  10. #10
    Regular Contributor
    Join Date
    Jul 2010
    Posts
    113

    Re: Help please!

    Oh, Ok. Thank you so much for your help!

  11. #11
    Regular Contributor
    Join Date
    Jul 2010
    Posts
    113

    Re: Help please!

    Hello,

    I used java me sdk for running the Bluetooth chat application demo. But only one emulator is running. The second emulator is not displaying. Can anyone please tell me about how to run two emulator sessions using java me sdk3.0?

    Also, when i used sun java wireless toolkit 2.5.2_01 integrated with Eclipse ide pulsar, i faced the same problem.

    But when sun java wtk is used alone to run and test it works fine with two emulator sessions. Since Bluetooth chat application demo comes along with the sdk, it can be able to run by opening that project. But , it has no text editor for writing the source code and it needs to be installed. So, i have now installed. But can anyone please tell me about how to integrate JEit with sun java wtk and run the emulator sessions?

    Please, help me with answers.

    Thanks in advance!

  12. #12
    Super Contributor
    Join Date
    Jun 2003
    Location
    Cheshire, UK
    Posts
    7,395

    Re: Help please!

    Did you check the SDK 3.0 documentation?

Similar Threads

  1. Replies: 18
    Last Post: 2009-06-10, 08:28
  2. please please help me show contents of file txt
    By finalcomp in forum Symbian
    Replies: 1
    Last Post: 2006-07-17, 12:36
  3. please please help me show contents of file txt
    By finalcomp in forum Symbian User Interface
    Replies: 7
    Last Post: 2006-07-16, 20:44
  4. Nokia 7280 Problem. Please please please help...
    By zekmaster in forum Mobile Java General
    Replies: 4
    Last Post: 2005-11-10, 20:20
  5. Replies: 1
    Last Post: 2003-05-23, 16:30

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×