×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Jan 2011
    Location
    Russia, Saint-Petersburg
    Posts
    38

    How to install OpenC on Nokia SDK 1.0.2?

    Hello everybody!

    Please, help me with my problem. I have installed Nokia SDK 1.0.2 on my computer (under windows XP operating system). I've downloaded OpenC archive from http://bit.ly/openc. I am trying to install it (unpacked, launched setup.exe), but the installer doesn't see any symbian SDKs... I need OpenC because of openSSL (i need to use it on symbian ^3).

    Or there is no support on symbian ^3 by OpenC? What should i do then? How to use openSSL under symbian ^3?

    Thank you very much for reply!
    Last edited by evgeny_123; 2011-01-27 at 10:49.

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,567

    Re: How to install OpenC on Nokia SDK 1.0.2?

    So far you can not install anything to the Symbian^3 SDK, it has built-in everything, Open C, Open C++ and Qt.
    However if you need the separate Open C/C++ examples and documentation, you will have to install one of the supported SDK-s, then install Open C/C++ into that one. The examples and the documentation are going to be located in the nokia_plugin folder created parallel to the epoc32 folder.

  3. #3
    Registered User
    Join Date
    Jan 2011
    Location
    Russia, Saint-Petersburg
    Posts
    38

    Re: How to install OpenC on Nokia SDK 1.0.2?

    Thanks for reply!
    No, i don't need OpenC/C++ examples... But i need OpenSSL library. Are you sure that it is in NokiaQtSDK/Symbian directory? And do you know where i can find it and how it is called?

    ----
    UPD

    Oh, didnt't catch.... Are you talking about "Symbian^3 SDK" or "Nokia Qt SDK 1.0.2"?
    Last edited by evgeny_123; 2011-01-27 at 10:50.

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,567

    Re: How to install OpenC on Nokia SDK 1.0.2?

    Quote Originally Posted by evgeny_123 View Post
    Are you talking about "Symbian^3 SDK" or "Nokia Qt SDK 1.0.2"?
    I could also ask that from you :-).
    I was talking about the Symbian^3 SDK, and it contains libssl.lib (and libssl.dso).
    However now I understand what you meant on "Nokia SDK 1.0.2", just did not recognize it without the Qt. And no, it does not contain libssl.lib.
    You may want to consider asking this question on the Qt-boards too (http://discussion.forum.nokia.com/fo...lay.php?219-Qt, perhaps in Qt for Symbian or the SDK-s and Tools board).
    It may be possible to simply copy the missing files from a Symbian/S60 SDK, but I do not know for sure.

  5. #5
    Registered User
    Join Date
    Jan 2011
    Location
    Russia, Saint-Petersburg
    Posts
    38

    Re: How to install OpenC on Nokia SDK 1.0.2?

    =) Yeah, sorry... I was talking about Nokia Qt SDK... Just forgot to add "Qt" ((

    I've already tried to add missing files from Symbian ^3 SDK (0.9) to Nokia Qt SDK (1.0.2)... And there was no result.... I have the same "undefined symbols" while linking the project.... Ok thanks, i'll try to ask there.

    I don't understand why in NokiaQtSDK\Symbian there _is_ header files of OpenSSL, but there is no this library (((((

    So is there a way to install OpenC/C++ on my Nokia Qt SDK 1.0.2?

  6. #6
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: How to install OpenC on Nokia SDK 1.0.2?

    The Nokia Qt SDK was designed with Qt development in mind, and Qt only. To support the build process it does have a Symbian SDK inside (based in fact on the S60 5th Edition SDK, aka Symbian^1) but many of the OS libraries have been stripped down. The Qt SDK v1.1 should have better support at least for the S^3 based SDK core, but I'm not sure if the S^1 one has been updated and thus if it contains the library you need.

    As for installing additional APIs in the SDK that should be rather easy (although generally speaking mixing SDK components is not recommended). Make sure to take the content from the S60 5th Edition SDK or from OpenC/C++ 1.6 (that's the version used by Qt 4.6.3). Then add the library to the *.pro, call qmake and verify that the generated MMP does include the corresponding library statement.

    To ensure that in the future you don't face the same problems, make sure to create a bug report at http://bugreports.qt.nokia.com and ask for the full OpenC support to be included in the SDK.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. How to install Java SDK on S60
    By cryptyritu in forum Mobile Java Tools & SDKs
    Replies: 9
    Last Post: 2011-01-27, 09:05
  2. Replies: 6
    Last Post: 2008-06-30, 09:53
  3. Unable to install Nokia SDK on Netbeans
    By Transcend3nt in forum Mobile Java General
    Replies: 1
    Last Post: 2008-05-06, 05:36
  4. How to install Nokia SDK 3.0 on Windows 2003?? HELP
    By s.piadlowski in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2006-04-13, 17:55
  5. 3510 SDK - how to install on Netbeans 4.1
    By leopardo.f in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2005-10-11, 11:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •