×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    Registered User
    Join Date
    Jan 2011
    Posts
    192

    Question Smart installer problem

    Hi,
    I am trying to make a smart installer sis of my application.
    i used this command :

    make installer_sis QT_SIS_CERTIFICATE=mycer.cer QT_SIS_KEY=mykey.key

    and the installer.sis is created,
    but when i run it on my device, it gives me the following error :

    package qtmobility(0x2002AC89 v1.01.0) is not available for this device

    so what to do ? i surfed the web and i didn't find a case like this.
    any help???

    Thank you
    Regards,

  2. #2
    Super Contributor
    Join Date
    Mar 2008
    Posts
    1,481

    Re: Smart installer problem

    Hi,
    What version of QtSDK you are using?

  3. #3
    Registered User
    Join Date
    Jan 2011
    Posts
    192

    Re: Smart installer problem

    Quote Originally Posted by mahbub_s60 View Post
    Hi,
    What version of QtSDK you are using?
    QT 4.7.0 and QTmobility 1.1.0

  4. #4
    Super Contributor
    Join Date
    Mar 2008
    Posts
    1,481

    Re: Smart installer problem

    You can take a look in the table what is supported and what is not from this link
    http://wiki.forum.nokia.com/index.ph...er_for_Symbian

    I can reproduce this error in N97 with QtSDK 1.1, I am checking if there any solution for this,

  5. #5
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: Smart installer problem


  6. #6
    Registered User
    Join Date
    Jan 2011
    Posts
    192

    Re: Smart installer problem

    Quote Originally Posted by divanov View Post
    hi..i read these documents..but i dont know if it is my case
    when i run the smart installer and check my device..i noticed that the required sis files are downloaded to the device(qt installer, qt , qt mobility, sqlite etc...) but it is stopped i guess when reaching the installation of the application..i tried to install the application manually..it works butt didnt open
    the application worked well on n97 and now i am trying to install it on c5 or e75 and the aplication is not opening on both devices..
    please i need your help.

    Regards

  7. #7
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Smart installer problem

    I am a bit confused what it means to "run" a SIS file and where said error message is displayed.

    The Smart Installer generates log files under c:\logs\ADM if this directory exists on the device. Please create it using a file manager and then run the Smart Installer driven installation again. Collect the log files and if they are not clear, post them here.

    However, Qt 4.7 is not available on the Smart Installer server, nor does Qt Mobility, so while the error may be strange in some context it may in fact simply signal that the needed Qt package is not available.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  8. #8
    Registered User
    Join Date
    Jan 2011
    Posts
    192

    Re: Smart installer problem

    Quote Originally Posted by ltomuta View Post
    I am a bit confused what it means to "run" a SIS file and where said error message is displayed.

    The Smart Installer generates log files under c:\logs\ADM if this directory exists on the device. Please create it using a file manager and then run the Smart Installer driven installation again. Collect the log files and if they are not clear, post them here.

    However, Qt 4.7 is not available on the Smart Installer server, nor does Qt Mobility, so while the error may be strange in some context it may in fact simply signal that the needed Qt package is not available.
    i mean by "run" the sis on the device, that when i open the installer.sis on the device, the connection to the internet is established in order to install the approriate qt packages on the phone, but after 2 mins of installing it give me the previous error qbout qtmobility.
    i didn't resolve yet my issue.

  9. #9
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Smart installer problem

    Please collect the logs and let's have a look at them.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  10. #10
    Super Contributor
    Join Date
    Mar 2008
    Posts
    1,481

    Re: Smart installer problem

    Hi
    I added logs
    Attached Files Attached Files

  11. #11
    Registered User
    Join Date
    Jan 2011
    Posts
    192

    Re: Smart installer problem

    Quote Originally Posted by ltomuta View Post
    Please collect the logs and let's have a look at them.
    There is no logs file under the C: directory, and i am not able to create it a new folder there. when trying to create a folder under c: on the phone, the following error appear :
    "operation failed.a file or folder you are trying to create, rename , or delete is protected from access"

  12. #12
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Smart installer problem

    Quote Originally Posted by mahbub_s60 View Post
    Hi
    I added logs
    The logs indicate that the Qt package was not found, which is fine since as said already it is indeed missing from Samrt Installer's servers. Why that gets converted into a "Qt Mobility" issue (and why that error is shown to begin with) is a different story.

    Install Qt and Webkit manually (and eventually the Mobility), then installing the app with Smart Installer package will work too.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  13. #13
    Super Contributor
    Join Date
    Mar 2008
    Posts
    1,481

    Re: Smart installer problem

    Try to use File browser from drjukka.com, any way I have stored the logs also

  14. #14
    Registered User
    Join Date
    Jan 2011
    Posts
    192

    Re: Smart installer problem

    it seems that i cannot use Qt 4.7 and Qt mobility 1.1.0 in order to do a smart installer.

    Can i use Qt 4.6.3 and Qt mobility 1.1.0 ? or should i use the Qt 4.6.3 wiith the mobility 1.0.2 ???

  15. #15
    Super Contributor
    Join Date
    Mar 2008
    Posts
    1,481

    Re: Smart installer problem

    This is correct, we have to wait until Qt 4.7 is available to server.
    See supported Qt/Qt mobility from this link
    http://wiki.forum.nokia.com/index.ph...er_for_Symbian

Similar Threads

  1. Smart installer 1.1 packaging
    By mamaji4 in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 2
    Last Post: 2011-01-07, 13:58
  2. smart installer always have problem
    By xhsoldier in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 2
    Last Post: 2010-11-17, 01:55
  3. problem with smart installer
    By xhsoldier in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 2
    Last Post: 2010-11-02, 11:19
  4. RDA and smart installer
    By Guilo19 in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 1
    Last Post: 2010-06-18, 22:34

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×