×

Discussion Board

Results 1 to 12 of 12
  1. #1
    Registered User
    Join Date
    May 2009
    Location
    Russia, Spb
    Posts
    5

    [moved] phone install problem

    i sucsecsfull install my aplication on my n97 but when i installing this on 5800 i can see Error, but progress bar was full on 2/3

    sorry for my badly english
    Last edited by dimzhur; 2011-01-28 at 13:50.

  2. #2
    Nokia Developer Champion
    Join Date
    Jun 2008
    Location
    Noida,India
    Posts
    4,025

    Re: phone install problem

    ok , so what error did you got while installing on 5800? Also, is your application self-signed/open signed online/signed by developer certificate?

  3. #3
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,689

    Re: phone install problem

    Check if you can get a detailed error message: http://blogs.forum.nokia.com/blog/lu...er-debug-guide
    It is a good idea to set your device to English for the experiments, and include the exact messages in your question.

  4. #4
    Registered User
    Join Date
    Dec 2008
    Posts
    4

    Re: phone install problem

    i don`t see any detail about error, but i can install this on 5730 without autostart after inslall

  5. #5
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: phone install problem

    does the autostart work in any other device ?

  6. #6
    Registered User
    Join Date
    May 2009
    Location
    Russia, Spb
    Posts
    5

    Re: phone install problem

    yes, it worked on my n97

  7. #7
    Nokia Developer Champion
    Join Date
    Jun 2008
    Location
    Noida,India
    Posts
    4,025

    Re: phone install problem

    please be very specific about your query, one liners won't help you out. what exactly does the error message appears when your try installing the application on 5800?

  8. #8
    Registered User
    Join Date
    Dec 2008
    Posts
    4

    Re: phone install problem

    when i try installing on 5800 i can see just alert (Error, aplication don`t can install, without any codes )

    for autostart i use this code
    "$(EPOCROOT)Epoc32\release\gcce\urel\prv_0xE1BE2248.exe" -"!:\system\apps\10003a3f\prv_0xE1BE2248.exe",FR,RI

  9. #9
    Registered User
    Join Date
    Feb 2007
    Location
    India
    Posts
    1,128

    Re: phone install problem

    For Auto start you should be use like as

    "$(EPOCROOT)Epoc32\release\gcce\urel\prv_0xE1BE2248.exe" -"!:\sys\bin\prv_0xE1BE2248.exe",RI

  10. #10
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,689

    Re: phone install problem

    Quote Originally Posted by dimzhur93 View Post
    when i try installing on 5800 i can see just alert (Error, aplication don`t can install, without any codes )
    The installer has no such error message. Get the English message, and/or pick the English translation of the message from the suggested blog entry. Like "Unable to install", etc.
    for autostart i use this code
    That code can not work. Starting from S60 3rd edition, .exe files are to be placed in \sys\bin folder, the kernel will not load executables from any other location.
    If this starter facility appears to work on any device, that device probably has a prv_0xE1BE2248.exe in its \sys\bin folder, and that might get started.

  11. #11
    Registered User
    Join Date
    Dec 2008
    Posts
    4

    Re: phone install problem

    Quote Originally Posted by wizard_hu_ View Post
    The installer has no such error message. Get the English message, and/or pick the English translation of the message from the suggested blog entry. Like "Unable to install", etc..
    Yea, was it message, but on russian, and i badly translate

    thnks for you ask

    i write
    "$(EPOCROOT)Epoc32\release\gcce\urel\prv_0xE1BE2248.exe" -"!:\sys\bin\prv_0xE1BE2248.exe",RI
    and now at my n97 i can see "Unable to install" then progress bar was full at 5/6
    Last edited by dimzhur93; 2011-01-28 at 18:37.

  12. #12
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: phone install problem

    dimzhur93, if the language is a problem, please use the Russian Developer Forum - Форум Российских разработчиков, there are Russian speaking developers there ready to help you.

    With this type of errors, there are a few easy thing to try.
    1) Remove the FR, RI flags
    The installation may fail because the application is executed but it panics and that causes the installer to abort.
    2) Comment out the file copying parts of the PKG script one by one
    This way you can find out at which stage the installation fails and then you can focus on that component to understand what there might be wrong with it.
    3) Post the entire PKG script here
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. [Moved]unable install in the phone
    By ragu. in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 16
    Last Post: 2010-08-27, 08:04
  2. [Moved] "Unable to install. Component is built in." on N86 8mp nokia phone
    By chandran.biju007 in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 3
    Last Post: 2010-03-22, 16:45
  3. [moved] unable to install problem
    By nehasaxena in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 10
    Last Post: 2009-10-16, 12:44
  4. Replies: 1
    Last Post: 2008-12-28, 19:57
  5. [moved] Install problem (was Re: Ask The Expert on Device Specifications)
    By rider76 in forum General Development Questions
    Replies: 4
    Last Post: 2008-07-19, 19:33

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×