×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Jan 2008
    Posts
    6

    Can I use Qt to develop app for any Series 60 v3 and v5 devices?

    Hi all,
    As Nokia has released the Qt 1.0 SDK, can someone tell me that does it support all S60 V3 and V5 devices? e.g. E61i, E71, E90, N97 and so on. I have searched the whole wiki but no pages could tell me the support device list of Qt SDK 1.0.
    Hope the answer is yes, since I don't want to touch the Symbian platform SDK (there are too many versions) and Symbian C++ (so odd dialect) any more.

    And if the answer is yes, does it mean I just need to install one SDK (Qt SDK) and I never need to intall Symbian platform SDK, ActivelPerl and other packages?

    Thanks in advance!

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Can I use Qt to develop app for any Series 60 v3 and v5 devices?

    No. ideally you donot need the Symbian SDK .. you can install only "Nokia Qt SDK".

    but that said it all depends what you want to do in your application .. in most of the common applications you donot need Symbian SDK .. but in particular cases you might have to.

  3. #3
    Registered User
    Join Date
    Jan 2008
    Posts
    6

    Re: Can I use Qt to develop app for any Series 60 v3 and v5 devices?

    Thanks shkmar_rao, it is really cool.
    Sounds if I want to use some features that are highly related to a specific platform, I still need to install the Symbian PSDK. Can I have Qt SDK and Symbian PSDK both intsalled on the same machine?

  4. #4
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Can I use Qt to develop app for any Series 60 v3 and v5 devices?

    yes . Nokia Qt SDK works completely isolated from S60 SDKs installed so it is safe to use other SDKs.

  5. #5
    Nokia Developer Expert
    Join Date
    Jun 2008
    Location
    Brisbane, Australia
    Posts
    18

    Re: Can I use Qt to develop app for any Series 60 v3 and v5 devices?

    You can target v3 and v5 devices, but your users will just have to install Qt packages as well.
    Code Monkey, QtMobility, Nokia

  6. #6
    Registered User
    Join Date
    Jan 2008
    Posts
    6

    Re: Can I use Qt to develop app for any Series 60 v3 and v5 devices?

    Thanks guys.
    After some investigation, I found that Qt was supported from S60 3.1 (3rd FP1), because I can only found Qt runtime package for S60 3.1 platform, S60 3.0 (a.k.a initial release) was not currently supported.

  7. #7
    Registered User
    Join Date
    Dec 2006
    Posts
    2,280

    Re: Can I use Qt to develop app for any Series 60 v3 and v5 devices?

    That is correct, however also look at the supported devices list for Qt in the Ovi Store, it is much shorter, since I assume you also want to deploy and or sell the app to the widest possible group of users.
    https://www.forum.nokia.com/Distribu...xhtml#article1

Similar Threads

  1. Can i develop Midlet app to support all platform?
    By chaoraksa in forum Mobile Java General
    Replies: 6
    Last Post: 2009-03-23, 08:35
  2. Enable error code on series 60 v3 devices?
    By __usr in forum Symbian
    Replies: 1
    Last Post: 2006-07-12, 17:45
  3. How to develop Screensaver for 60 series?
    By jjump in forum Streaming and Video
    Replies: 18
    Last Post: 2006-07-08, 12:18
  4. Telephone app UID on Series 60 v3
    By anumeets in forum Symbian
    Replies: 3
    Last Post: 2006-06-26, 15:09
  5. Replies: 1
    Last Post: 2004-02-19, 18:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×