×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    May 2009
    Posts
    18

    GCCE plugin to a Qt for Symbian port (compiled in ARMV5)

    Hello guys,
    I am wrote a plugin to be loaded by one of the Qt port components but I am facing a problem having the plugin loaded on hardware (it is working on emulator):
    The plugin is compiled for GCCE and the ports binaries are ARMV5 , could this be the problem?

    I already checked the capabilities , UIDs and correct location of the plugin and its stub.

  2. #2
    Registered User
    Join Date
    Dec 2006
    Posts
    2,280

    Re: GCCE plugin to a Qt for Symbian port (compiled in ARMV5)

    No, not likely. GCCE and the RVCT compiler both produce compatible binaries (following the ARM ABI specification).

  3. #3
    Registered User
    Join Date
    Dec 2006
    Posts
    2,280

    Re: GCCE plugin to a Qt for Symbian port (compiled in ARMV5)

    If the compiler is not the latest GCCE and you have writeable static data in your plug-in DLL then that might possibly cause the problem. Make sure the GCCE version is at least 4.4.1 (I hope I remembered that version number correctly).

Similar Threads

  1. How to port QT (in symbian) to Blackberry?
    By shrawan0786 in forum Qt
    Replies: 15
    Last Post: 2012-12-04, 09:53
  2. Replies: 2
    Last Post: 2010-10-22, 07:15
  3. Compiling QT Mobility GCCE or ARMV5?
    By AhmedAndre in forum [Archived] Qt Mobility Project
    Replies: 6
    Last Post: 2010-06-15, 10:05
  4. Replies: 3
    Last Post: 2009-12-11, 02:36
  5. How to use GCCE compiled DLL?
    By ash_bhatia in forum Symbian
    Replies: 4
    Last Post: 2006-06-01, 16:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •