×

Discussion Board

Results 1 to 12 of 12
  1. #1
    Regular Contributor
    Join Date
    Dec 2010
    Posts
    228

    Question Problem of packaging the sis file with smart installer

    hi everyone,

    i am facing a problem while trying to package my sis file with smart installer and deploy it to the device
    after building the project and the packages ffiles are created ..i am changing the app_installer.pkg line

    #{"App installer"},(0xA000D7CE),1,0,0 to :
    #{"App installer"},(0x2002CCCF),1,0,0
    and replace the c: with ! in the line:
    "C:/qtt/App /app.sis" - "c:\private\2002CCCE\import\app.sis"
    it will become as following
    "C:/qtt/App /app.sis" - "!:\private\2002CCCE\import\app.sis"

    now i run the command line make installer_sis QT_SIS_CERTIFICATE= xxx.cer QT_SIS_KEY=xxx.key

    this command line is creating me the app_installer.sis which is the package file that i should install it to the device

    Now ..when i am trying to install this sis file it is giving me the error :
    package qtmobility(0x2002AC89 v1.01.0) is not available for this device

    can anyone tell me if i am doing something wrong herE?? and how can i resolve this problem
    Thank you for any help
    Last edited by Rondo23; 2011-01-31 at 14:46.

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Problem of packaging the sis file with smart installer

    You are building your application with Qt 4.7 (and eventually Qt Mobility 1.1) but one of the stated limitations of the SDK is that Ovi Store distribution is not possible at the moment and as such there is no need for the smart installer. The Smart Installer itself does not support the Qt 4.7 and Qt Mobility packages (as you can see from http://tinyurl.com/SmartInstaller) and in Qt Creator 2.1-rc1 you can already generate smart installer packages without command line tools.

    All this is resumed in an existing bug report at http://bugreports.qt.nokia.com/browse/QTCREATORBUG-3624 and we're told it should be fixed in the next SDK release.

    If you are not using Qt Mobility, and as a result the error message makes no sense to you, that is caused by a bug in Smart Installer, already reported as well.

    As for a solution: don't use Smart Installer until you are close to being ready with your project and full support for Qt 4.7 is announced by Nokia. Instead, install Qt and Qt Webkit on your device and then run the app from the IDE, it will be installed automatically and run on device.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Regular Contributor
    Join Date
    Dec 2010
    Posts
    228

    Re: Problem of packaging the sis file with smart installer

    Quote Originally Posted by ltomuta View Post
    You are building your application with Qt 4.7 (and eventually Qt Mobility 1.1) but one of the stated limitations of the SDK is that Ovi Store distribution is not possible at the moment and as such there is no need for the smart installer. The Smart Installer itself does not support the Qt 4.7 and Qt Mobility packages (as you can see from http://tinyurl.com/SmartInstaller) and in Qt Creator 2.1-rc1 you can already generate smart installer packages without command line tools.

    All this is resumed in an existing bug report at http://bugreports.qt.nokia.com/browse/QTCREATORBUG-3624 and we're told it should be fixed in the next SDK release.

    If you are not using Qt Mobility, and as a result the error message makes no sense to you, that is caused by a bug in Smart Installer, already reported as well.

    As for a solution: don't use Smart Installer until you are close to being ready with your project and full support for Qt 4.7 is announced by Nokia. Instead, install Qt and Qt Webkit on your device and then run the app from the IDE, it will be installed automatically and run on device.

    Do yo mean that i cant publish my application to ovi store :S?
    yes i am using Qt 4.7 and qt mobility 1.1
    should i install Nokia Qt SDK 1.0.2 and qtMobility 1.0.2 to be able to publish my application with smart installer? will it works if i do that?
    or what should i do to be able to package my application with smart installer?
    Thank you
    Last edited by Rondo23; 2011-02-01 at 05:55.

  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Problem of packaging the sis file with smart installer

    In the page http://www.forum.nokia.com/Develop/Qt/ the Qt SDK v1.1 Technology Preview is annouced with the following note:
    NOTE! Developers wishing to create Qt apps for publication in Ovi store should download and use the Nokia Qt SDK 1.0.
    Then in the download page you have:
    App publication
    You cannot publish apps created with the Qt SDK1.1 technology preview to Ovi Store. Smart Installer doesn't support upgrading devices to the Qt 4.7 and Qt Mobility 1.1 APIs. Only apps built with the Nokia Qt SDK 1.0, using Qt 4.6, can be published through Ovi Store.
    Bottom line: if publishing to Ovi is your short term priority then use Nokia Qt SDK 1.0.2. If you are only now starting to evaluate Qt, or want to experiment with Qt Quick in your spare time, then the Qt SDK 1.1 TP is an option.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  5. #5
    Regular Contributor
    Join Date
    Dec 2010
    Posts
    228

    Re: Problem of packaging the sis file with smart installer

    Thanks ltomuta.. i already have the Nokia Qt SDK 1.0.1 installed...i will install now the Qt 4.6 and try to publish it
    Thank you a lot
    Regards

  6. #6
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Problem of packaging the sis file with smart installer

    Make sure to check for an SDK update, 1.0.2 is the latest version of the Nokia Qt SDK. Also, get the latest smart installer release from http://tinyurl.com/SmartInstaller and replace the one in the SDK with it. Then you are ready to test and eventually publish your app.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  7. #7
    Registered User
    Join Date
    Jan 2011
    Posts
    192

    Re: Problem of packaging the sis file with smart installer

    Quote Originally Posted by ltomuta View Post
    Make sure to check for an SDK update, 1.0.2 is the latest version of the Nokia Qt SDK. Also, get the latest smart installer release from http://tinyurl.com/SmartInstaller and replace the one in the SDK with it. Then you are ready to test and eventually publish your app.
    hello, i am facing a similar problem and i have the Nokia SDK 1.0.2 with the Qt mobility 1.1.0 but getting the same error in this thread("[COLOR="rgb(0, 0, 0)"]package qtmobility(0x2002AC89 v1.01.0) is not available for this device[/COLOR]")
    should the Qt mobility be other then 1.1.0? or does it work with this edition and the error is independent from the Qt mobility version?
    Appreciate any help

  8. #8
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Problem of packaging the sis file with smart installer

    Same problem, same solution. Don't use Smart Installer for applications if they are not ready to be released and don't plan to release applications which are based on packages not supported by the Smart Installer.

    And yes, the same applies to the next guy asking for the same thing
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  9. #9
    Regular Contributor
    Join Date
    Jan 2009
    Location
    Bangalore
    Posts
    52

    Re: Problem of packaging the sis file with smart installer

    Hi Lucian

    I am using Qt 4.7 and qt mobility 1.0.1 can u please update me If I can still continue to publish my app in ovi store???

    Thanks
    rj12info

  10. #10
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Problem of packaging the sis file with smart installer

    Quote Originally Posted by rj12info View Post
    Hi Lucian

    I am using Qt 4.7 and qt mobility 1.0.1 can u please update me If I can still continue to publish my app in ovi store???

    Thanks
    rj12info
    Ovi Store and Smart Installer support only Qt 4.6.3 and Qt Mobility 1.0.2.
    For newer releases you have to wait for the final release of the Qt SDK 1.1. When it will be available, Smart Instaler and Ovi Store support will be opened too.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  11. #11
    Regular Contributor
    Join Date
    Jan 2009
    Location
    Bangalore
    Posts
    52

    Re: Problem of packaging the sis file with smart installer

    Quote Originally Posted by ltomuta View Post
    Ovi Store and Smart Installer support only Qt 4.6.3 and Qt Mobility 1.0.2.
    For newer releases you have to wait for the final release of the Qt SDK 1.1. When it will be available, Smart Instaler and Ovi Store support will be opened too.
    Hi ltomuta

    Small mistake I am using Qt 4.6.3. My app.pkg file says
    (0x2001E61C), 4, 6, 3, {"Qt"}
    So I guess I am using Qt 4.6.3.
    Now I tried to install it on device and Its still giving me the same error "package qtmobility(0x2002AC89 v1.01.0) is not available for this device"
    I have to have Qt mobility for my app. What should I be doing for Qt mobility 1.0.1 or higher to get installed???

    Thanks
    rj12info
    Last edited by rj12info; 2011-02-25 at 09:04.

  12. #12
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Problem of packaging the sis file with smart installer

    Quote Originally Posted by rj12info View Post
    I have to have Qt mobility for my app. What should I be doing for Qt mobility 1.0.1 or higher to get installed???
    Wait for it to become available, as part of the Qt SDK 1.1 release, and then supported by the Ovi Store.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. Smart Installer not recognising QT.sis stub file
    By shadowninty in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 5
    Last Post: 2011-01-11, 07:44
  2. Smart installer 1.1 packaging
    By mamaji4 in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 2
    Last Post: 2011-01-07, 13:58
  3. problem with smart installer
    By xhsoldier in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 2
    Last Post: 2010-11-02, 11:19
  4. Where is the Ovi-Certified smart installer sis
    By tamhanna in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 8
    Last Post: 2010-07-02, 20:01

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×