×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 16
  1. #1
    Regular Contributor
    Join Date
    Jan 2011
    Posts
    122

    "General OS-related error" when deploying in N8

    Hello,

    I'm trying to run my app to the device(N8). At first, I was getting "Please start App TRK on COM5". Then based from http://www.forum.nokia.com/Develop/Q.../Step_3.xhtml:

    Install and configure the TRK debugging application on the device

    Use the shortcut in the Start Menu to install the TRK application (StartMenu > Nokia Qt SDK -Beta release > Symbian > Install TRK to Symbian device). Then select the Symbian device platform that matches your device.

    As an alternative, you can navigate to <NokiaQtSDK_install_path>\Symbian\sis and select the compatible TRK application (for example, Symbian^3_app_trk_3_2_7.sisx).
    I installed C:\NokiaQtSDK\Symbian\sis\Symbian^3_app_trk_3_2_7.sisx. (I believe for N8 it's Symbian^3.) Now I no longer get the "Please start App TRK on COM5" but a different error:

    Executable file: 10994 2011-02-03T19:43:56 C:\NokiaQtSDK\Symbian\SDK\epoc32\release\gcce\udeb\GraphicsViewDemo.exe
    Package: 10756 2011-02-03T20:44:27 C:\NokiaQtProjects\fromTraining\sample\GraphicsViewDemo\GraphicsViewDemo.sis
    Deploying application to 'Nokia N8-00 USB Serial Port (COM5)'...
    Copying installation file...
    Installing application...
    Starting application...
    Could not start application: General OS-related error
    Finished.

    I'm using Qt Creator 2.0.1 Based on Qt 4.7.0(32 bit). Run settings is: http://img818.imageshack.us/img818/4697/runsettings.jpg

    Please help I'm stuck at this part.
    Last edited by vilmavaliente; 2011-02-03 at 13:07.

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169

    Re: "General OS-related error" when deploying in N8

    you could either try manually installing the GraphicsViewDemo.sis into the device, or try disabling the silen instalaltion from the application settings. Then you should be able to get more meaningfull error message that might help determining the actual cause.

  3. #3
    Regular Contributor
    Join Date
    Jan 2011
    Posts
    122

    Re: "General OS-related error" when deploying in N8

    By manual installation you meant, double clicking the .sis from the device? I already tried that. It asks me to complete the installation on my device, and I did. The installation is successful(even if I install it from the OVI, still successful), but I still can't run the app on the device using Qt Creator. I also can't find the app icon to try and run it on the device.

    How do you disable the silent installation of the application? i cant find the app icon. ive been browsing the device, cant find it.

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169

    Re: "General OS-related error" when deploying in N8

    Basically just install it manually to same drive that the Creator build settings are set it to be installed. And then see whether it is actually running in the device. You might get the error also if the application would crash on start up (though it should really give different error then)

    For the buils settings, click the "projects" tab on the left side and then click the "Run" button on symbian.

  5. #5
    Regular Contributor
    Join Date
    Jan 2011
    Posts
    122

    Re: "General OS-related error" when deploying in N8

    The build settings point it to C:\NokiaQtProjects\fromTraining\sample\GraphicsViewDemo. There's a graphicsviewdemo.sis file in there, and I run it, it is successfully installed in the device. It's not crashing cause it's not even loading after clicking Run button.

  6. #6
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169

    Re: "General OS-related error" when deploying in N8

    then if it is indeed installed into the device. then find the icon for the application from the device and run it from there. And do check the panic code: http://wiki.forum.nokia.com/index.ph...ded_panic_code for any possible crashes.

  7. #7
    Regular Contributor
    Join Date
    Jan 2011
    Posts
    122

    Re: "General OS-related error" when deploying in N8

    I was able to find the app and the .sis file in the device. But I can't run the app, nothing happens. No prompt or anything, just nothing. I manually installed the .sis in the device, and it was intalled successfully. And I tried running the app again, still nothing happens. I also tried one of the sample programs "Animated Tiles" and it won't run.

    Maybe there's something wrong in my development environment? I only installed Nokia_Qt_SDK_Win_offline_v1_0_2_en.exe and qt-win-opensource-4.7.1-mingw.exe. There's a zip file that we're told to use as well with qt-mobility-symbian-opensource-1.1.0 folder in it, but I can't remember where to save it once extracted. But even without it, I can use desktop and simulator to run my program so I just left it. Do you know where should I put that folder? Or what to do with it? Maybe that can solve my problem. I can't find an instruction where to put it. I got that from:

    http://qt.nokia.com/products/qt-addons/mobility
    Source and binary Symbian .zip - qt-mobility-symbian-opensource-1.1.0.zip

  8. #8
    Regular Contributor
    Join Date
    Jan 2011
    Posts
    122

    Re: "General OS-related error" when deploying in N8

    Ok, I uninstalled and reinstalled my symbian environment, and still, I'm getting the:

    Executable file: 113876 2011-02-05T10:10:34 C:\NokiaQtSDK\Symbian\SDK\epoc32\release\gcce\udeb\animatedtiles.exe
    Package: 115024 2011-02-05T10:13:27 C:\NokiaQtSDK\Examples\4.6\animation\animatedtiles\animatedtiles.sis
    Deploying application to 'Nokia N8-00 USB Serial Port (COM5)'...
    Copying installation file...
    Installing application...
    Starting application...
    Could not start application: General OS-related error
    Finished.

    And now, the N8 displayed battery low, and died. Even though I charge it, it won't turn on. So far my development in Nokia Qt has been hell. Never had deployment nor development problem with VS before. It's ok if I'm too dumb to do things but I'm following the guide that Qt provided in its site and im still getting this neverending problems. What's most disappointing is, the problems don't just happen to me. Others experienced it as well, and most of it are still unanswered.
    Last edited by vilmavaliente; 2011-02-05 at 04:23.

  9. #9
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169

    Re: "General OS-related error" when deploying in N8

    just recharge the device. Then you could see that you have the latest Qt SDK, and instaa all of the S^3 sis files for Qt & TRK that are shipped with the SDK. Then if the application still fails with the "General OS-related error". Then do check the link I gave on e more time.

    if the manual installation from the device is not giving any errors, then you should be able to start the application by clicking its icon. And if it still appears not to start, then do install my Y-Tasks and use the crash monitor (free self-signed version is ok), it will always get the process exit code.

    Also please make sure you are building for Symbian^3 target.

  10. #10
    Regular Contributor
    Join Date
    Jan 2011
    Posts
    122

    Re: "General OS-related error" when deploying in N8

    I already tried that. I saw the app icon on the device, double-clicked it, nothing happened.

    I had these installed:
    - StartMenu > Nokia Qt SDK > Symbian > Install Qt to Symbian device
    - StartMenu > Nokia Qt SDK > Symbian > Install QtMobility to Nokia N8 device
    - StartMenu > Nokia Qt SDK > Symbian > Install TRK to Symbian device > TRK Symbian^3

    all installations were successful. I keep on getting the General OS-related error.

    Unfortunately, I can't test using the device since the N8 wont turn on anymore. The device is still plugged to my laptop for more than an hour now, it still wont turn on.

  11. #11
    Super Contributor
    Join Date
    Oct 2008
    Location
    INDIA
    Posts
    2,326

    Re: "General OS-related error" when deploying in N8

    "General OS related error" is like common error..

    This is error is faced by so many people, and asked in this forum also, You can search with that word in the wiki.

    Best regards,

  12. #12
    Regular Contributor
    Join Date
    Jan 2011
    Posts
    122

    Re: "General OS-related error" when deploying in N8

    The thing is, why am I getting errors when I just followed steps 1,2 and 3 from https://www.forum.nokia.com/Develop/Qt/Getting_started/? Of course I've searched from the forum regarding this, and tried applying their solutions which I thihk is similar to what I'm experiencing, but still I'm getting the same error.

    And now that the device battery is low, i cant turn it on. I already searched how to do that and guess what I've found, people suggesting to have it repaired to the nearest nokia service center. I just loaned this device from nokia. The weird part is, i only used it a couple times and it's always plugged to my computer when i do use it, I saw it charging, how come it still went low on battery? I saw it prompted for battery low and after that it died. Been charging it now for couple of hours, when i try to turn it on, still dead. When I press the power button, the white led blinks at the left side near the cable slot.

  13. #13
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169

    Re: "General OS-related error" when deploying in N8

    Try charging it on a charger instead. Anyway, I suppose you did not try the Y-Tasks, since it will always get the process exit code. And as the Qt SDK should do the registration resource files etc ok, the executable should always be executad after clickign the icon. Thus please, just re-try.

  14. #14
    Regular Contributor
    Join Date
    Jan 2011
    Posts
    122

    Re: "General OS-related error" when deploying in N8

    Ok. I will try it as soon as the phone's up. Unfortunately, I don't have N8 charger, Nokia didn't send it. They only sent the phone and the cable. That's all. I don't know anyone who uses N8 so I can't borrow a charger. So charging it on the pc is my only chance, unless I'll send the unit back to Nokia.

    Thanks for trying to help. Really appreciate it.

  15. #15
    Regular Contributor
    Join Date
    Jan 2011
    Posts
    122

    Re: "General OS-related error" when deploying in N8

    symbianyucca, maybe there's something wrong with my installation. When I tried adding Desktop to target projects, it says "Qt version is not properly installed, please run make install"



    I just followed the instructions from https://www.forum.nokia.com/Develop/Qt/Getting_started/. I haven't tried what you suggested below yet, cause OVI can't detect my new device(NOkia sent me a new N8). I need to uninstall Qt first before OVI can detect new phone. I opened a thread regarding that: http://discussion.forum.nokia.com/fo...517#post817517.

Similar Threads

  1. Replies: 6
    Last Post: 2011-02-28, 11:28
  2. Replies: 1
    Last Post: 2009-03-28, 22:52
  3. Replies: 1
    Last Post: 2008-06-05, 07:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×