×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Feb 2009
    Posts
    40

    Problem in building with mobility in Qt SDK 1.1 TP

    There's probably something wrong in my Qt SDK 1.1 TP installation as the KittyApp (code) build fails on Qt 4.7.1 for S^3 target. Seems like mobility is not correctly configured - the build fails in qfeedbackeffect.h that unsuccessfully tries to include qmobilityglobal.h (containing QTM_USE_NAMESPACE etc definitions). However, qmobilityglobal.h does exist under \QtSDK\Symbian\SDKs\Symbian3Qt471\src\global . Any tips for fixing this?

    Same problem on both my machines, Win7 64-bit and WinXP 32-bit.

    Compile output: http://qt.pastebin.com/A6X7gcQF

    Maybe the output doesn't help much but in Qt creator opening qfeedbackeffect.h from the Build Issues pane highlights that #include "qmobilityglobal.h" cannot be resolved, and thus the QTM_* macros are undefined. This probably causes the errors in compile output starting from line 154.

    Has anyone experienced similar problem?

  2. #2
    Nokia Developer Moderator
    Join Date
    Oct 2009
    Posts
    4,326

    Re: Problem in building with mobility in Qt SDK 1.1 TP

    It should be under Qt Mobility include folder, something like this:
    .../include/QtMobility/qmobilityglobal.h
    You can use file search in SDK directory.

  3. #3
    Nokia Developer Expert
    Join Date
    Dec 2004
    Location
    Austin, TX
    Posts
    399

    Re: Problem in building with mobility in Qt SDK 1.1 TP

    Quote Originally Posted by mauso View Post

    Has anyone experienced similar problem?
    See http://bugreports.qt.nokia.com/browse/QTSDK-483 There a patch you can put in until the next update.

  4. #4
    Registered User
    Join Date
    Feb 2009
    Posts
    40

    Re: Problem in building with mobility in Qt SDK 1.1 TP

    Quote Originally Posted by divanov View Post
    It should be under Qt Mobility include folder, something like this:
    .../include/QtMobility/qmobilityglobal.h
    You can use file search in SDK directory.
    The one and only QtMobility folder I could find under SDK dir is \QtSDK\Symbian\SDKs\Symbian3Qt471\epoc32\data\z\resource\qt\imports\QtMobility

    Quote Originally Posted by timm-ah View Post
    See http://bugreports.qt.nokia.com/browse/QTSDK-483 There a patch you can put in until the next update.
    The updated mobility.prf did not fix my build. I think my SDK misses some other parts of mobility too.

    This is all I could find with search 'mobility' under SDK dir: http://dl.dropbox.com/u/9981154/mobilityfiles.jpg

    I've installed all updates available via SDK maintenance tool and used the offline version originally to install SDK.

  5. #5
    Nokia Developer Moderator
    Join Date
    Oct 2009
    Posts
    4,326

    Re: Problem in building with mobility in Qt SDK 1.1 TP

    Do you mean offline version of Qt SDK 1.1 TP and then updates?

  6. #6
    Registered User
    Join Date
    Feb 2009
    Posts
    40

    Re: Problem in building with mobility in Qt SDK 1.1 TP

    Yes, exactly.

    Quite weird if it's only me having this problem with mobility in 1.1 TP.

  7. #7
    Nokia Developer Moderator
    Join Date
    Oct 2009
    Posts
    4,326

    Re: Problem in building with mobility in Qt SDK 1.1 TP

    It's hard to say. There are some other threads which might describe the same issue.

  8. #8
    Registered User
    Join Date
    Feb 2009
    Posts
    40

    Re: Problem in building with mobility in Qt SDK 1.1 TP

    Thanks so far, no help from other threads though. Maybe I could try building mobility from sources with these instructions and try copying its libs+headers from S^3 SDK to Symbian SDKs under QtSDK 1.1 TP.

  9. #9
    Nokia Developer Moderator
    Join Date
    Oct 2009
    Posts
    4,326

    Re: Problem in building with mobility in Qt SDK 1.1 TP

    I don't think situation is so bad that one needs to build Qt Mobility from sources. Even being a Linux user I know that Qt SDK 1.1 TP works fine with Qt Mobility on Windows, so you face something specific. It could be related to specific setup of your Windows workstation and it's very hard to find without having access to your computer.
    I suggest you to file a bug to Qt dashboard
    http://bugreports.qt.nokia.com/secure/Dashboard.jspa
    one good starting point could be providing output of tree /F C:\QtSDK > QtSDKfiles.txt attached to a bug, making it possible to verify that SDK has all files in place.

Similar Threads

  1. Qt SDK 1.1 TP issue with Mobility/Camera
    By charshep in forum [Archived] Qt SDKs and Tools
    Replies: 4
    Last Post: 2011-03-14, 15:03
  2. Build problem with Qt SDK 1.1 TP
    By charshep in forum [Archived] Qt SDKs and Tools
    Replies: 3
    Last Post: 2011-01-26, 09:26
  3. Where are EPOC32 zip files in qt-mobility-opensource-src-1.1.0-tp.zip
    By rahul.kulshreshtha in forum [Archived] Qt Mobility Project
    Replies: 3
    Last Post: 2010-09-29, 11:18
  4. Qt Mobility-messaging in Nokia Qt SDK
    By sportz.90 in forum [Archived] Qt Mobility Project
    Replies: 5
    Last Post: 2010-09-13, 06:42
  5. Problem with Qt Mobility 1.1.0 TP For Symbian
    By skumar_rao in forum [Archived] Qt Mobility Project
    Replies: 9
    Last Post: 2010-08-31, 04:37

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •