×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Sep 2010
    Location
    Lahore, Pkaistan
    Posts
    3

    Unhappy Correct download required

    Hello!

    I require a bit of guidance as I'm interested in developing using Qt for my Nokia 5800 Xpress. I have downloaded the Nokia Qt SDK for Windows (Offline) (>~900MB) but it came with no virtual device. It's default target is a Nokia Device (Physical). I need there the following targets: Desktop, Mobile Physical, Mobile Virtual.

    Also, I loaded the Widget demo of Calculator and it won't build giving off this error:

    :: warning: The Symbian toolchain does not handle special characters in a project path well.

    I installed to the following folder: D:\Projects\Nokia_Qt_SDK

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,165

    Re: Correct download required

    Basically tools generally work best if they are installed all in same drive, as well as the code should generally be in same drive, at least when working with symbian targets.

    anyway, have you checked the simulator already ?, it is sort-of-virtual-device thingi.

  3. #3
    Registered User
    Join Date
    Sep 2010
    Location
    Lahore, Pkaistan
    Posts
    3

    Re: Correct download required

    Quote Originally Posted by symbianyucca View Post
    Basically tools generally work best if they are installed all in same drive, as well as the code should generally be in same drive, at least when working with symbian targets.

    anyway, have you checked the simulator already ?, it is sort-of-virtual-device thingi.
    I'm re-installing to the default folder and I'm installing everything. Cant see the simulator in the last install.

  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Correct download required

    The SDK comes with a Simulator, you should have it unless you have chosen not to install it to begin with. Also the SDK installs all tools in the same location, to date there are no reports (AFAIK) about the SDK having errorneous behaviuour when installed in a different location.

    The warning you see comes from the use of a _ in the directory path, and may in fact show regardless of where the SDK is installed if your project path ends up to have spaces or non alphanumeric characters. Avoid "My Documents" and similar locations and you will be fine.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  5. #5
    Registered User
    Join Date
    Sep 2010
    Location
    Lahore, Pkaistan
    Posts
    3

    Re: Correct download required

    Okay, un-installed and installed with everything default. I'm on a Windows 7 x64 machine. Now I'm geting all sorts of Header files 404 error (#includes). None of the include file are being found by the IDE or builder. Any idead as to why?

Similar Threads

  1. correct write
    By shadow-2005 in forum Symbian
    Replies: 6
    Last Post: 2006-12-08, 20:10
  2. cable required for download of midlet
    By gerrykilleen in forum Mobile Java General
    Replies: 0
    Last Post: 2004-03-07, 14:08
  3. Replies: 0
    Last Post: 2003-07-30, 13:02
  4. Replies: 2
    Last Post: 2002-05-31, 08:50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×