×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Oct 2004
    Posts
    28

    Unhappy EABI version error

    error: Source object \NokiaQtSDK\Symbian\SDK\epoc32\release\ARMV5\udeb\alarmclient.lib(alarmclient{000a0000}-5.o) has EABI version 2, but target \NokiaQtSDK\Symbian\SDK\EPOC32\BUILD\myapp\MYAPP_0XEE653D4F\GCCE\udeb\MYApp.exe has EABI version 4

    I am getting this error on creating a wrapper API for Alarm & building it in Qt.

    Any idea about this?




    Thanx

  2. #2
    Registered User
    Join Date
    Dec 2006
    Posts
    2,280

    Re: EABI version error

    Have you copied the library to your NokiaQtSDK - it's not in mine? Have you got the .dso file in there too?

  3. #3
    Registered User
    Join Date
    Oct 2004
    Posts
    28

    Re: EABI version error

    Yes I copied the .dso & .lib files from 5th Edition SDK to NokiaQtSDk

  4. #4
    Regular Contributor
    Join Date
    Sep 2008
    Posts
    286

    Re: EABI version error

    I notice that you are trying to statically link to that library. Copying lib files from platform x and then trying to statically link them in platform y will get you into troubles
    Library is built with RVCT and older version of EABI according to error note. You are building this on Symbian^3 version of Qt SDK 1.1 with GCCE. It just won't work.

    I can't remember the specifics right now, but not the first time I see this error.
    Search bugreports.qt.nokia.com and you might find something to go with, but I bet you need to rebuild the lib.

    EDIT: how about try using the DLL instead?

    EDIT2: scrap that. just use this http://wiki.forum.nokia.com/index.ph...h_Custom_Sound
    Last edited by jakoskin; 2011-02-09 at 10:37.

Similar Threads

  1. EABI Compiler
    By jascco in forum Symbian Tools & SDKs
    Replies: 4
    Last Post: 2006-12-07, 10:33
  2. EABI and bwins
    By johngoche in forum Symbian
    Replies: 1
    Last Post: 2006-11-10, 16:37
  3. EABI Versioning Problem
    By jfinger in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2006-07-19, 15:33
  4. Unsupported JRE Version Error
    By nagir in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2005-12-21, 12:39
  5. Running EABI executables on current Symbian OS
    By hotcheese in forum Symbian
    Replies: 0
    Last Post: 2004-09-17, 05:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×