×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 24
  1. #1
    Registered User
    Join Date
    Jul 2010
    Posts
    48

    Could not install from package *.sis on device: General OS-related error

    Hello,
    I am getting "Could not install from package *.sis on device: General OS-related error" output and i cant solve this for a 3 days. please help me, application was running safely 3 day ago but suddenly starts to give this error. hard to understand what i am doing wrong ??
    here is my pro file :
    QT += core gui

    QT += network xml

    QT += webkit



    TARGET = Babylon
    TEMPLATE = app


    SOURCES += main.cpp\
    mainwindow.cpp \
    xmlparsed.cpp \
    rsslisting.cpp \
    mekanlist.cpp \
    itemdetails.cpp \
    item.cpp \
    infomekan.cpp \
    infoapp.cpp \
    events.cpp \
    eventlist.cpp \
    event.cpp

    HEADERS += mainwindow.h \
    xmlparsed.h \
    rsslisting.h \
    mekanlist.h \
    itemdetails.h \
    item.h \
    infomekan.h \
    infoapp.h \
    events.h \
    eventlist.h \
    event.h

    FORMS += mainwindow.ui \
    xmlparsed.ui \
    mekanlist.ui \
    itemdetails.ui \
    item.ui \
    infomekan.ui \
    infoapp.ui \
    eventlist.ui

    CONFIG += mobility
    MOBILITY =
    symbian {
    LIBS +=-lcone -leikcore -lavkon -lhwrmvibraclient

    vendorinfo = \
    "%{\"Artechin"}" \
    ":\"Artechin""

    my_deployment.pkg_prerules = vendorinfo



    TARGET.UID3 = 0x20030F5D

    TARGET.CAPABILITY = NetworkServices
    TARGET.EPOCSTACKSIZE = 0x14000
    TARGET.EPOCHEAPSIZE = 0x20000 0x200000
    }
    RESOURCES += \
    a.qrc

    ICON = .\icon\babylon.svg
    and here is pkg file
    ; Babylon_template.pkg generated by qmake at 2011-02-14T14:21:49
    ; This file is generated by qmake and should not be modified by the user
    ;

    ; Language
    &EN


    ; SIS header: name, uid, version
    #{"Babylon"},(0x20030F5D),1,0,0

    ; Localised Vendor name
    %{"Vendor"}

    ; Unique Vendor name
    :"Vendor"


    ; Manual PKG pre-rules from PRO files
    ; Dependency to Qt Webkit
    (0x200267C2), 4, 6, 3, {"QtWebKit"}
    ; Default dependency to Qt libraries
    (0x2001E61C), 4, 6, 3, {"Qt"}
    ; Default HW/platform dependencies
    [0x101F7961],0,0,0,{"S60ProductID"}
    [0x102032BE],0,0,0,{"S60ProductID"}
    [0x102752AE],0,0,0,{"S60ProductID"}
    [0x1028315F],0,0,0,{"S60ProductID"}
    [0x20022E6D],0,0,0,{"S60ProductID"}

    ; Default dependency to QtMobility libraries
    (0x2002AC89), 1, 0, 2, {"QtMobility"}

    ; Executable and default resource files
    "/NokiaQtSDK/Symbian/SDK/epoc32/release/$(PLATFORM)/$(TARGET)/Babylon.exe" - "!:\sys\bin\Babylon.exe"
    "/NokiaQtSDK/Symbian/SDK/epoc32/data/z/resource/apps/Babylon.rsc" - "!:\resource\apps\Babylon.rsc"
    "/NokiaQtSDK/Symbian/SDK/epoc32/data/z/private/10003a3f/import/apps/Babylon_reg.rsc" - "!:\private\10003a3f\import\apps\Babylon_reg.rsc"
    "/NokiaQtSDK/Symbian/SDK/epoc32/data/z/resource/apps/Babylon.mif" - "!:\resource\apps\Babylon.mif"


    ; Manual PKG post-rules from PRO files
    cert and key files have added . what could be my problem ?

  2. #2
    Registered User
    Join Date
    Jul 2010
    Posts
    48

    Could not install from package *.sis on device: General OS-related error

    Hello,
    I am getting "Could not install from package *.sis on device: General OS-related error" output and i cant solve this for a 3 days. please help me, application was running safely 3 day ago but suddenly starts to give this error. hard to understand what i am doing wrong ??
    here is my pro file :
    QT += core gui

    QT += network xml

    QT += webkit



    TARGET = Babylon
    TEMPLATE = app


    SOURCES += main.cpp\
    mainwindow.cpp \
    xmlparsed.cpp \
    rsslisting.cpp \
    mekanlist.cpp \
    itemdetails.cpp \
    item.cpp \
    infomekan.cpp \
    infoapp.cpp \
    events.cpp \
    eventlist.cpp \
    event.cpp

    HEADERS += mainwindow.h \
    xmlparsed.h \
    rsslisting.h \
    mekanlist.h \
    itemdetails.h \
    item.h \
    infomekan.h \
    infoapp.h \
    events.h \
    eventlist.h \
    event.h

    FORMS += mainwindow.ui \
    xmlparsed.ui \
    mekanlist.ui \
    itemdetails.ui \
    item.ui \
    infomekan.ui \
    infoapp.ui \
    eventlist.ui

    CONFIG += mobility
    MOBILITY =
    symbian {
    LIBS +=-lcone -leikcore -lavkon -lhwrmvibraclient

    vendorinfo = \
    "%{\"Artechin"}" \
    ":\"Artechin""

    my_deployment.pkg_prerules = vendorinfo



    TARGET.UID3 = 0x20030F5D

    TARGET.CAPABILITY = NetworkServices
    TARGET.EPOCSTACKSIZE = 0x14000
    TARGET.EPOCHEAPSIZE = 0x20000 0x200000
    }
    RESOURCES += \
    a.qrc

    ICON = .\icon\babylon.svg
    and here is pkg file
    ; Babylon_template.pkg generated by qmake at 2011-02-14T14:21:49
    ; This file is generated by qmake and should not be modified by the user
    ;

    ; Language
    &EN


    ; SIS header: name, uid, version
    #{"Babylon"},(0x20030F5D),1,0,0

    ; Localised Vendor name
    %{"Vendor"}

    ; Unique Vendor name
    :"Vendor"


    ; Manual PKG pre-rules from PRO files
    ; Dependency to Qt Webkit
    (0x200267C2), 4, 6, 3, {"QtWebKit"}
    ; Default dependency to Qt libraries
    (0x2001E61C), 4, 6, 3, {"Qt"}
    ; Default HW/platform dependencies
    [0x101F7961],0,0,0,{"S60ProductID"}
    [0x102032BE],0,0,0,{"S60ProductID"}
    [0x102752AE],0,0,0,{"S60ProductID"}
    [0x1028315F],0,0,0,{"S60ProductID"}
    [0x20022E6D],0,0,0,{"S60ProductID"}

    ; Default dependency to QtMobility libraries
    (0x2002AC89), 1, 0, 2, {"QtMobility"}

    ; Executable and default resource files
    "/NokiaQtSDK/Symbian/SDK/epoc32/release/$(PLATFORM)/$(TARGET)/Babylon.exe" - "!:\sys\bin\Babylon.exe"
    "/NokiaQtSDK/Symbian/SDK/epoc32/data/z/resource/apps/Babylon.rsc" - "!:\resource\apps\Babylon.rsc"
    "/NokiaQtSDK/Symbian/SDK/epoc32/data/z/private/10003a3f/import/apps/Babylon_reg.rsc" - "!:\private\10003a3f\import\apps\Babylon_reg.rsc"
    "/NokiaQtSDK/Symbian/SDK/epoc32/data/z/resource/apps/Babylon.mif" - "!:\resource\apps\Babylon.mif"


    ; Manual PKG post-rules from PRO files
    cert and key files have added . what could be my problem ?

  3. #3
    Registered User
    Join Date
    May 2009
    Location
    Rome
    Posts
    268

    Re: Could not install from package *.sis on device: General OS-related error

    Hi i m stuck with a problem like your one...

    until i use TARGET.UID3 = 0xA000A648 in my .pro everything is fine

    as i m ready to deploy i have changed it to 0x20035D45 , that is one of the five ids Ovi feed me
    then added cert and key files as required to release configuration
    then cleaned up everything and rebuild...

    after that , i m running commad line as :
    makesis ../xxxxxPlay_installer.pkg

    xxxxxx_OviPublishCert_Jan17.sis certificate from Ovi Support has been installed on my N8 too...

    as i m using one of the 5 id Nokia gave me i supposed that it should run at least on my own device ... no luck, it doesn't install

    Simply i have to admit i still not get how it should be signing workflow
    I ' m on the point to submit it in the Ovi store just to hear about the response , i guess it will be negative, hopefully they will point me what i'm doing wrong ...
    Thanks for helping
    Keep it simple, stupid
    borg - http://store.ovi.com/content/116105

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: Could not install from package *.sis on device: General OS-related error

    Basically with Qt running, if you get this error, just disable the silent installation. Or check the location where the file was loaded and manually install it by clicking the file with file manager.

    For the installation that fails on the device, please do change the device to be using English language, and then see what the excat error message is, it would help on determining what is going wrong in there.

  5. #5
    Regular Contributor
    Join Date
    Jan 2011
    Posts
    122

    Re: Could not install from package *.sis on device: General OS-related error

    Same happened to me. I thought I must have made a mistake on my latest project settings. But when I tried running all the previous projects that were running perfectly before, it won't install as well. I'm not sure if it has something to do with the new key and cert provided to me the other day by publishtoovi.support@nokia.com. I tried it and the cert and key they've provided didn't work. They also provided testcert_990.sis which also failed to install. Not sure if it's just a coincidence but the next day after that, I wasn't able to deploy any app to the device.

    Something like this happened before a few times already. All I need to do was just restart the phone and it worked fine. But now,even if I restart it, unplug/replug the cable, still throws the same error. Anyone who knows how to solve this? Or at least how to know what's wrong?

  6. #6
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: Could not install from package *.sis on device: General OS-related error

    did you read my last reply, and did you try what was suggested. And what did happen after you tried what was suggested ?

  7. #7
    Regular Contributor
    Join Date
    Jan 2011
    Posts
    122

    Re: Could not install from package *.sis on device: General OS-related error

    The phone's language is already set to English, actually nothing was changed in the device's settings, at least not manually.

    I tried running the sis file from the File mgr and it prompted "Unable to start operation. Installer already in use." I tried to run the sis file from the project folder manually, it shows this error:
    Something's gone wrong

    There was a problem with installing the file.
    Error code: 2153775105

    I tried running the older sis files that were previously working, it's giving the same error. What could've changed?

    By the way, how to disable silent installation? Should I use this? http://wiki.forum.nokia.com/index.ph...lUninstall.zip
    Last edited by vilmavaliente; 2011-05-06 at 09:54.

  8. #8
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: Could not install from package *.sis on device: General OS-related error

    disconnect the cable, re-start the device, and then try again installing the file from the filemanager.

  9. #9
    Regular Contributor
    Join Date
    Jan 2011
    Posts
    122

    Re: Could not install from package *.sis on device: General OS-related error

    It prompts:

    Security warning:
    Application is untrusted and may be harmful to your phone

    then,

    Unable to install a protected application from an untrusted supplier

    I tested several sis files(that are previously working).

  10. #10
    Super Contributor
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: Could not install from package *.sis on device: General OS-related error

    looks like your issue is related to certificate. What is UID of your application? Either use unprotected UID, i.e. 0xA0000000 - 0xAFFFFFFF for self-signing your application OR use developer certificate.

  11. #11
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: Could not install from package *.sis on device: General OS-related error

    That error comes indeed when the UID of the applciation is on protected range, and the certificate used in self-signed. Thus re-check that you have set the certificate correctly in your build settings.

  12. #12
    Regular Contributor
    Join Date
    Jan 2011
    Posts
    122

    Re: Could not install from package *.sis on device: General OS-related error

    The certificate is correctly set and i had the correct key and cert path and the files exist.

    I tried using the Qt generated UID3 and self-signing, installation was successful.

    The testcert_990.sis that failed was a Certificate Provisioner. I didn't uninstall the existing Nokia R&D Certificate Provisioner so maybe it messed up something. publishtoovi.support already replied regarding the failed installation and gave additional instructions. But unfortunately, the cert and key they've provided still gives me the same error.

    Not sure if I need a new set of key and cert as well as UID3s.

    Using the self-sign will be enough for now. Thanks for the help.

  13. #13
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: Could not install from package *.sis on device: General OS-related error

    Basically I have never used the Ovi certificate, I suppose there were a requirement to install something beforehand on the device, as well as you do remember that you can use the certificate only for the devices that you specified when you applied for the certificate.

  14. #14
    Super Contributor
    Join Date
    Nov 2009
    Location
    Minnesota, USA
    Posts
    3,209

    Re: Could not install from package *.sis on device: General OS-related error

    Are you sure this phone is in the serial number list for the provisional certificate?

  15. #15
    Regular Contributor
    Join Date
    Jan 2011
    Posts
    122

    Re: Could not install from package *.sis on device: General OS-related error

    I actually was thinking about the IMEI cause I remember when I first asked for UIDs, cert and key, they asked me for the IMEI of the device I'm using. And when I switched from N8 to E7, I gave them a new IMEI and they added it to my cert. But I just assumed that publishtoovi made the new cert and key specifically for me and that it already is set to work on the device I'm using. But maybe I assumed incorrectly. They said
    We have recently updated our certificates and are issuing you a new certificate installer and cert key pair. Please update your environments with these new files.
    Last edited by vilmavaliente; 2011-05-09 at 03:50.

Similar Threads

  1. Replies: 6
    Last Post: 2011-02-28, 11:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×