×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Mar 2009
    Posts
    9

    QtMultimediaKit...wich version?

    Hi, i use the Qt Sdk 1.1(tech preview) with this code:
    Code:
    import Qt 4.7
    import QtMultimediaKit
    
    
    Rectangle {
        width: 360
        height: 360
        Audio{
            id:song
            source:"gue2.mp3"
        }
    
        MouseArea {
            anchors.fill: parent
            onClicked: {
                song.play()
            }
        }
    }
    I get this error:
    Library import requires a version
    I tried also with
    Code:
    import QtMultimediaKit1.1
    but i get another error:
    module "QtMultimediaKit1" is not installed

  2. #2
    Super Contributor
    Join Date
    Mar 2005
    Location
    Paris
    Posts
    814

    Re: QtMultimediaKit...wich version?

    you have to install QtMobility. Good luck with that, depending on your platform it can be pretty complex

  3. #3
    Registered User
    Join Date
    Mar 2009
    Posts
    9

    Re: QtMultimediaKit...wich version?

    thank's....i use Windows7 on pc and deploy for Maemo(N900 PR1.3) i have to install QtMobility on both or only on my pc?

  4. #4
    Super Contributor
    Join Date
    Mar 2005
    Location
    Paris
    Posts
    814

    Re: QtMultimediaKit...wich version?

    on your pc if you want to use the simulator, on your device if you want to use your device.

  5. #5
    Nokia Developer Moderator
    Join Date
    Jul 2006
    Location
    Tampere, Finland
    Posts
    13

    Re: QtMultimediaKit...wich version?

    Quote Originally Posted by vitna View Post
    Hi, i use the Qt Sdk 1.1(tech preview) with this code:
    I tried also with
    Code:
    import QtMultimediaKit1.1
    but i get another error:
    Try importing with
    Code:
    import QtMultimediaKit 1.1
    I.e. add a space between QtMultimediaKit and 1.1. Works for me at least.
    - Late

  6. #6
    Registered User
    Join Date
    Mar 2009
    Posts
    9

    Re: QtMultimediaKit...wich version?

    Quote Originally Posted by LateJ View Post
    Try importing with
    Code:
    import QtMultimediaKit 1.1
    I.e. add a space between QtMultimediaKit and 1.1. Works for me at least.
    i tried it and don't work, i get always the same error..

    Possible that is so hard insert and play an audio file into an application? QML is so simple that i can't believe that there isn't a simple way to play an mp3 file.

Similar Threads

  1. N900 QtMultimediaKit 1.1
    By cristids in forum [Archived] Qt Mobility Project
    Replies: 2
    Last Post: 2011-01-29, 20:43
  2. QML QtMultimediaKit Video Element
    By Onddo in forum [Archived] Qt Mobility Project
    Replies: 0
    Last Post: 2010-12-23, 19:07
  3. Wich SDK for N95?
    By gulmc in forum Symbian Tools & SDKs
    Replies: 7
    Last Post: 2010-07-02, 16:16
  4. wich dreamweaver version need for nokia wrt
    By caballeroantonio in forum Symbian
    Replies: 5
    Last Post: 2010-02-08, 15:58

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×