×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Mar 2003
    Location
    Sweden, Stockholm
    Posts
    90

    Question Qt SDK Version 1.1 Beta on Max OS X -- module "QtQuick" is not installed

    Hi,
    Yesterday I Installed "Qt SDK Version 1.1 Beta on Max OS X ", when I run a QT Quick example I got this error:

    Starting /Users/ove/QtSDK/Examples/4.7/declarative/animation/basics/coloranimation-build-desktop/coloranimation.app/Contents/MacOS/coloranimation...
    file:///Users/ove/QtSDK/Examples/4.7/declarative/animation/basics/coloranimation-build-desktop/coloranimation.app/Contents/Resources/qml/qml/color-animation.qml:41:1: module "QtQuick" is not installed
    import QtQuick 1.0

    What to do?

    Best Regards,
    Ove

  2. #2
    Super Contributor
    Join Date
    Mar 2009
    Posts
    1,024

    Re: Qt SDK Version 1.1 Beta on Max OS X -- module "QtQuick" is not installed

    Hi Ove,
    I suppose you are using a target which makes use of "old" Qt libs (< 4.7.1)
    Replace "import Quick 1.0" with "import Qt 4.7" and it will start to work.

    http://doc.qt.nokia.com/4.7-snapshot...-whatsnew.html

  3. #3
    Registered User
    Join Date
    Mar 2003
    Location
    Sweden, Stockholm
    Posts
    90

    Re: Qt SDK Version 1.1 Beta on Max OS X -- module "QtQuick" is not installed

    Quote Originally Posted by gnuton View Post
    Hi Ove,
    I suppose you are using a target which makes use of "old" Qt libs (< 4.7.1)
    Replace "import Quick 1.0" with "import Qt 4.7" and it will start to work.

    http://doc.qt.nokia.com/4.7-snapshot...-whatsnew.html
    Then I got this error:
    Starting /Users/ove/QtSDK/Examples/4.7/declarative/animation/basics/coloranimation-build-desktop/coloranimation.app/Contents/MacOS/coloranimation...
    file:///Users/ove/QtSDK/Examples/4.7/declarative/animation/basics/coloranimation-build-desktop/coloranimation.app/Contents/Resources/qml/qml/color-animation.qml:43:1: module "Qt.labs.particles" is not installed
    import Qt.labs.particles 1.0

  4. #4
    Registered User
    Join Date
    Mar 2003
    Location
    Sweden, Stockholm
    Posts
    90

    Re: Qt SDK Version 1.1 Beta on Max OS X -- module "QtQuick" is not installed

    Quote Originally Posted by ovjo12 View Post
    Then I got this error:
    Starting /Users/ove/QtSDK/Examples/4.7/declarative/animation/basics/coloranimation-build-desktop/coloranimation.app/Contents/MacOS/coloranimation...
    file:///Users/ove/QtSDK/Examples/4.7/declarative/animation/basics/coloranimation-build-desktop/coloranimation.app/Contents/Resources/qml/qml/color-animation.qml:43:1: module "Qt.labs.particles" is not installed
    import Qt.labs.particles 1.0
    I was thinking, it is perhaps because I have old Qt SDK installed so I have now removed old Qt SDK and when installing Qt SDK 1.1 beta again I have also pressed button "Remove old Qt Creator settings"

  5. #5
    Registered User
    Join Date
    Mar 2003
    Location
    Sweden, Stockholm
    Posts
    90

    Re: Qt SDK Version 1.1 Beta on Max OS X -- module "QtQuick" is not installed

    Quote Originally Posted by ovjo12 View Post
    I was thinking, it is perhaps because I have old Qt SDK installed so I have now removed old Qt SDK and when installing Qt SDK 1.1 beta again I have also pressed button "Remove old Qt Creator settings"
    did not work, same problem

  6. #6
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: Qt SDK Version 1.1 Beta on Max OS X -- module "QtQuick" is not installed

    I did a fresh install on Mac (first I removed Qt SDK 1.1 TP) and the Color Animation example worked.
    Though I got a number of warnings when opening Qt Creator - I guess my installation was not a complete success :-(

    So it is something related your set-up. Unfortunately I cannot tell you what is the problem exactly...

    Hartti

  7. #7
    Registered User
    Join Date
    Mar 2003
    Location
    Sweden, Stockholm
    Posts
    90

    Re: Qt SDK Version 1.1 Beta on Max OS X -- module "QtQuick" is not installed

    Quote Originally Posted by hartti View Post
    I did a fresh install on Mac (first I removed Qt SDK 1.1 TP) and the Color Animation example worked.
    Though I got a number of warnings when opening Qt Creator - I guess my installation was not a complete success :-(

    So it is something related your set-up. Unfortunately I cannot tell you what is the problem exactly...

    Hartti
    I understand now I also had one more Qt SDK, I found a python-script in /Developer/Tools, I was able to remove Qt using "sudo unistall-qt.py" and "sudo unistall-qtsdl.py", it was installed in /usr/bin/qt. Now it works!!!! :-)

  8. #8
    Regular Contributor
    Join Date
    Feb 2009
    Location
    ASIA PACIFIC
    Posts
    108

    Re: Qt SDK Version 1.1 Beta on Max OS X -- module "QtQuick" is not installed

    Quote Originally Posted by ovjo12 View Post
    I understand now I also had one more Qt SDK, I found a python-script in /Developer/Tools, I was able to remove Qt using "sudo unistall-qt.py" and "sudo unistall-qtsdl.py", it was installed in /usr/bin/qt. Now it works!!!! :-)
    The problem is there in Windows too - If this is the case, you will be unable to develop for Ovistore . till ovistore starts accepting QML apps
    Website: http://nmamobiles.byethost2.com
    Blog: http://nmamobiles.byethost2.com/blog

  9. #9
    Registered User
    Join Date
    Aug 2010
    Posts
    3

    Re: Qt SDK Version 1.1 Beta on Max OS X -- module "QtQuick" is not installed

    Hey,,
    I did the same. It worked for me.
    thanks,
    http://www.kmdarshan.com/blog

Similar Threads

  1. module "Qt.labs.particles" is not installed on N8
    By chintandave_er in forum [Archived] Qt Quick
    Replies: 7
    Last Post: 2011-01-28, 07:25
  2. samegame "Qt.labs.particles" is not installed
    By fg313071405 in forum [Archived] Qt General ( Qt技术)
    Replies: 2
    Last Post: 2010-12-21, 03:25
  3. Qt/3D with QML bindings - "module "Qt3D" is not installed"
    By John de Witt in forum [Archived] Qt SDKs and Tools
    Replies: 0
    Last Post: 2010-10-20, 04:53
  4. "Pure Qt" SDK cannot live next to Symbian OS specific Qt SDK on a single PC
    By svdwal in forum [Archived] Qt SDKs and Tools
    Replies: 1
    Last Post: 2010-07-06, 07:51
  5. Replies: 3
    Last Post: 2010-06-30, 01:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×