×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Feb 2005
    Posts
    5

    Deploying to N900/Mad Developer from Qt Creator; Connection Refused

    Hello,

    Thought to get back to coding after a while with some hobby project for N900. App runs fine on Qt Simulator, but I can't deploy it on to phone.

    Just installed Qt_SDK_Win_offilne_v1_1_beta_en to PC and Mad Developer to a N900. I configured wifi connection with this guide:
    http://www.forum.nokia.com/Develop/Q...d/Step_4.xhtml

    Connection test syas it's OK, deploying SSH key works fine. But deploying app to phone gives
    c:\qtsdk\maemo\4.6.2\targets\fremantle-pr13\bin\ar.exe: creating ../helloworld_0.0.1_armel.deb
    dpkg-genchanges -b >../helloworld_0.0.1_armel.changes
    dpkg-buildpackage: binary only upload (no source included)
    dpkg-genchanges: binary-only upload - not including any source code
    Package created.
    Connecting to device...
    Error while building project helloworld (target: Maemo)
    When executing build step 'Deploy to Maemo device'


    and Build issues says
    Could not connect to host: Connection refused
    File not found:

    ...and nothing else. What file? How's that related to Connection refused?

    There's one suspicious error in build log earlier:
    which: pgp: unknown command

    What might be wrong?

    BTW, noticed earlier that space in name of project directory path ruins some build step...where to report bugs?


    EDIT:
    got this to work;
    Projects Maemo/Run settings had QEMU as deploy device
    Last edited by wilho; 2011-03-04 at 23:32. Reason: solved

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Deploying to N900/Mad Developer from Qt Creator; Connection Refused

    Quote Originally Posted by wilho View Post

    BTW, noticed earlier that space in name of project directory path ruins some build step...where to report bugs?
    http://bugreports.qt.nokia.com
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. Segfault when deploying on N900 from QtCreator 2.0.1
    By Grinchman in forum [Archived] Qt SDKs and Tools
    Replies: 2
    Last Post: 2010-11-16, 08:01
  2. I refused an update -> Qt Creator proceeds to uninstall itself
    By Matoking in forum [Archived] Qt SDKs and Tools
    Replies: 4
    Last Post: 2010-10-30, 19:25
  3. can connect to N900 through mad terminal
    By pigling in forum [Archived] Qt SDKs and Tools
    Replies: 3
    Last Post: 2010-10-04, 14:51
  4. fail to deploy from Nokia Qt SDK for Mac in Qt Creator
    By ovjo12 in forum [Archived] Qt SDKs and Tools
    Replies: 4
    Last Post: 2010-07-23, 14:38
  5. Trying to run Qt project on N900 via MAD developer: getting Packaging error
    By titanic2 in forum [Archived] Qt SDKs and Tools
    Replies: 1
    Last Post: 2010-07-08, 10:18

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×