×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Feb 2011
    Posts
    4

    Question Selecting proper FL version, when (nearly) all works

    I make content in Flash Lite 2.0, to make it as combatible as possible with Nokia and others platforms. For the Nokia part (or in general) – would it be beneficial to select a higher output version like 3.0 or 3.1 for devices that supports it – even though the content doesn't require so?

    (If it matters – that for .swf, .nfl and .sisx)

    Regards
    Hakan Olsson
    Last edited by hakano13; 2011-03-11 at 11:34.

  2. #2
    Registered User
    Join Date
    May 2009
    Location
    Nairobi, Kenya
    Posts
    42

    Re: Selecting proper FL version, when (nearly) all works

    Hey?

    It depends on functionality. If you want to stream video for instance you must target FL3 and above. If you are working with non dynamic content like wallpapers and screen savers, you may be safe with FL2. I usually guide clients to a FL3.1 download link for S60 3rd and 5th edition devcies before allowing them to download my applications. However remember Nokia has released newer models with FL3 including a lot of Symbian Series 40 mid range phones. My advice is try to herd users to at least FL3.0 as the updates are readily available.

  3. #3
    Nokia Developer Champion
    Join Date
    Jul 2008
    Location
    Pakistan
    Posts
    1,065

    Re: Selecting proper FL version, when (nearly) all works

    Hi Hakan Olsson,
    Since you already developed your content with Flash Lite 2.0 and obviously, i am assuming it is working fine. You are free to support all Flash Lite 2.0 to 4.0 devices if your Flash Lite 2.0 is coded softly i.e it can fit in any orientation & support non-touch screen & touch screen phones as well. Because all Flash Lite versions are backward compatible (2.0-4.0).
    would it be beneficial to select a higher output version like 3.0 or 3.1 for devices that supports it – even though the content doesn't require so?
    If content doest require advance features than i don't think you have to adapt higher version for your content but obviously, as the end-users required innovative applications and newer versions are exposing new APIs that can add more features to your existing content, thats why, switching to newer versions always have some advantages. :Hope it helps )

    Best Regards,
    Sajid Ali Anjum

Similar Threads

  1. Replies: 2
    Last Post: 2010-06-21, 14:26
  2. EIKCTL 25 when selecting listbox item
    By vmakinen in forum Symbian User Interface
    Replies: 2
    Last Post: 2009-02-13, 01:38
  3. Guys,I need you help fl 2.0 and fl 3.0
    By lSet in forum [Archived] Flash Lite on Nokia Devices
    Replies: 1
    Last Post: 2009-01-08, 11:03
  4. 6210 Navigator is a FL 3 device not FL 2.1
    By biskero in forum [Archived] Flash Lite on Nokia Devices
    Replies: 7
    Last Post: 2008-02-27, 03:07
  5. 6131 NFC Emulator v1.1 crashes on nearly all SVG content
    By steview in forum Tools and SDK Feedback (Closed)
    Replies: 0
    Last Post: 2007-07-31, 19:37

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×