×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Mar 2011
    Posts
    1

    Qt 4.7.1 installation problem with new C5-03 phones

    Hi everyone!

    Our team tried to install Qt 4.7.1 to three new C5-03 phones, but the installation gives us errors every time. We didn't had any problems with about three month old C5-03 model which has the same firmware version. Has something changed with the new phones?

    Details:

    Device: C5-03, Firmware v 11.0.024 (08-12-2010), Type RM-697

    Tried to install Qt 4.7.1 installer.sis to three different C5-03 phones. These installations were the first things we did to these devices after opening the boxes.

    In all three devices the installation gives us errors:

    "PIPS Installer is not upgradable (-10257). Continue anyway?"
    After OK comes next message:
    "SWI error 0 !:\sys\bin\signalserver.exe"
    Then there is only "Exit" choice.

    Have anyone else have this problem or does anyone know what to do for this?

    Br.
    Aki Kolehmainen

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Qt 4.7.1 installation problem with new C5-03 phones

    A search for "PIPS Installer is not upgradable (-10257)" should have shown you the solution already. We're talking here about the fact that these new devices have already the correct OpenC package and therefore the "update" that Qt's installer tries to perform is not needed and not possible.

    Install qt.sis and qtwebkit.sis instead of the qt_installer.sis package.

    Please also note that the Qt SDK 1.1 has been updated and the new beta contains Qt 4.7.2.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Regular Contributor
    Join Date
    Sep 2008
    Posts
    286

    Re: Qt 4.7.1 installation problem with new C5-03 phones

    Quote Originally Posted by ltomuta View Post
    A search for "PIPS Installer is not upgradable (-10257)" should have shown you the solution already. We're talking here about the fact that these new devices have already the correct OpenC package and therefore the "update" that Qt's installer tries to perform is not needed and not possible.

    Install qt.sis and qtwebkit.sis instead of the qt_installer.sis package.

    Please also note that the Qt SDK 1.1 has been updated and the new beta contains Qt 4.7.2.
    You know that Qt SDK 1.1 Beta Qt.sis (formerly called qt_installer.sis) contains Open C sis files as convenience and there is no separate Qt.sis anymore.
    One could extract embedded Qt.sis from Qt.sis and install that.
    like this:
    epoc32\tools\dumpsis qt.sis
    cd qt
    ren file4 qt.sis
    qt.sis <- to install.

    -Janne

    edit: I think this should be least investigated if the issue is there. I don't have C5-03 so I could try it.
    http://twitter.com/#!/koshui

  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Qt 4.7.1 installation problem with new C5-03 phones

    Quote Originally Posted by jakoskin View Post
    edit: I think this should be least investigated if the issue is there. I don't have C5-03 so I could try it.
    The issue is known and should be fixed in PR 1.2 (IIRC).
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. Nokia C5-03' s BUG for j2me !!!
    By atasoyh in forum Mobile Java General
    Replies: 5
    Last Post: 2011-03-11, 19:38
  2. Installation problem, I can't create a new application with Sun Studio
    By minschk in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 1970-01-01, 02:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×