×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Sep 2010
    Posts
    10

    Platform Services 2.0 startCamera callback mostly fails

    And by failing I mean that after taken the photo and returning to WRT application the WRT crashes in about 40% of the cases. The other 60% works fine and I can continue with the callback function, it returns the imagepath ok.

    It's not phone or photo size related. I've tried it with C7, N8 and E7. Same results. N8 full resolution images work as often as 0.3Mpix C7 photos.

    Any suggestions? I've tried about everything I could imagine, but maybe you have a better imagination.

  2. #2
    Nokia Developer Expert
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: Platform Services 2.0 startCamera callback mostly fails

    Lets continue in this thread then..
    I would suggest that you install ErrRd file on your device. After it has been installed you will get some basic info about what has crashed and the error code.
    http://www.symbianresources.com/ has the ErrRd tool available, but there might be some other sites as well.

    May I ask what are the firmware versions of the devices?

    Br,
    Ilkka

  3. #3
    Registered User
    Join Date
    Sep 2010
    Posts
    10

    Re: Platform Services 2.0 startCamera callback mostly fails

    The units and firmwares we have tested are:

    - C7 PR1.0 (012.003.270.01) english
    - N8 PR1.0 (011.012.240.01) finnish/english
    - N8 PR1.0 (011.011.00.01) english/german

    And they all act the same way. One addition to the behaviour descripted before: The callback function fails and crashes sometime even when no photo is taken (straight back -> exit in camera).

    I added some delays to JS-functions (setTimeout(...)) and it seems like the crash rate has dropped a bit. But I'm not sure, haven't kept a list or anything.

  4. #4
    Registered User
    Join Date
    Sep 2010
    Posts
    10

    Re: Platform Services 2.0 startCamera callback mostly fails

    Some new devices tested:

    - C5-03 (5th edition) V 11.0.024: Doesn't support camera at all

    - E7 PR1.1 (014.002.263.03) english: Worked couple of days without crashing, now is back to unstabile 50-50 (success-fail). Haven't got any decent debugging info yet, the ErrRd hasn't worked too well. Try to report today if I found any decent crash tracker.

  5. #5
    Registered User
    Join Date
    Sep 2010
    Posts
    10

    Re: Platform Services 2.0 startCamera callback mostly fails

    Here's the debug info when a photo is shot and returning to WRT callback function.

    ErrRd says:

    Application Closed: WidgetUi
    KERN-EXEC 3
    (Reason: 3, Status: -13).

    Not very descriptive, or is it? Is there a way to get more detailed information?

  6. #6
    Registered User
    Join Date
    Oct 2011
    Posts
    2

    Re: Platform Services 2.0 startCamera callback mostly fails

    Hello:
    i'm experimet the same issue:
    On N97,
    - take a picture OK
    - save: OK
    - and callback function dont rise, but app. crashed
    Some times, all works OK and callback runs correct.

    Do you found any solution or reason about this?
    Thanks!

Similar Threads

  1. MMS with Platform Services
    By biskero in forum [Archived] Flash Lite on Nokia Devices
    Replies: 9
    Last Post: 2011-03-11, 20:39
  2. platform services / messaging / sms content
    By joppe_k in forum Symbian
    Replies: 5
    Last Post: 2011-01-14, 12:30
  3. Platform Services
    By vijayvittal in forum Symbian
    Replies: 2
    Last Post: 2010-09-06, 10:39
  4. Platform Services 2.0 and Aptana ?
    By Tintolo in forum Symbian
    Replies: 4
    Last Post: 2010-01-14, 21:13
  5. Nokia Platform Services wishlist/suggestions
    By daaain in forum [Archived] Flash Lite on Nokia Devices
    Replies: 0
    Last Post: 2009-02-22, 19:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×