×

Discussion Board

Results 1 to 11 of 11
  1. #1
    Registered User
    Join Date
    Mar 2011
    Posts
    29

    Qt application not running on device.

    hello ...

    i have done a 6 page widget application running ok on simulator.
    but on device it run extremely slow.it takes 1 or 2 minutes to respond after click.
    my sis size is 6.73 MB.

  2. #2
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: Qt application not running on device.

    Hello harshalsengar

    with your explananation of the problem one thing i could tell is there me a problem like your application goes out of sufficient heap memory available.

    Try increasing the heap size, this may help you a bit.

  3. #3
    Registered User
    Join Date
    Mar 2011
    Posts
    29

    Re: Qt application not running on device.

    thank you gaba .........i try that

  4. #4
    Registered User
    Join Date
    Mar 2011
    Posts
    29

    Re: Qt application not running on device.

    problem solved with heap..

    i more is with widget.
    i extended mainwindow with "QMainWindow" and other remaining with ""QStackWidg..."
    my application show next widget on click.
    excluding 'mainwindow', all widgets are not fit to screen.

  5. #5
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: Qt application not running on device.

    hello harshalsengar

    can you make the question bit more clear, as i am not so clear about your question.

    Regards

  6. #6
    Registered User
    Join Date
    Mar 2011
    Posts
    29

    Re: Qt application not running on device.

    ok ....
    my 'class' parent is QStackWidget and i am showing mainwindow object inside that widget

  7. #7
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: Qt application not running on device.

    i am not sure whats your problem is but the approach you are trying is bit wrong , you need to place QStackedWidget Object inside your MainWindow and then based on than you need to change the widget based on some logic try this link http://wiki.forum.nokia.com/index.ph...t_and_QToolbar

    Regards

  8. #8
    Registered User
    Join Date
    Mar 2011
    Posts
    29

    Re: Qt application not running on device.

    actully gaba i told you something wrong...
    will clear you later..

    i watch your link..
    Last edited by harshalsengar; 2011-03-29 at 15:15.

  9. #9
    Registered User
    Join Date
    Mar 2011
    Posts
    29

    Re: Qt application not running on device.

    hello gaba88..

    is there any API exists in QT for facebook.

  10. #10
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: Qt application not running on device.

    there is no direct API as such but there are two options:

    1. You can go to facebook developers website, and understand the Graph API which is very much easy to understand , then try writing your own implementation of consuming that API using the webview as its just the matter of calling two three URLS, i recommend this approach.

    2. Try Understanding the QFaceBook project http://gitorious.org/qfacebook and try porting it to fit the Symbian mobiles.

    Regards

  11. #11
    Registered User
    Join Date
    Mar 2011
    Posts
    29

    Re: Qt application not running on device.

    thanks gaba.....................................
    Last edited by harshalsengar; 2011-04-11 at 06:10.

Similar Threads

  1. Running Qt application on device
    By Maysoon88 in forum Qt
    Replies: 7
    Last Post: 2010-11-24, 07:50
  2. Application running on emulator but not running on Device
    By syedshakeel2004 in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 3
    Last Post: 2010-09-28, 13:55
  3. Application not running on the device
    By vicky_nits in forum Symbian
    Replies: 8
    Last Post: 2010-07-01, 13:33
  4. XML application running on emulator not on device
    By deshmukhcv in forum Mobile Java General
    Replies: 1
    Last Post: 2008-09-23, 11:06
  5. XML application running on emulator but not on device.
    By deshmukhcv in forum General Development Questions
    Replies: 1
    Last Post: 2008-09-23, 09:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×