×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Aug 2009
    Posts
    12

    [Qt SDK 1.1] Conn. Failed - Conn. Unavailable

    Hi everyone!
    I'm having a hard time with networking using the latest Qt Sdk 1.1 (Qt 4.7.2, Qt Mobility 1.1.1, Qt Creator 2.1).
    I've tried every example and idea I could think of, but I couldn't get it working.

    I'm 100% sure this is related to the new SDK (be it a problem with Qt 4.7.2 or with Qt Mobility 1.1.1), because I had a sample working fine with the SDK 1.0, that now doesn't work anymore.
    Besides, it seems to work fine on the emulator, but not on a real device (I've tested it on a Nokia C7).

    Every time I try to establish a connection, I get a balloon tip on the top of the screen displaying "Conn. Failed Conn. Unavailable". I've tried that with both an already established wifi connection (which works perfectly on the phone's browser), and only using the USB connection, both scenarios fail in the same way.
    There doesn't seem to be any other error besides that balloon tip.

    We are working on a very big project, for a major US corporation, and one of Nokia Senior Architects suggested we use the SDK 1.1... please if someone can help me out with this, I'll be really thankful.

    UPDATE:
    This seems to be a device specific problem. I've tested the same application on a Nokia N95 under the same testing conditions, and it works perfectly.


    Thanks in advance,
    JCC.
    Last edited by juanchoc; 2011-03-29 at 20:03. Reason: Update - Device Specific Problem - Nokia C7

  2. #2
    Super Contributor
    Join Date
    Nov 2009
    Location
    Minnesota, USA
    Posts
    3,209

    Re: [Qt SDK 1.1] Conn. Failed - Conn. Unavailable

    In general, Symbian phones network poorly when no SIM is installed (which is, of course, the usual case for development phones). There seems to be very little interest in fixing this.

  3. #3
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: [Qt SDK 1.1] Conn. Failed - Conn. Unavailable

    Quote Originally Posted by juanchoc View Post
    Hi everyone!
    I'm having a hard time with networking using the latest Qt Sdk 1.1 (Qt 4.7.2, Qt Mobility 1.1.1, Qt Creator 2.1).
    Surely Qt Creator should not be to blame in all this story, it is just an IDE after all.

    Quote Originally Posted by juanchoc View Post
    I've tried every example and idea I could think of, but I couldn't get it working.
    Are you saying that existing example applications do not work either? Which ones have you tried?

    Quote Originally Posted by juanchoc View Post
    I'm 100% sure this is related to the new SDK (be it a problem with Qt 4.7.2 or with Qt Mobility 1.1.1), because I had a sample working fine with the SDK 1.0, that now doesn't work anymore.
    Can you share that code? Or basically the smallest code sample you have that can help reproduce the problem ...

    Quote Originally Posted by juanchoc View Post
    Besides, it seems to work fine on the emulator, but not on a real device (I've tested it on a Nokia C7).
    Not really comparable when it comes to network capabilities, after all the Qt Simulator build is a Windows build and not a Symbian one.

    Quote Originally Posted by juanchoc View Post
    Every time I try to establish a connection, I get a balloon tip on the top of the screen displaying "Conn. Failed Conn. Unavailable". I've tried that with both an already established wifi connection (which works perfectly on the phone's browser), and only using the USB connection, both scenarios fail in the same way.
    There doesn't seem to be any other error besides that balloon tip.

    We are working on a very big project, for a major US corporation, and one of Nokia Senior Architects suggested we use the SDK 1.1... please if someone can help me out with this, I'll be really thankful.
    Well, I would not expect someone on this forum to contradict the Nokia's Senior Architects .... Oh, wait, let me do it: the SDK you're talking about is a beta SDK, providing a Qt version not yet supported by Ovi Store. So unless you know what you are doing, and unless you really need some of this SDK's features, then you should NOT used it. Which does not mean that the SDK is necessarily broken, but ...

    Quote Originally Posted by juanchoc View Post
    UPDATE:
    This seems to be a device specific problem. I've tested the same application on a Nokia N95 under the same testing conditions, and it works perfectly.


    Thanks in advance,
    JCC.
    You cannot compare a S60 3.1 device with a Symbian^3 one and then make the assumption that the defect is device specific. After all, those two devices are 3 generations apart, with at least two of them having significant re-work on the networking system (Application Level Roaming, FreeWay ... ).

    Quote Originally Posted by danhicksbyron View Post
    In general, Symbian phones network poorly when no SIM is installed (which is, of course, the usual case for development phones). There seems to be very little interest in fixing this.
    There's little info above that would suggest that a SIM card is not present. It is true that when developing phones are mostly SIM-less but that should not be the testing environment, especially once problems have been identified and are about to be reported, so I'm sure that Juan would have told us if that really makes a difference...
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  4. #4
    Registered User
    Join Date
    Aug 2009
    Posts
    12

    Re: [Qt SDK 1.1] Conn. Failed - Conn. Unavailable

    Thanks for your answer danhicksbyron!

    Quote Originally Posted by danhicksbyron View Post
    In general, Symbian phones network poorly when no SIM is installed (which is, of course, the usual case for development phones). There seems to be very little interest in fixing this.
    I've tried both with and without a SIM card with no success.

  5. #5
    Registered User
    Join Date
    Aug 2009
    Posts
    12

    Re: [Qt SDK 1.1] Conn. Failed - Conn. Unavailable

    Quote Originally Posted by ltomuta View Post
    Surely Qt Creator should not be to blame in all this story, it is just an IDE after all.
    I know, I know, but at first I thought it might be something related to my development environment or my code.

    Quote Originally Posted by ltomuta View Post
    Are you saying that existing example applications do not work either? Which ones have you tried?
    Well, too many to remember them all.
    This are the ones that I've kept at hand:

    http://wiki.forum.nokia.com/index.ph..._QNetworkReply
    http://wiki.forum.nokia.com/index.ph..._request_in_Qt
    http://wiki.forum.nokia.com/index.ph...nnection_in_Qt

    Quote Originally Posted by ltomuta View Post
    Can you share that code? Or basically the smallest code sample you have that can help reproduce the problem ...
    This is the sample I'm currently using:
    http://wiki.forum.nokia.com/index.ph..._QNetworkReply

    It seems to be the most stable sample around.

    Quote Originally Posted by ltomuta View Post
    Not really comparable when it comes to network capabilities, after all the Qt Simulator build is a Windows build and not a Symbian one.
    True. I always avoid using the Qt Simulator, because most of the time I end up with very different results between the simulator and the real devices its suppose to emulate.

    Quote Originally Posted by ltomuta View Post
    Well, I would not expect someone on this forum to contradict the Nokia's Senior Architects .... Oh, wait, let me do it: the SDK you're talking about is a beta SDK, providing a Qt version not yet supported by Ovi Store. So unless you know what you are doing, and unless you really need some of this SDK's features, then you should NOT used it. Which does not mean that the SDK is necessarily broken, but ...
    LOL, well, I asked this specific Nokia Senior Architect about which version should I use (considering the restrictions on the Ovi Store deployment, and stability), and he told me to use the SDK 1.1 beta. I also thought it was a bit weird for him to suggest we use a beta SDK...
    I think I'm going to sugest switching to Qt 4.7.0, which I hope is more stable, or else to Qt 4.6.3 (i would rather not go as far as 4.6.3 because there are many features of 4.7.0 that we need and would have to be made from scratch on 4.6.3).

    Quote Originally Posted by ltomuta View Post
    You cannot compare a S60 3.1 device with a Symbian^3 one and then make the assumption that the defect is device specific. After all, those two devices are 3 generations apart, with at least two of them having significant re-work on the networking system (Application Level Roaming, FreeWay ... ).
    You're right. Still, I've tried with the Qt Symbian^1 (same .sys file) on both devices, and on the N95 8gb it works, and on the C7 it doesn't.

    Quote Originally Posted by ltomuta View Post
    There's little info above that would suggest that a SIM card is not present. It is true that when developing phones are mostly SIM-less but that should not be the testing environment, especially once problems have been identified and are about to be reported, so I'm sure that Juan would have told us if that really makes a difference...
    That's correct, I've tried with both a SIM card installed (with 3G working), and without a SIM card. The problem remained on both scenarios.

  6. #6
    Registered User
    Join Date
    Aug 2009
    Posts
    12

    Re: [Qt SDK 1.1] Conn. Failed - Conn. Unavailable

    Well, now I'm quite sure it is something device specific (in fact, something about the C7 i have), because I've tried the same application with a Nokia C7 from Forum Nokia remote devices, and it worked like a charm.
    This are the details of this phone.

    Release
    92_201042_hw79 PRD

    Software version
    020.016

    Software version date
    2010-10-21

    Custom version
    020.016.00.01

    Custom version date
    2010-10-21

    Language set
    020.016.01.01

    Product code
    059B4X9

    Model
    C7-00

    Type
    RM-675

    Latest update
    Not updated

    Browser version
    7.3

    Flash version
    4.0

    Java version
    2.2

    Product code
    059B4X9

    I've tried to update the firmware with both Nokia Ovi Suite and directly from the cellphone in Device updates, but i get the same balloon tip saying "Conn. failed Conn. unavailable".
    In fact, I restored the phone to factory defaults, but the problem continues.

    Any ideas?

  7. #7
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: [Qt SDK 1.1] Conn. Failed - Conn. Unavailable

    Do try an RDA C7 device which has the same firmware version as your current device (i.e. PR 1.x)
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  8. #8
    Registered User
    Join Date
    Aug 2009
    Posts
    12

    Re: [Qt SDK 1.1] Conn. Failed - Conn. Unavailable

    After reinstalling all of the Qt dependencies on the device again (after doing a restore to factory defaults), it suddenly started working on it's own. LOL

    Thanks for your help Itomuta!
    Greatly appreciated that you took the time to answer!

  9. #9
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: [Qt SDK 1.1] Conn. Failed - Conn. Unavailable

    Glad to hear that. Good luck with the rest of your app.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. CSocketsEngine Conn. Failed -4158??
    By prakashsainani in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2003-09-10, 19:23
  2. Using Conn. SDK without Conn. Manager
    By Chienkuo in forum PC Suite API and PC Connectivity SDK
    Replies: 0
    Last Post: 2003-06-10, 09:21
  3. PC Conn SDK 2.1 and 6310
    By dzaga in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2002-11-19, 06:22
  4. 5110 & PC conn SDK
    By indisoft in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2002-07-17, 06:34
  5. PC Conn. SDK On WIN NT
    By saleemr in forum PC Suite API and PC Connectivity SDK
    Replies: 0
    Last Post: 2002-06-17, 07:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×