×

Discussion Board

Results 1 to 12 of 12
  1. #1
    Regular Contributor
    Join Date
    Nov 2008
    Posts
    138

    [moved] Smart Installer - Device not supported

    Hello,

    for some reason I get "Device not supported" error when I try to install application to E7 device. What could cause this?

    Code:
    symbian {
        LIBS += -lcone -leikcore -lavkon # For forcing display to portrait mode
        TARGET.UID3 = 0x2003XXXX
        TARGET.CAPABILITY += Location NetworkServices UserEnvironment
        TARGET.EPOCHEAPSIZE = 0x40000 0x6000000
        ICON = appicon.svg
    
        DEPLOYMENT.installer_header=0x2002CCCF
    
        vendorinfo = \
          "%{\"XXX\"}" \
          ":\"XXX\""
    
        my_deployment.pkg_prerules = vendorinfo
        DEPLOYMENT += my_deployment
    }

    # 1. xxx/make distclean
    # 2. xxx/qmake
    # 3. xxx/make release-gcce
    # 4a. xxx/make sis QT_SIS_CERTIFICATE=OVI_2011-02-01.crt QT_SIS_KEY=OVI_2011-02-01.key
    # 4b. xxx/src/make installer_sis QT_SIS_CERTIFICATE=OVI_2011-02-01.crt QT_SIS_KEY=OVI_2011-02-01.key

    Regards,
    FoL

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: [moved] Smart Installer - Device not supported

    Any hints in the log files? (c:\logs\ADM)
    What is the reported machine UID on that device?
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Registered User
    Join Date
    Feb 2011
    Posts
    1

    Re: [moved] Smart Installer - Device not supported

    Hi

    I have probably the same problem. From logs:
    28.03.2011 21:39:41 FileCheck: c:\sys\bin\qmlwebkitplugin.dll (0)
    28.03.2011 21:39:41 Package 0x200267C2 files present
    28.03.2011 21:39:41 Package 0x200267C2: v4.08.0 installed (v4.07.2 requested)
    28.03.2011 21:39:41 + SetState(): 2 -> 3
    28.03.2011 21:39:41 Downloading CHANGES: '200267c2_changes.xml'
    28.03.2011 21:39:42 Starting download
    28.03.2011 21:39:42 DL 7370/ 7370 (0.3 s, 22.27 kB/s) (total: 7 kB, 0.3 s, avg 22.27 kB/s) OK
    28.03.2011 21:39:42 + SetState(): 3 -> 4
    28.03.2011 21:39:42 + ParseChangesFileL(): 'C:\system\adm\200267c2_changes.xml'
    28.03.2011 21:39:42 + SM::RunError(): 4, 20
    28.03.2011 21:39:42 ! Package 0x200267C2 v4.07.2 (qtwebkit) not available for 0x20029A73
    28.03.2011 21:39:42 Exiting due to failure 4

    Device is N8 and it has 4.7.2 installed previously. I have no idea why it thinks there is already 4.08.0. Anyway it fails to fetch webkit.
    Plain unwrapped .sis installs and runs fine. Any suggestions how to proceed with Calling all Innovators competition submit?

    Br, aa

  4. #4
    Regular Contributor
    Join Date
    Nov 2008
    Posts
    138

    Re: [moved] Smart Installer - Device not supported

    Quote Originally Posted by ltomuta View Post
    Any hints in the log files? (c:\logs\ADM)
    What is the reported machine UID on that device?
    I don't have (c:\logs\ADM) at all. I used Office -> File mgr. application.

  5. #5
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: [moved] Smart Installer - Device not supported

    Quote Originally Posted by forceoflight View Post
    I don't have (c:\logs\ADM) at all. I used Office -> File mgr. application.
    Use a full featured file manager (like Y-Browser) and make sure to create the c:\logs\ADM, then reinstall the app and collect the logs.
    The built-in File Manager shows c:\Data mapped as "Phone memory"/C: drive.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  6. #6
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: [moved] Smart Installer - Device not supported

    Quote Originally Posted by antti@mureke.fi View Post
    Hi

    I have probably the same problem. From logs:
    28.03.2011 21:39:41 FileCheck: c:\sys\bin\qmlwebkitplugin.dll (0)
    28.03.2011 21:39:41 Package 0x200267C2 files present
    28.03.2011 21:39:41 Package 0x200267C2: v4.08.0 installed (v4.07.2 requested)
    28.03.2011 21:39:41 + SetState(): 2 -> 3
    28.03.2011 21:39:41 Downloading CHANGES: '200267c2_changes.xml'
    28.03.2011 21:39:42 Starting download
    28.03.2011 21:39:42 DL 7370/ 7370 (0.3 s, 22.27 kB/s) (total: 7 kB, 0.3 s, avg 22.27 kB/s) OK
    28.03.2011 21:39:42 + SetState(): 3 -> 4
    28.03.2011 21:39:42 + ParseChangesFileL(): 'C:\system\adm\200267c2_changes.xml'
    28.03.2011 21:39:42 + SM::RunError(): 4, 20
    28.03.2011 21:39:42 ! Package 0x200267C2 v4.07.2 (qtwebkit) not available for 0x20029A73
    28.03.2011 21:39:42 Exiting due to failure 4

    Device is N8 and it has 4.7.2 installed previously. I have no idea why it thinks there is already 4.08.0. Anyway it fails to fetch webkit.
    Plain unwrapped .sis installs and runs fine. Any suggestions how to proceed with Calling all Innovators competition submit?

    Br, aa
    You cannot use Smart Installer for testing/deploying Qt 4.7.2. See list of supported packages at http://nokia.ly/SmartInstaller
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  7. #7
    Regular Contributor
    Join Date
    Nov 2008
    Posts
    138

    Re: [moved] Smart Installer - Device not supported

    Something doesn't match. You must submit app to Ovi QA for participating to Calling Innovator Competition. How do QA team verify your app if they cannot install app to their device?

    http://www.callingallinnovators.com/10m/

    Q: Smart Installer currently supports only Qt SDK 1.0 apps. If I have a Qt SDK 1.1 Beta app, should I use the Smart Installer or submit the SIS file without the Smart Installer?
    A: Qt SDK 1.1 Beta apps should be packaged with the Nokia Smart Installer as documented at http://wiki.forum.nokia.com/index.ph..._the_Ovi_Store. Although the documentation currently refers only to the Qt SDK 1.0, Qt SDK 1.1 Beta apps should be packaged with the Smart Installer according to those instructions.

  8. #8
    Regular Contributor
    Join Date
    Nov 2008
    Posts
    138

    Re: [moved] Smart Installer - Device not supported

    Stupid question, but how can you make a file by using Y-Browser? It creates a zip file. I cannot see any logs, if I create a zip file and name it as ADM. I created file to both places:

    c:\logs\ADM
    c:\data\logs\ADM

    Quote Originally Posted by ltomuta View Post
    Use a full featured file manager (like Y-Browser) and make sure to create the c:\logs\ADM, then reinstall the app and collect the logs.
    The built-in File Manager shows c:\Data mapped as "Phone memory"/C: drive.

  9. #9
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: [moved] Smart Installer - Device not supported

    Quote Originally Posted by forceoflight View Post
    Stupid question, but how can you make a file by using Y-Browser? It creates a zip file. I cannot see any logs, if I create a zip file and name it as ADM. I created file to both places:

    c:\logs\ADM
    c:\data\logs\ADM
    Why do I think that you should be very famiar with RFileLogger and its way of working? The ADM is a directory, not a file, and you create it using the Options -> File -> New forder option.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  10. #10
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: [moved] Smart Installer - Device not supported

    Quote Originally Posted by forceoflight View Post
    Something doesn't match. You must submit app to Ovi QA for participating to Calling Innovator Competition. How do QA team verify your app if they cannot install app to their device?

    http://www.callingallinnovators.com/10m/

    Q: Smart Installer currently supports only Qt SDK 1.0 apps. If I have a Qt SDK 1.1 Beta app, should I use the Smart Installer or submit the SIS file without the Smart Installer?
    A: Qt SDK 1.1 Beta apps should be packaged with the Nokia Smart Installer as documented at http://wiki.forum.nokia.com/index.ph..._the_Ovi_Store. Although the documentation currently refers only to the Qt SDK 1.0, Qt SDK 1.1 Beta apps should be packaged with the Smart Installer according to those instructions.
    Well, the organisers of the CAI 10M competition wanted to help you out and allow/support development of Qt 4.7.2 applications. Unfortuantely that does not match well with the SDK release schedule and with Ovi Store's full support for Qt 4.7.2
    I'm afraid I cannot give you any guidance regarding CAI's submission rules as they stand now. But if Ovi asks for a Smart Installer packaged application, then that is what you should provide and then let the CAI/Ovi Store team wory about the testing.
    Last edited by ltomuta; 2011-03-31 at 08:33. Reason: Corrected. It is the Ovi Store that asks for SI wrapped apps, not CAI.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  11. #11
    Registered User
    Join Date
    Feb 2006
    Location
    Espoo, Finland
    Posts
    43

    Question Re: [moved] Smart Installer - Device not supported

    Hi
    I tried to install my app relying on openc and pips lib for E7 but got the same Device Not supported error:
    Code:
    (0x2000F866), 1, 6, 0 ~ *, *, *, {"Standard C++ library Common"}
    (0x20013851), 1, 6, 0 ~ *, *, *, {"PIPS Installer"}
    and c:/logs/adm/log.txt content is:
    Code:
    12/04/2011	12:46:34	CADMAppUi::CADMAppUi()
    12/04/2011	12:46:34	+ CADMAppUi::ConstructL()
    12/04/2011	12:46:35	+ ProcessCommandLineArgsL(): 7
    12/04/2011	12:46:35	Arg[0]='C:\sys\bin\ADM.exe'
    12/04/2011	12:46:35	Arg[1]='1519'
    12/04/2011	12:46:35	Arg[2]='4'
    12/04/2011	12:46:35	Arg[3]='537054415'
    12/04/2011	12:46:35	Arg[4]='10'
    12/04/2011	12:46:35	Arg[5]='3'
    12/04/2011	12:46:35	Arg[6]='e:\private\2002CCCE\import\IF_3rdFP2_4smart.sisx'
    12/04/2011	12:46:35	(cmd) pVer(raw) = 1519 (5ef)
    12/04/2011	12:46:35	(cmd) BVersion: 4
    12/04/2011	12:46:35	(cmd) Wrapper Uid: 0x2002CCCF
    12/04/2011	12:46:35	(cmd) IAP: 10
    12/04/2011	12:46:35	CDownloadHandler::SetIap(): 10
    12/04/2011	12:46:35	(cmd) LState 3
    12/04/2011	12:46:35	(cmd) SisFile: 'e:\private\2002CCCE\import\IF_3rdFP2_4smart.sisx'
    12/04/2011	12:46:35	- ProcessCommandLineArgsL(): 7->7
    12/04/2011	12:46:35	+ GetPhoneInformation()
    12/04/2011	12:46:35	  machine uid = 0x2002bf96
    12/04/2011	12:46:35		Sw Ver = 014.002.2011-03-01.RM-626.(c) Nokia
    12/04/2011	12:46:35	- GetPhoneInformation (0)
    12/04/2011	12:46:35	configFile = C:\Private\2002ccce\config.ini
    12/04/2011	12:46:35	configUrl = http://dl.qt.nokia.com/smartinstaller/ (default)
    12/04/2011	12:46:36	+ CStateMachine::Start()
    12/04/2011	12:46:36	- CADMAppUi::ConstructL()
    12/04/2011	12:46:36	+ SetState(): 0 -> 1
    12/04/2011	12:46:36	Installer pkg on E: (1)
    12/04/2011	12:46:36	* Parsing 'e:\private\2002CCCE\import\IF_3rdFP2_4smart.sisx'
    12/04/2011	12:46:36	+ SetState(): 1 -> 2
    12/04/2011	12:46:36	+ BuildDepTreeL(0)
    12/04/2011	12:46:36	* Processing 0x2000F866 (0, 0)
    12/04/2011	12:46:36	Package 0x2000F866: v1.06.0 to be downloaded
    12/04/2011	12:46:36	+ SetState(): 2 -> 3
    12/04/2011	12:46:36	Downloading CHANGES: '2000f866_changes.xml'
    12/04/2011	12:46:37	Starting download
    12/04/2011	12:46:37	DL    5885/   5885 (0.3 s, 20.34 kB/s) (total: 5 kB, 0.3 s, avg 20.34 kB/s) OK
    12/04/2011	12:46:37	+ SetState(): 3 -> 4
    12/04/2011	12:46:37	+ ParseChangesFileL(): 'C:\system\adm\2000f866_changes.xml'
    12/04/2011	12:46:37	+ SM::RunError(): 4, 20
    12/04/2011	12:46:37	! Package 0x2000F866 v1.06.0 (stdcpp) not available for 0x2002BF96
    12/04/2011	12:46:37	Exiting due to failure 4
    12/04/2011	12:46:37	+ SetState(): 4 -> 16
    12/04/2011	12:46:37	+ CADMAppUi::HandleFailure(): 16. err=4, m=3
    12/04/2011	12:46:37	- CADMAppUi::HandleFailure(): 0
    12/04/2011	12:46:38	+ SetState(): 16 -> 15
    12/04/2011	12:46:38	About to uninstall wrapper
    12/04/2011	12:46:38	+ SetState(): 15 -> 18
    12/04/2011	12:46:38	Exit (4)
    12/04/2011	12:46:38	Uninstalling wrapper 0x2002CCCF
    12/04/2011	12:46:46	CInstallManager: Install completed (0). 0
    12/04/2011	12:46:46	HandleInstallCompletedL(0): 18
    12/04/2011	12:46:46	+ TStateExit::InstallCompleted(0): 4, 4
    12/04/2011	12:46:46	+ CADMAppUi::ExitApp(): 4, 0
    12/04/2011	12:46:50	ADM icon hidden: 1 (0)
    12/04/2011	12:46:50	CADMAppUi::~CADMAppUi()
    12/04/2011	12:46:50	+ CStateMachine::Stop(): 0 pkgs installed.
    12/04/2011	12:46:50	Total 5 kB in 0.3 s, avg 20.34 kB/s (15.9 s)
    Should I try different library versions? Or E7 has built in openc library which is earlier that 1.6?
    Ovi store is installed on the phone, but I don't see any openc packages installed in application manager. Should I try to install some application from ovi suite which rely on Qt and openc and see if it brings the dependant library?

    Anyway E7 is not in the list of unsupported devices so hopefully it will work in the end.

  12. #12
    Registered User
    Join Date
    Feb 2006
    Location
    Espoo, Finland
    Posts
    43

    Re: [moved] Smart Installer - Device not supported

    Ok. Looks like E7 is really not presented in changes.xml files for stdcpp and pips:
    http://dl.qt.nokia.com/smartinstalle...66_changes.xml
    http://dl.qt.nokia.com/smartinstalle...51_changes.xml

    I suppose it's because it's already present on the phone, so there is no need to download it. I tried to install application to the phone without mentioning this dependency and it worked after I didn't wrap it with smartinstaller at all.

    So looks like I'll have one more installation package to maintain - for S^3 phones without using smartinstaller? Or are there some s^3 phones which require stdcpp to be downloaded? Could there be 5th edition phones which also doesn't include stdcpp and pips UID in their smartinstaller changes.xml files, but have it installed by default?
    Would be good to have a list of those and not to check them one by one...

Similar Threads

  1. [moved] Do I need the Smart Installer?
    By john_god in forum Qt
    Replies: 10
    Last Post: 2011-03-17, 00:15
  2. [moved] Application version for outer smart installer package
    By nETPOBu4 in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 1
    Last Post: 2011-02-16, 11:00
  3. Please add Python runtime to dependencies supported by Smart Installer
    By dehlerm in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 4
    Last Post: 2010-08-18, 21:45
  4. [moved] Smart Installer for application signed with a devcert
    By JohnAndy in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 2
    Last Post: 2010-07-19, 17:23
  5. [moved] SDK Install (was Smart installer how-to)
    By codestain in forum Symbian Tools & SDKs
    Replies: 7
    Last Post: 2010-06-20, 21:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×