×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jan 2009
    Location
    Penang, Malaysia
    Posts
    3

    QNetworkAccessManager compilation error on device

    i created a Qt project (Qt SDK 1.0) from Qt Mobile Application Template, and added below line in one of the header file
    #include <QNetworkAccessManager>

    added below to project file
    QT += core gui network

    it passed compilation and run on simulator. but i have an error when i switch my project to run on device.
    it shown below:
    QNetwork AccessManager: No such file or directory

    any idea what i missed here?

  2. #2
    Regular Contributor
    Join Date
    Dec 2008
    Posts
    145

    Re: QNetworkAccessManager compilation error on device

    i get this error
    is it something wrong with my installation? i guess i must try to setup in another pc to see

    Running build steps for project testHK...
    Starting: "c:\qtsdk\symbian\sdks\symbian3qt472\bin\qmake.exe" C:\nokia_qt_projects\testHK\testHK.pro -r -spec symbian-sbsv2 CONFIG+=release -after OBJECTS_DIR=obj MOC_DIR=moc UI_DIR=ui RCC_DIR=rcc QMLJSDEBUGGER_PATH=C:/QtSDK/QtCreator/share/qtcreator/qml/qmljsdebugger
    The process "c:\qtsdk\symbian\sdks\symbian3qt472\bin\qmake.exe" exited normally.
    Starting: "C:\QtSDK\Symbian\SDKs\Symbian3Qt472\epoc32\tools\make.exe" release-gcce -w
    C:\QtSDK\Symbian\SDKs\Symbian3Qt472\epoc32\tools\make.exe: Entering directory `C:/nokia_qt_projects/testHK'
    sbs -c arm.v5.urel.gcce4_4_1
    C:\QtSDK\Symbian\SDKs\Symbian3Qt472\epoc32\tools\make.exe: Leaving directory `C:/nokia_qt_projects/testHK'
    ImportError: No module named site
    C:\QtSDK\Symbian\SDKs\Symbian3Qt472\epoc32\tools\make.exe: *** [release-gcce] Error 1
    The process "C:\QtSDK\Symbian\SDKs\Symbian3Qt472\epoc32\tools\make.exe" exited with code 2.
    Error while building project testHK (target: Symbian Device)
    When executing build step 'Make'

  3. #3
    Regular Contributor
    Join Date
    Dec 2008
    Posts
    145

    Re: QNetworkAccessManager compilation error on device

    Quote Originally Posted by xiaohanlouie View Post
    i created a Qt project (Qt SDK 1.0) from Qt Mobile Application Template, and added below line in one of the header file
    #include <QNetworkAccessManager>

    added below to project file
    QT += core gui network

    it passed compilation and run on simulator. but i have an error when i switch my project to run on device.
    it shown below:
    QNetwork AccessManager: No such file or directory

    any idea what i missed here?
    i solve this problem by installing and running Qt SDK 1.1 beta on a windows XP 32 bit machine. Here is the output. Is it Qt SDK 1.1 beta is not compatible with Windows 7 64 bit? (the problem i faced in thread #2 is on windows 7 64 bit)

  4. #4
    Registered User
    Join Date
    Jan 2009
    Location
    Penang, Malaysia
    Posts
    3

    Re: QNetworkAccessManager compilation error on device

    Quote Originally Posted by weiwei2 View Post
    i solve this problem by installing and running Qt SDK 1.1 beta on a windows XP 32 bit machine. Here is the output. Is it Qt SDK 1.1 beta is not compatible with Windows 7 64 bit? (the problem i faced in thread #2 is on windows 7 64 bit)
    yes... this issue resolved with SDK 1.1 beta. No more compilation error for Device. And i follow below steps to debug on device.
    But not sure when the SDK 1.1 beta will avaible for OVI store app.

    Developing for Symbian^31.Choose Start > Qt SDK > Symbian^3 > Install Qt 4.7.1 to Symbian^3 Device. Follow the instructions on the screen to install Qt libraries to the device.
    2.Choose Start > Qt SDK > Symbian^3 > Install QtMobility 1.1.0 to Symbian^3 Device and follow the instructions on the screen to install Qt mobility libraries to the device.
    3.Choose Start > Qt SDK > Symbian^3 > Install TRK (Debug Agent) to Symbian^3 Device and follow the instructions on the screen to install the TRK debugging application (s60_tb_9_2_app_trk_3_2_8.sisx) to the device.

Similar Threads

  1. Replies: 4
    Last Post: 2007-05-31, 07:06
  2. HelloWorld.rsc "Error 1" on Phone Release compilation
    By fogo99 in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 7
    Last Post: 2007-02-15, 08:37

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×