×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Jun 2005
    Posts
    5

    Re: Installation security error. Unable to Install. - Solved by changing date

    Here's how I got the error "Installation security error. Unable to Install." and solved it...

    I tell the full story what I was trying to do...
    I was copying contacts from Nokia 6680 to N8.
    First, I tried to make a back-up with PC Suite, but it failed: The contacts would not be copied from 6680 to the computer (in a NBU file). PC Suite just gave the error "a fatal error happened during the backup operation" error code 0x80400005.

    Then, I tried the Phone Switch application, which is supposed to copy contacts to N8 from another phone. I activated the Phone Switch in the N8 (applications -> tools -> phone setup -> data transfer -> another phone).
    Phone Switch attempted, using Bluetooth, to install the required application also to the 6680. However, installation on the 6680 failed with the error: "Installation security error. Unable to Install."

    Then I found the information on zolved.com discussions: The phone date (the 6680 phone's date) must be earlier than 12.6.2007! Then it worked!!! (I set the 6680's date to 1st March 2007, that made the trick)

    Finally I was able to install the copier application and transfer my contacts. But why on earth is this crazy date setting thing needed, before I can install some application!?
    Unbelievable.

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,740

    Re: Installation security error. Unable to Install. - Solved by changing date

    If it happens to be a signed application (which is not a requirement, but a possibility on S60 2nd edition too), the signature has an expiration date. However the topic of this thread was Java (so I do not know what it does here in Symbian C++ boards), and it happened 5-9 years ago (so I do not know why you picked this one to revive).
    Will cut this thread into half and move the parts into appropriate boards on 30/03.

    [EDIT: Cut happened, though later. Original thread is kept and moved to the Java boards: http://discussion.forum.nokia.com/fo...le-to-Install.]
    Last edited by wizard_hu_; 2011-04-02 at 23:27.

  3. #3
    Registered User
    Join Date
    Jun 2005
    Posts
    5

    Re: Installation security error. Unable to Install. - Solved by changing date

    Thanks for your comment wizard_hu_ and thanks for moving the parts to appropriate boards.

    I picked this thread by random Googling, I think
    I just wanted to share the knowledge about how to solve the error

Similar Threads

  1. "unable to install" error during IMSIReader Installation
    By anwar21387 in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 46
    Last Post: 2009-05-29, 02:51
  2. Installation Security Error. Unable to install.
    By seanlks82 in forum Mobile Java Networking & Messaging & Security
    Replies: 2
    Last Post: 2007-08-08, 11:45
  3. Installation security error. Unable to Install.
    By nallott in forum Mobile Java General
    Replies: 3
    Last Post: 2005-09-19, 07:58
  4. Installation Security Error! Unable To Install
    By jinesh_l in forum Mobile Java General
    Replies: 0
    Last Post: 2005-09-19, 06:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×