×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Nov 2010
    Posts
    42

    autostart problem

    Hi, all Symbian Experts!

    I need your help.
    I have Nokia5230.
    I am developing an application which starts at phone boot time.

    /*
    ============================================================================
    Name : EAF210C4.rss
    Author :
    Copyright : Your copyright notice
    Description : This file contains all the resources for the myapp.
    ============================================================================
    */

    #include <appinfo.rh>
    #include <startupitem.rh>

    UID2 KUidAppRegistrationResourceFile
    UID3 0xEAF210C4

    RESOURCE APP_REGISTRATION_INFO
    {
    app_file = "MyApp";
    embeddability = KAppNotEmbeddable;
    newfile = KAppDoesNotSupportNewFile;
    }


    RESOURCE STARTUP_ITEM_INFO myapp
    {
    executable_name = "c:\\sys\\bin\\myapp.exe";
    recovery = EStartupItemExPolicyNone;
    }

    //myapp.mmp
    START RESOURCE ..\data\EAF210C4.rss
    TARGETPATH \private\10003a3f\apps
    END
    ...
    CAPABILITY NetworkServices WriteUserData ReadUserData

    //myapp.pkg

    ; Languages
    &EN

    ; Header
    #{"myapp"},(0xEAF210C4),1,0,0,TYPE=SA

    ; Platform compatibility
    ;[0x101F7961], *, *, *, {"Series60ProductID"}

    ; vendor
    %{"Vendor Name"}
    :"Vendor Name"

    ; Target
    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\myapp.exe"-"c:\sys\bin\myapp.exe"
    "$(EPOCROOT)Epoc32\data\z\private\10003a3f\apps\EAF210C4.rSC"-"c:\private\101f875a\import\[EAF210C4].rSC"



    But myapp doesn't excute at phone boot time.
    What's wrong?

  2. #2
    Nokia Developer Champion
    Join Date
    Feb 2009
    Location
    India
    Posts
    1,173

    Re: autostart problem

    But myapp doesn't excute at phone boot time.
    What's wrong?
    I hope its not a self signed application. Is it?

  3. #3
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,572

    Re: autostart problem

    If self-signed is the problem, use Open Signed Online, http://www.symbiansigned.com

  4. #4
    Registered User
    Join Date
    Nov 2010
    Posts
    42

    Re: autostart problem

    Thanks wizard_hu_ and not_dying .
    I have resolved using Open Signed Online!

Similar Threads

  1. Autostart problem
    By remesh in forum Symbian
    Replies: 7
    Last Post: 2009-09-11, 13:17
  2. HELP....autostart problem
    By Adrian99420 in forum Symbian
    Replies: 3
    Last Post: 2008-03-20, 06:50
  3. Autostart signing problem
    By marcinkrol84 in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 9
    Last Post: 2007-07-05, 10:25
  4. Autostart Problem
    By Utk in forum Symbian
    Replies: 5
    Last Post: 2007-04-20, 14:00
  5. about autostart problem
    By ld_road in forum Symbian
    Replies: 1
    Last Post: 2005-01-11, 01:15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •