×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Oct 2010
    Posts
    66

    GetInstalledApps example is not Working................

    Hello Friends ,
    I download the example from http://wiki.forum.nokia.com/index.ph..._its_UID_in_Qt , there is an error due to LIBS += -lswinstcli and due to #include <SWInstApi.h> #include <SWInstDefs.h>.

    Can any body tell me how can i add this library file and debug the code successfully...........

    Thanks

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: GetInstalledApps example is not Working................

    your link is not working, anyway, do check whether the API is part of public SDK, or whether it is part of API plug-in.

  3. #3
    Registered User
    Join Date
    Oct 2010
    Posts
    66

    Re: GetInstalledApps example is not Working................

    http://www.google.co.in/url?sa=t&sou...SKqMPw&cad=rja



    can you please try this link for example for me......

  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: GetInstalledApps example is not Working................

    http://wiki.forum.nokia.com/index.ph..._its_UID_in_Qt (looks the same but it actually works, as it wan't badly copied from some other post) is the link and there are two problems with the code snippet:
    - class XQInstaller is part of the deprecated Mobility Extensions project, and should not have any more value than as example code
    - swinstcli is the library belonging to the non-public SW Installer Launcher API which is part of the SDK API Plug-in and therefore should not be used unless really really really badly needed by a developer who knows what he does. For the particular use case illustrated in this wiki article the library is not even needed.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  5. #5
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: GetInstalledApps example is not Working................

    google search for the missing headers got me this link: http://wiki.forum.nokia.com/index.ph...r_Launcher_API and as you can see the headers are not part of public SDK. Anyway, if you want you could use Symbian C++ for the task: http://wiki.forum.nokia.com/index.ph...d_applications, it would also require less capabilities.

  6. #6
    Registered User
    Join Date
    Oct 2010
    Posts
    66

    Re: GetInstalledApps example is not Working................

    Thanks, but in Symbian C++ code , how can read data fromCDesCArrayFlat* MyArray = new(ELeave) CDesCArrayFlat(KArrGranularity); and save as a text file or show in a list.......??????

    I am facing problem in reading data from MyArray .......pls. help me

  7. #7
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: GetInstalledApps example is not Working................

    listbox would take the array normally, just make sure the tabs are there for separating the columns. For writing a file, you could copy each element one-by-one to 8-bit wide descriptor, and write that to the file with RFile for example.

  8. #8
    Registered User
    Join Date
    Oct 2010
    Posts
    66

    Re: GetInstalledApps example is not Working................

    Thanks....it is working for Name of Installed application, if i want to know the UID of application , How can i do it ????

  9. #9
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: GetInstalledApps example is not Working................

    have you considered on checking what information you can get in the TApaAppInfo already ?

Similar Threads

  1. WebTV example is not working
    By yabune in forum Symbian
    Replies: 1
    Last Post: 2011-04-14, 05:35
  2. AKNEXQUERY Example is not working
    By lingtao in forum Symbian User Interface
    Replies: 0
    Last Post: 2003-10-20, 01:26
  3. recording is not working in sound example
    By amitagrawal78 in forum Symbian
    Replies: 1
    Last Post: 2002-10-08, 11:08
  4. recording is not working in sound example
    By amitagrawal78 in forum Symbian User Interface
    Replies: 0
    Last Post: 2002-10-08, 10:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×