×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Dec 2010
    Posts
    1

    Playing videos using Qt

    Hello,

    I am developing an App with the capability to play videos (HTTP delivery using Progressive Download). Using a combination of QVideoWidget, QMediaPlayer and QMediaPlaylist [Qt version 4.7.2; QtMobility version 1.01(2)] I've been able to make it work on a Nokia N8, but the problem is that when moving the App to other devices (a C7 and another N8) all the App works fine except for the VideoPlayer. When loading the video I get an error message that seems to come from the OS, not the App: "Conn. Failed. Access Denied"

    I have placed traces on the App in order to determine exactly when this error happens by showing messages for each of the following signals:
    • QMediaPlayer::error(QMediaPlayer::Error)
    • QMediaPlayer::stateChanged(QMediaPlayer::State)
    • QMediaPlayer::mediaStatusChanged(QMediaPlayer::MediaStatus)

    The resulting flow is the following:
    For the working N8
    • media status change 0
    • error 0
    • media status change 2
    • media status change 3
    • new status 1
    • VIDEO PLAYS
    • media status change 6
    • media status change 5

    For non working devices (N8 & C7)
    • media status change 0
    • error 0
    • media status change 2
    • OS Error : "Conn. Failed. Access Denied"
    • After this many "media status change" signals pop-up but without specific order in each of the trials, until the player closes

    After many tries and since the error seems to be from the OS I'm starting to believe that the error might be due to some configuration issue instead of the App, but I really don't know. Any help is more than welcome.

    Best,

    Bittor.

  2. #2
    Nokia Developer Moderator
    Join Date
    Jun 2007
    Location
    Moscow, Russia
    Posts
    1,355

    Re: Playing videos using Qt

    Hello,
    Please check if Internet access point is setted up properly in your non-working devices.
    Could you try to open that URL in default device web browser. Is it able to connect and play video?

Similar Threads

  1. Playing Youtube videos in Java Apps
    By scharffc in forum Mobile Java Media (Graphics & Sounds)
    Replies: 2
    Last Post: 2010-06-06, 09:46
  2. Orientation change while playing videos..
    By mudit.agar in forum Mobile Java General
    Replies: 2
    Last Post: 2010-01-18, 04:12
  3. Is it possible to force playing QVGA videos in 5310XM using J2ME applications?
    By jonathanwong_31 in forum General Development Questions
    Replies: 2
    Last Post: 2008-03-27, 13:18
  4. Playing videos using JSR-135
    By oemer71 in forum Mobile Java Media (Graphics & Sounds)
    Replies: 0
    Last Post: 2005-11-17, 12:37

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •