×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Regular Contributor
    Join Date
    Jul 2010
    Posts
    178

    Signed Application is running in S40 device but not on S60 device

    Hi
    I have signed the JAD File.

    For S40 Device
    When i put the both the JAR and JAD File into the Nokia 2730 Classic.
    The Application is running perfectly with the warnings "From the trusted supplier".
    (when i see in the memory card there is only one file instead of both JAR and JAD)

    For S60 Device
    When i connected through the Nokia OVI PC Suite and install the JAD File of the
    Signed Application it is running with the warnings "not from the trusted supplier"


    My question is why the Signed JAD File is not running with the warnings "from the trusted supplier"?

    Please help me.

  2. #2
    Nokia Developer Champion
    Join Date
    Feb 2009
    Location
    Noida, India
    Posts
    3,073

    Re: Signed Application is running in S40 device but not on S60 device

    Which certificate are you using for signing the app.

    Try downloading the signed app - OTA (over-the-air) to both of your device S60 and S40.
    thanks,
    ~Amitabh
    (Champion of the Month -Aug'13)
    Follow me on my blog for Innovative Mobile Apps

  3. #3
    Regular Contributor
    Join Date
    Jul 2010
    Posts
    178

    Re: Signed Application is running in S40 device but not on S60 device

    Hi
    Thanks for the reply.
    I am using Verisign Certificate.

    For S40
    The JAD File is not downloading with the JAD file type instead it is downloading as EXT file type.
    When i download the JAR File it is downloading and when i run it shows the warning messages. i.e "Not from the trusted supplier"

    For S60
    When i try to download the JAD File when i click on the particular link it hang there(displaying the empty website)
    When i download the JAR File it is downloading and when i run it shows the warning message i.e "Not from the trusted supplier"

    Note:
    I have signed only the JAD File.

  4. #4
    Nokia Developer Champion
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,192

    Re: Signed Application is running in S40 device but not on S60 device

    There could be multiple problems at work in here.

    First of all a clarification. The signing information is stored only in the JAD file, but the signing information is based on the contents in the JAR file. The JAR file (read: manifest) should not contain any signing information.
    Also if you try to install the MIDlet using JAR file only, the result will be an untrusted app (like you describe). You need both JAD and JAR files to install signed MIDlets.

    Download problems: Does your Web server have the correct MIME-types set for both JAR and JAD files?

    Are you sure you are using the correct JAD file for installation? If the phone does not recognize the certificate used in the signing the phone should complain about it and not install the application at all.

    Hartti

  5. #5
    Regular Contributor
    Join Date
    Jul 2010
    Posts
    178

    Re: Signed Application is running in S40 device but not on S60 device

    Hi
    Thanks for the reply.
    How to check the whether my Web Server have the correct MIMI-types set for both JAR and JAD Files?
    Please provide some information it will be useful to me.

    I am sure i have uploaded the correct JAD File.
    And i have tested my phones i.e Nokia 2730 Classic and Nokia 5130 Xpress Music both the phone has the Verisign Certificate.

    Please help me.

  6. #6
    Nokia Developer Champion
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,192

    Re: Signed Application is running in S40 device but not on S60 device

    How you check it depends on what kind of server you are running. this (old) article contains at least the correct MIME types
    http://developers.sun.com/mobility/m...ticles/deploy/

    "For the JAD file type, set the file extension to .jad and the MIME type to text/vnd.sun.j2me.app-descriptor.
    For the JAR file type, set the file extension to .jar and the MIME type to application/java-archive."

    If the device does not complain about incorrect certificate/signature and it does not install as trusted app, the JAD file you are using does not contain the signing information, or you are trying to install the app using JAR only. Could happen because a) you have incorrect JAD on the server b) somehow the phone gets an incorrect JAD from the server c) the phone contains the old, unsigned JAD file and uses that for installation instead of the signed one. etc.

    Hartti

Similar Threads

  1. Application running on emulator but not running on Device
    By syedshakeel2004 in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 3
    Last Post: 2010-09-28, 13:55
  2. Replies: 5
    Last Post: 2010-01-19, 07:04
  3. XML application running on emulator but not on device.
    By deshmukhcv in forum General Development Questions
    Replies: 1
    Last Post: 2008-09-23, 09:08
  4. Detect if Device is S40 or S60 Device
    By Stalkin in forum Mobile Java General
    Replies: 3
    Last Post: 2008-09-01, 12:39
  5. Application is working fine on device but not on emulator
    By Sharmilasrjasthi in forum Symbian C++
    Replies: 21
    Last Post: 2006-06-03, 10:32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •