×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Dec 2010
    Posts
    5

    Making HTTP Connections in S60 Emulator/Device

    I am trying to make a HTTP request from my S60 emulator in which I am facing some problems. I am not able to send the request outside the emulator i.e. the request does not leave the device. I looked at the server logs and I can see the request never reached it. But I get a 'RemoteHostClosedError' after some time. This is after the emulator asks me to choose an access point in which I have only option(winsock) which I am assuming is trying to connect through the network my computer is connected to. I have tried the same piece of code in the QT simulator of QT creator where I get a proper response from the server for the same call. My code is as follows.

    Code:
               m_networkRequest = new QNetworkRequest;
               m_networkRequest->setUrl(QUrl(QString(((CPVXHTTPRequest*)req)->GetRequestURL())));
              m_networkReply = m_networkAccessManager.get(*m_networkRequest);
               QNetworkReply::NetworkError networkError = m_networkReply->error();
    "netWorkError" in the above code gets "NoError", does this mean I am getting no error when my request is sent or is there some other meaning to it.
    When I try to send a request from the emulator's browser, I see that the emulator adds "x-wap-profile" in the HTTP header options. I also tried emulating the same on my code as follows

    Code:
               m_networkRequest->setRawHeader("x-wap-profile", "http://nds1.nds.nokia.com/uaprof/N3250r100.xml");
    This did not help either.

    I think I am missing some option in the HTTP header or I am missing something completely unknown to me. Any direction in this regard will be appreciated.

    My current environment is as given:
    S60 5th Edition
    Qt 4.7
    Carbide 2.7

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Making HTTP Connections in S60 Emulator/Device

    Hi vaidehik

    First things first: does your emulator have clear path to the internet? Start the built-in browser and navigate to ... forum.nokia.com. If it does not work, then you have a proxy issue and you need to set the proxy settings in emulator window's Preferences dialog.
    Then, Qt 4.7.3, the current version recommended for development is not available outside the Qt SDK. Have you built it from source?
    Qt 4.7 also requires OpenC 1.7.5. have you installed that on your SDK before building?
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Registered User
    Join Date
    Mar 2009
    Location
    Chennai, India
    Posts
    49

    Re: Making HTTP Connections in S60 Emulator/Device

    Have you tested it on the device?

Similar Threads

  1. Multiple http connections in 5800
    By jmblazquez in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2009-10-22, 11:09
  2. http connection in J2me(working fine in emulator but not in real device)???
    By prasad767 in forum Mobile Java Networking & Messaging & Security
    Replies: 2
    Last Post: 2006-11-29, 05:14
  3. Replies: 4
    Last Post: 2006-01-28, 16:39
  4. S40 emulator does not allow http connections
    By anobject in forum Mobile Java Networking & Messaging & Security
    Replies: 0
    Last Post: 2005-08-10, 06:55
  5. Making multiple connections to a BT device by using one PSM
    By olhuang in forum Bluetooth Technology
    Replies: 2
    Last Post: 2004-08-11, 02:30

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×