Hi all,
We have an application that requires to open a link in the browser. If we install application without signing application works as it should. when we tried to open the browser phone asks whether to allow the connection or not. if we allow the connection application is closed and browser is opened as it should. however, if we sign the same application, it doesn't allow us to open browser not even asks whether to allow or not. i tried all choices related to connectivity and network under the settings->app manager-> installed apps-> APP_NAME menu but it didn't change anything. In signed application when we tried to open the browser by calling the PlatformRequest method it throws ConnectionNotFoundException exception. Our related code snippet is as follows :

try {
Controller.getInstance().getMidlet().platformRequest(URL);
Controller.getInstance().exit();
} catch (ConnectionNotFoundException e) {
Controller.getInstance().show(new AlertAndShowMenuScreen("error_openbrowser_cannothandle"));
}

we know that URL is a valid wap-site and phone has internet connection (it works when application is not signed). Problem occurs only Symbian^3 phones (N8,C7, E7 etc). signed application also works on S60 and S40 series phones.

Is this a bug or what? how can we solve that problem. we can't publish unsigned application since this is a banking application.