×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Nov 2010
    Posts
    16

    Device not supported error.

    I 've just installed symbian^3 Qt 4.7.3 platform (included in Nokia Qt SDK 1.1 RC) on my N8 ( Qt 4.7.2, Qt Mobility 1.1 & ovi notifications)

    I simply tried to install the same sis file I was installing with the previous SDK, but I always get the installation reverted and the "Device not supported" error.

    Can anyone explains what's going on with the new SDK?

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Device not supported error.

    i suggest you install the Qt runtime sis files from newer symbian^3 Qt 4.7.3 that you have downloaded.

  3. #3
    Registered User
    Join Date
    Nov 2010
    Posts
    16

    Re: Device not supported error.

    I already installed the Qt runtime from sis files in the installation directory(<NokiaQtSDK4.7.3 Dir>/symbian/sis/symbian^3), but it gaves me that error!!

  4. #4
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Device not supported error.

    Quote Originally Posted by ghanemabdo View Post
    I already installed the Qt runtime from sis files in the installation directory(<NokiaQtSDK4.7.3 Dir>/symbian/sis/symbian^3), but it gaves me that error!!
    that is strange . can you show us your .pro and both pkg files might give some clue.

  5. #5
    Registered User
    Join Date
    Jul 2010
    Posts
    36

    Re: Device not supported error.

    I have the same issue, this is pro file content

    # Add files and directories to ship with the application
    # by adapting the examples below.
    # file1.source = myfile
    # dir1.source = mydir
    DEPLOYMENTFOLDERS = # file1 dir1

    symbian:TARGET.UID3 = 0x2xxxxxxx
    DEPLOYMENT.installer_header = 0x2002CCCF
    # Allow network access on Symbian
    symbian:TARGET.CAPABILITY += ReadDeviceData WriteDeviceData SWEvent NetworkServices LocalServices ReadUserData WriteUserData

    symbian:LIBS += -lws32 -lcone -lapgrfx
    # If your application uses the Qt Mobility libraries, uncomment
    # the following lines and add the respective components to the
    # MOBILITY variable.
    # CONFIG += mobility
    # MOBILITY +=

    SOURCES += main.cpp mainwindow.cpp
    HEADERS += mainwindow.h
    FORMS += mainwindow.ui

    # Please do not modify the following two lines. Required for deployment.
    include(deployment.pri)
    qtcAddDeployment()
    and installer pkg file content.

    ; C:/QtWork/Tari//Tari_installer.pkg generated by qmake at 2011-04-19T18:02:28
    ; This file is generated by qmake and should not be modified by the user
    ;

    ; Language
    &EN


    ; SIS header: name, uid, version
    #{"Tari installer"},(0x2002CCCF),1,0,0

    ; Default localized vendor name
    %{"Vendor"}


    ; Default unique vendor name
    :"Vendor"



    ; Manual PKG pre-rules from PRO files
    ; Default dependency to Qt libraries
    ; Default HW/platform dependencies
    [0x20022E6D],0,0,0,{"S60ProductID"}
    [0x20032DE7],0,0,0,{"S60ProductID"}


    "C:/QtWork/Tari/Tari.sis" - "!:\private\2002CCCE\import\Tari.sis"
    @"C:/QtSDK/Symbian/SDKs/Symbian3Qt472//smartinstaller.sis",(0x2002CCCD)

  6. #6
    Registered User
    Join Date
    Nov 2010
    Posts
    16

    Re: Device not supported error.

    This problem happens only when packaging the smart installer one. If I try to install the sis file without the smart installer binaries, the application installs without any problem. Is this a problem with the smart installer in the new SDK?

  7. #7
    Registered User
    Join Date
    Jun 2007
    Location
    Mumbai, India
    Posts
    1,998

    Re: Device not supported error.

    Quote Originally Posted by ghanemabdo View Post
    This problem happens only when packaging the smart installer one. If I try to install the sis file without the smart installer binaries, the application installs without any problem. Is this a problem with the smart installer in the new SDK?
    It seems so, probably when final release is made then smart installer will start supporting it.

Similar Threads

  1. [moved] Smart Installer - Device not supported
    By forceoflight in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 11
    Last Post: 2011-04-14, 08:49
  2. Device not supported
    By vladest in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 20
    Last Post: 2010-10-15, 07:44
  3. Get "Feture not Supported" error message in device.
    By SymbianTH in forum Symbian Media (Closed)
    Replies: 6
    Last Post: 2010-02-09, 12:57
  4. Replies: 0
    Last Post: 2007-06-08, 12:55

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×