×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Oct 2010
    Posts
    10

    Symbian Compression libs

    hi,

    im newbie in Qt Symbian

    im working on QtNokia SDK to target Symbian

    to make a project to compress and decompress files and folders

    i found Compressing and decompressing GZIP files
    it uses
    -lefsrv
    -lezlib.lib


    while compiling i got error

    :: error: No rule to make target `\NokiaQtSDK\Symbian\SDK\epoc32\release\ARMV5\udeb\efsrv.lib', needed by `\NokiaQtSDK\Symbian\SDK\epoc32\release\gcce\udeb\testZip.exe'. Stop
    .

    any solution

    regards,

  2. #2
    Registered User
    Join Date
    Oct 2010
    Posts
    10

    Re: Symbian Compression libs

    after cleaning and building the project

    i got error in ezlib.dso

    :: error: No rule to make target `\NokiaQtSDK\Symbian\SDK\epoc32\release\armv5\LIB\ezlib.dso', needed by `\NokiaQtSDK\Symbian\SDK\epoc32\release\gcce\udeb\testZip.exe'. Stop.

  3. #3
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Symbian Compression libs

    I suggest using many Qt zip libraries then using Symbian one, one i have used in past is QuaZip ..

    if you still want to stick with ezlib then you can search in NokiaQtSDK\Symbian\SDK\epoc32\release\armv5\LIB\ for ezlib if you did not find it there then olny other way is to copy those missing libs from Symbian All-In One SDKs for Symbian^1

  4. #4
    Super Contributor
    Join Date
    Nov 2009
    Location
    Minnesota, USA
    Posts
    3,209

    Re: Symbian Compression libs

    My recollection is that the .dso file is the "front end" of the .dll. It needs to be bound into your executable for the .dll to be linked at runtime.

    I don't offhand know where this .dso should be found, but you need to find it in your development environment and make sure the build can find it (probably by adding a -L clause to your LIBS).

    Or else it may be that you aren't linking to a .dll, but rather to a .lib. In that case you (curiously) should leave the ".lib" off the lib name in the LIBS statement.

  5. #5
    Registered User
    Join Date
    Oct 2010
    Posts
    10

    Re: Symbian Compression libs

    about QuaZip
    its webSite says
    " Requirements
    Just zlib and Qt 4. Well, Qt 4 depends on zlib anyway."

    which is the problem that zlib is missing
    , right or i understand it in a wrong way ?

  6. #6
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Symbian Compression libs

    Quote Originally Posted by mms007 View Post
    about QuaZip
    its webSite says
    " Requirements
    Just zlib and Qt 4. Well, Qt 4 depends on zlib anyway."

    which is the problem that zlib is missing
    , right or i understand it in a wrong way ?
    looks like i missed the part where Nokia Qt SDK says (Partially support Symbian). I suggest you copy those files from S60 5th edition SDK

  7. #7
    Super Contributor
    Join Date
    Nov 2009
    Location
    Minnesota, USA
    Posts
    3,209

    Re: Symbian Compression libs

    Of course, the other option is to download zlib or gzip source and use that. I recommend zlib since it's license is the least restrictive/confusing (and I've used it in a couple of projects with no difficulty).

Similar Threads

  1. Replies: 1
    Last Post: 2010-11-05, 11:35
  2. Replies: 1
    Last Post: 2007-03-12, 13:19
  3. link to download symbian 6.1 libs?
    By clarktony in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 1970-01-01, 02:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×