×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 22
  1. #1
    Registered User
    Join Date
    Apr 2011
    Posts
    16

    Can't run the application on E5 mobile

    I tried to install the application on E5 and it is not working.When I run the application using QT Creator I get this error

    Executable file: 2768807 2011-04-18T12:27:05 C:\NokiaQtSDK\Symbian\SDK\epoc32\release\gcce\udeb\OpenLanes.exe
    Package: 2593056 2011-04-18T12:27:10 C:\OpenLanes\OpenLanes\OpenLanes.sis
    Deploying application to 'Nokia E5-00 USB Serial Port (COM3)'...
    Copying installation file...
    Installing application...
    Starting application...
    Could not start application: General OS-related error
    Finished.

    When I install the application using Ovi Suite, the application is installed but does not open, and no errors appear.
    My trails:
    • Uninstall and delete the app from the mobile.
    • Clean , run qmake, and the build the application.
    • Adding TARGET.CAPABILITY += NetworkServices Location ReadUserData WriteUserData to the .pro file, as I am accessing user data and gps info.
    • Added division.c


    Offcourse I installed QT, QT mobility and TRK on the device. Any Idea ?!

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: Can't run the application on E5 mobile

    Check the pani code for the crash. http://wiki.forum.nokia.com/index.ph...ded_panic_code it propably does try to start, but just chrashes before it could show anything.

  3. #3
    Registered User
    Join Date
    Apr 2011
    Posts
    16

    Re: Can't run the application on E5 mobile

    well I tried and installed ErrRd, nothing appears, what really happens is that the application is installed, but does not open, and when I try to run the application using QT creator this error appears
    Installing application...
    Starting application...
    Could not start application: General OS-related error
    which means that the application is installed, but when the application starts it crashes.

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: Can't run the application on E5 mobile

    if other means fails, do the my Y-Tasks (free, self-signed version) mentioned in the page I gave you the link for, it will always get the process exit code. And after getting it, please write it in here.

  5. #5
    Registered User
    Join Date
    Apr 2011
    Posts
    16

    Re: Can't run the application on E5 mobile

    I installed y-tasks, istalled the app, started crash monitor, started the app, open crash monitor...I found Main Kill:O,Kill

  6. #6
    Registered User
    Join Date
    Apr 2011
    Posts
    16

    Re: Can't run the application on E5 mobile

    UISS Kill: O,Kill
    !SISHELPER Kill: O,Kill
    Main Kill: O,Kill

  7. #7
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: Can't run the application on E5 mobile

    Kill-0-Kill, would normally indicate normal applciation exit. Though during start-up of the applciation, is also culd indicate that statically linked library is not found, thus check the libraries included by the application, and see that all of them would possible be in teh device.

  8. #8
    Registered User
    Join Date
    Apr 2011
    Posts
    16

    Re: Can't run the application on E5 mobile

    my pro file:

    INCLUDEPATH += includes # folder containing the common header files for included libraries

    symbian {
    TARGET.UID3 = 0xE5518971 #unSigned
    VERSION = 1.10.0
    TARGET.CAPABILITY += NetworkServices Location ReadUserData WriteUserData
    TARGET.EPOCSTACKSIZE = 0x14000
    TARGET.EPOCHEAPSIZE = 0x200000 0x2000000


    LIBS += -lQTweetLib.lib
    LIBS += -lqjson.lib

    }


    i.e I am using qtweetlib and qjson and I have them in folder includes.
    Am I missing something, how can I chech that qtweetlib and qjson libraries are on the device ?

  9. #9
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: Can't run the application on E5 mobile

    you could try removing them and seeing whether it helps, basically the dll files for the libraries are under sys folders which are not accessible due the platform security.

  10. #10
    Registered User
    Join Date
    Apr 2011
    Posts
    16

    Re: Can't run the application on E5 mobile

    when I remove them the build fails generating errors "missing headers"

  11. #11
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: Can't run the application on E5 mobile

    you should of course alse comment all parts using the library out.

    Anyway, I'm nor familiar with the qjson.lib & QTweetLib.lib libraries, thus are they really part of normal Qt libraries, or did you get them from somewhere ? if you got them from somewhere the did you install them somehow into the SDK, as well as did you install those to the device ?

  12. #12
    Registered User
    Join Date
    Apr 2011
    Posts
    16

    Re: Can't run the application on E5 mobile

    I am sure that they are installed to the SDK, regarding he device I don't know. how can I install the to the device ?

  13. #13
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Can't run the application on E5 mobile

    You install SIS files on device, so find the SIS files provided by the developers of those libraries and install them on your phone.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  14. #14
    Registered User
    Join Date
    Apr 2011
    Posts
    16

    Re: Can't run the application on E5 mobile

    I removed the code of both libraries and removed the include from the .pro file, and I have the same error

  15. #15
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Can't run the application on E5 mobile

    Send the application to the phone via Bluetooth or PC Suite and start the installation manually, i.e. not from IDE. Or do it from the IDE but first disable silent install from project's target configuration. This way you can see if it is the installation that fails or runnin the application.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. I can't run the application with ffmpeg
    By iron94 in forum Symbian
    Replies: 11
    Last Post: 2011-02-21, 12:20
  2. Replies: 34
    Last Post: 2009-04-14, 13:47
  3. Replies: 3
    Last Post: 2007-05-30, 13:04
  4. Getting the mobile number on which the application is being run
    By contactabbas in forum Mobile Java General
    Replies: 6
    Last Post: 2006-11-07, 17:19
  5. My application run perfectly on Emulator but can't run on mobile device (Socket)
    By x1054 in forum Mobile Java Networking & Messaging & Security
    Replies: 5
    Last Post: 2005-11-07, 21:12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×