×

Discussion Board

Results 1 to 10 of 10
  1. #1
    Registered User
    Join Date
    Nov 2008
    Location
    Egypt
    Posts
    122

    Install Qt sis file on Nokia devices?

    Hello,
    I created a simple mobile application using Qt, but when I try to install the sis file on Nokia devices, it asks me to isntall Qt Mobiltiy first on the devices (12 MB). Do I need to install it on mobiles?

  2. #2
    Nokia Developer Champion
    Join Date
    Dec 2008
    Posts
    2,356

    Re: Install Qt sis file on Nokia devices?

    Yes, the device many not have Qt installed on it, so install Qt or use smartinstaller to install Qt apps

  3. #3
    Registered User
    Join Date
    Jun 2007
    Location
    Mumbai, India
    Posts
    1,998

    Re: Install Qt sis file on Nokia devices?

    Quote Originally Posted by elshorbagy76 View Post
    Hello,
    I created a simple mobile application using Qt, but when I try to install the sis file on Nokia devices, it asks me to isntall Qt Mobiltiy first on the devices (12 MB). Do I need to install it on mobiles?
    Also more info like the device and firmware version will also help.

  4. #4
    Super Contributor
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: Install Qt sis file on Nokia devices?

    If you are trying to install on Symbian^3 device then you need to install qtmobility.sis. Otherwise you need to install qt_installer.sis and qtmobility.sis. Those sis files are available in :\NokiaQtSDK\Symbian\sis, assuming you are using NokiaQtSDK.

  5. #5
    Regular Contributor
    Join Date
    Oct 2007
    Location
    India
    Posts
    349

    Re: Install Qt sis file on Nokia devices?

    Quote Originally Posted by savaj View Post
    If you are trying to install on Symbian^3 device then you need to install qtmobility.sis. Otherwise you need to install qt_installer.sis and qtmobility.sis. Those sis files are available in :\NokiaQtSDK\Symbian\sis, assuming you are using NokiaQtSDK.
    If I compile my app with Qt Mobility 1.0.2 and If I try to run on Symbian^3 It will work but If I try to run this app on <Symbian^3 devices (5, 3.1, 3.2) which Qt & QtMobility version need to be installed ?

  6. #6
    Super Contributor
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: Install Qt sis file on Nokia devices?

    One for which you compiled your build.

  7. #7
    Regular Contributor
    Join Date
    Oct 2007
    Location
    India
    Posts
    349

    Re: Install Qt sis file on Nokia devices?

    Quote Originally Posted by savajr View Post
    One for which you compiled your build.
    Is this mean I need to prepare 4 sis files for each platforms Symbian^3, S60 5th Ed, S60 3.1 and 3.2

  8. #8
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Install Qt sis file on Nokia devices?

    I thought that we have sorted this out in http://discussion.forum.nokia.com/fo...ility-Versions already, but clearly that isn't the case

    Quote Originally Posted by ltomuta View Post
    Quote Originally Posted by narendar_discover View Post
    *Is this possible that one .sis will be run on all 4 plaforms (mentioned above)
    Yes
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  9. #9
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Install Qt sis file on Nokia devices?

    Quote Originally Posted by narendar_discover View Post
    Quote Originally Posted by savaj View Post
    If you are trying to install on Symbian^3 device then you need to install qtmobility.sis. Otherwise you need to install qt_installer.sis and qtmobility.sis. Those sis files are available in :\NokiaQtSDK\Symbian\sis, assuming you are using NokiaQtSDK.
    If I compile my app with Qt Mobility 1.0.2 and If I try to run on Symbian^3 It will work but If I try to run this app on <Symbian^3 devices (5, 3.1, 3.2) which Qt & QtMobility version need to be installed ?
    I see that you needed a second opinion on this one too

    Quote Originally Posted by ltomuta View Post
    Quote Originally Posted by narendar_discover View Post
    *For Symbian^3 what would be the version of Qt Mobility
    Since you are using the Nokia Qt SDK 1.0.2 and it contains the Qt Mobility 1.0.2 then the minimum version you should install is ... 1.0.2
    Quote Originally Posted by narendar_discover View Post
    *For <Symbian^3 what would be the version of Qt & Qt Mobility
    Following the same logic as above, minimum Qt 4.6.3 and Qt Mobility 1.0.2
    Seriously, what is wrong with the Smart Installer solution?
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  10. #10
    Regular Contributor
    Join Date
    Oct 2007
    Location
    India
    Posts
    349

    Re: Install Qt sis file on Nokia devices?

    Quote Originally Posted by ltomuta View Post
    Seriously, what is wrong with the Smart Installer solution?
    Right Lucian

Similar Threads

  1. Unable to install the self certification sis file on Nokia E60 device
    By manjunaths in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 22
    Last Post: 2009-09-24, 07:09
  2. [split]Install sis on Series 40 (was. Re: install and run sis on s60 2nd edition fp3)
    By dariusmizuro in forum General Development Questions
    Replies: 1
    Last Post: 2009-01-15, 08:19
  3. jar file install fail on Nokia Devices
    By tharindufit in forum Mobile Java General
    Replies: 5
    Last Post: 2008-11-10, 18:27
  4. Cannot install a .SIS file on Nokia N93
    By newstu in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2007-03-14, 03:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×