×

Discussion Board

Results 1 to 12 of 12
  1. #1
    Regular Contributor
    Join Date
    Jan 2009
    Posts
    100

    Problems with https API on FL4 on E7, yet works on N8

    Hi,

    We are accessing some API's which are on secure domain (https://api.XXXX.com). These API's are accessible when I run the application on Nokia N8. But the same API's are not accessible when I run the same application on Nokia E7. Are there any changes in accessing secured API's from FlashLite 4 for E7.

    Please note I tried publishing the swf with local access/network access and added to \other\trusted folder but the same problem occours.

    It gives the error message as 'IOErrorEvent type='ioError' ..... text='Error #2032''.

    Has anyone faced the same issue before?

  2. #2
    Regular Contributor
    Join Date
    Jan 2009
    Posts
    100

    Re: Problems with https API on FL4 on E7, yet works on N8

    No one has ever used HTTPS call on E7?

    I am not able to figure out any problem as I am using the same file.

  3. #3
    Regular Contributor
    Join Date
    Jan 2009
    Posts
    100

    Re: Problems with https API on FL4 on E7, yet works on N8

    One more update:
    When I tried to execute the same file, it works well on E7 on Remote Device Access by Forum Nokia. But it does not work on the actual phisical E7 device, the device being sent by Forum Nokia as part of gift.

    Can anyone guess what could be the issue or what could be the solution? Does the device require any settings for enabling the access?

  4. #4
    Regular Contributor
    Join Date
    Jan 2009
    Posts
    100

    Re: Problems with https API on FL4 on E7, yet works on N8

    The device available on RDA and mine both have the same software version but still the file does not work on the actual device I have.

    Can anyone from Forum Nokia suggest anything? This is really driving me crazy now...

  5. #5
    Nokia Developer Champion
    Join Date
    Jul 2008
    Location
    Pakistan
    Posts
    1,065

    Re: Problems with https API on FL4 on E7, yet works on N8

    Hi sangramp,
    I dont have experience with https in Flash Lite 4 and E7. But one of my tip is that try to use WGZ packaging as it may solves networks issues related to security.

    Best Regards,
    SajiSoft

  6. #6
    Regular Contributor
    Join Date
    Jan 2009
    Posts
    100

    Re: Problems with https API on FL4 on E7, yet works on N8

    Thanks Saji for your suggestion.
    But I am not sure if I can use that as I am currently using entire screen for app.
    Any guess as why this working on RDA devices but not on actual device I have?

  7. #7
    Nokia Developer Champion
    Join Date
    Jul 2008
    Location
    Pakistan
    Posts
    1,065

    Re: Problems with https API on FL4 on E7, yet works on N8

    Hi ,
    But I am not sure if I can use that as I am currently using entire screen for app.
    Who say that you cant use entire screen in WGZ? Ofcourse, you can .And wgz packaging is quite fine from Symbian^3 as there are no such issues like double tap zoom, slow tap response etc etc
    Any guess as why this working on RDA devices but not on actual device I have?
    It may have to do with the versions. May be the build of Flash Lite 4 as compared to your actual device or may be they have a different access point like WiFi or 3g or may be some other reason.

    Best Regards,
    SajiSoft

  8. #8
    Regular Contributor
    Join Date
    Jan 2009
    Posts
    100

    Re: Problems with https API on FL4 on E7, yet works on N8

    What I meant is avoiding the widget menu buttons at bottom. I am not sure if this can be made invisible.

    Regarding access point, I can run it through 3G on N8 but not on E7.

  9. #9
    Nokia Developer Champion
    Join Date
    Jul 2008
    Location
    Pakistan
    Posts
    1,065

    Re: Problems with https API on FL4 on E7, yet works on N8

    Hi sangramp,
    What I meant is avoiding the widget menu buttons at bottom. I am not sure if this can be made invisible.
    Obviously, you can make them invisible by using :
    hideSoftkeys API

    Best Regards,
    SajiSoft

  10. #10
    Regular Contributor
    Join Date
    Jan 2009
    Posts
    100

    Re: Problems with https API on FL4 on E7, yet works on N8

    Hi Saji,

    As per the suggestion, I tried with the WGZ packaging but the same result, I get the same error. Also I checked the on RDA devices and it worked well there.

    Anything else I can try for now :-)

    Regards,
    Sangram

  11. #11
    Nokia Developer Champion
    Join Date
    Jul 2008
    Location
    Pakistan
    Posts
    1,065

    Re: Problems with https API on FL4 on E7, yet works on N8

    Hi Sangram,
    Just one more suggestion. Why not try some other E7 or ask someone else to test the swf on their E7 ?. Sometimes, there come issues with some specific network or phone as it may needs a hard reset etc.

    BTW, I am currently out of city and don't have all my phones here except an N8.Otherwise, it is a matter of few minutes to test for me.

    Best Regards,
    SajiSoft

  12. #12
    Regular Contributor
    Join Date
    Jan 2009
    Posts
    100

    Re: Problems with https API on FL4 on E7, yet works on N8

    Thanks all for the replies. It was actually a different problem all together:-)

    We are using Auth 2 for authorisation and sends current time-stamp as a requirement during the process.

    The E-7 device we had was running 10 minutes ahead of time and hence the server was rejecting the request and we were getting the error accordingly. But once we set the device time correctly, it started working.

    Should you all note if you are developing any Auth 2 based applications :-)

Similar Threads

  1. [moved] E-mail issues on E7 and N8
    By flixoft in forum [Archived] Qt Mobility Project
    Replies: 2
    Last Post: 2011-04-15, 12:55
  2. webClient component doesn't work on the phone yet it works on epoc
    By DmitryZayats in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2008-07-22, 08:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •