×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Apr 2011
    Posts
    21

    How get install s60 sdk on QT creator properly?

    Hi,

    I have tried almost every guide i can find online to install the s60 3rd edition sdk on my qt creator. I have tried just installing the basic nokia qt sdk and then even installing it seperately as guided here: http://wiki.forum.nokia.com/index.ph...r_with_Symbian There just isn't a s60 qt version in my project options. Can anyone give me a hand? When I was installing the s60 3rd sdk, it gave me an popup error: It gave me an error stating: "WINDOWS VISTA USERS::Please find the GCCE patch for MSVISTA in\C:\S60\devices\S60_3rd_FP2_SDK_v1.1\plugins\vistapatch". Does this have any significance in the failure of my approach?

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: How get install s60 sdk on QT creator properly?

    What exactly are you trying to do and why?
    Use the Nokia Qt SDK 1.0.2, that's the SDK to use if you plan to develop Qt applications for Symbian.
    If you want to develop a Symbian C++ module then install the correct SDK, and Carbide.c++.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Registered User
    Join Date
    Apr 2011
    Posts
    21

    Re: How get install s60 sdk on QT creator properly?

    Quote Originally Posted by ltomuta View Post
    What exactly are you trying to do and why?
    Use the Nokia Qt SDK 1.0.2, that's the SDK to use if you plan to develop Qt applications for Symbian.
    If you want to develop a Symbian C++ module then install the correct SDK, and Carbide.c++.
    I want to release my project to s60 3rd edition but I cant seem to figure out how. I only have the option to release it to symbian^1 and symbian^3.

  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: How get install s60 sdk on QT creator properly?

    As long as you use Qt 4.6.3 and Qt Mobility 1.0.2 (i.e. the Nokia Qt SDK 1.0.2) you can release the applications you build to all S60 3.1 and later devices.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  5. #5
    Registered User
    Join Date
    Apr 2011
    Posts
    21

    Re: How get install s60 sdk on QT creator properly?

    Do you know how I can fix all the auto detected QTs? All of them cannot find their qmakes.



    If these are the ones from the remote compiler, then how do I install the exact ones on my qt creator so I don't have to use the remote one?

Similar Threads

  1. Replies: 1
    Last Post: 2011-01-05, 15:28
  2. How to debug QT app on S60 emulator in Creator?
    By TheSham in forum [Archived] Qt SDKs and Tools
    Replies: 5
    Last Post: 2010-12-24, 10:05
  3. how to launch s60 emulator from qt creator for nokia qt sdk
    By sunil_pgt in forum [Archived] Qt SDKs and Tools
    Replies: 2
    Last Post: 2010-12-21, 07:56
  4. Replies: 21
    Last Post: 2010-11-17, 04:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •