×

Discussion Board

Results 1 to 9 of 9
  1. #1
    (Retired) Nokia Developer Admin.
    Join Date
    Jan 2006
    Location
    Michigan
    Posts
    4,664

    NFC plug-in for the Nokia Symbian^3 SDK 1.0 available

    To assist in the testing of NFC applications for NFC capable devices running Symbian^3 and Symbian Anna, the NFC plug-in for the Nokia Symbian^3 SDK 1.0 is available. This software adds support for the Symbian^3 NFC APIs and simulation features for NFC tags and devices to the Symbian^3 SDK for Nokia devices 1.0.
    Download the plug-in

    More information on NFC support in Symbian^3 devices

  2. #2
    Registered User
    Join Date
    May 2004
    Location
    Germany
    Posts
    21

    Re: NFC plug-in for the Nokia Symbian^3 SDK 1.0 available

    Is it supposed to also support the JSR-257 Contactless Communication API?
    does not work with NetBeans, the javax.microedition.contactless.* packages are not found, and the Emulator throws NoClassDefFoundException when trying to run JSR-257 applications.

    Is it just me or are these still not included yet?

  3. #3
    Registered User
    Join Date
    Sep 2011
    Posts
    2

    Re: NFC plug-in for the Nokia Symbian^3 SDK 1.0 available

    I also met the same problem. i did not find any file which name likes jsr257.jar/jsr257.zip under in the symbian3 SDK1.0 or the NFC Plugin. So I can't compiler the NFC application. any helps

  4. #4
    Super Contributor
    Join Date
    Mar 2008
    Posts
    1,481

    Re: NFC plug-in for the Nokia Symbian^3 SDK 1.0 available

    At least these API is meant for Symbian C++ and Qt
    JSR 257 should be compitable with these except peer to peer communication .
    If we create J2ME NFC app for s40 that should work also in C7.

  5. #5
    Registered User
    Join Date
    Sep 2011
    Posts
    2

    Re: NFC plug-in for the Nokia Symbian^3 SDK 1.0 available

    Hi,Manub, Thanks your helps first! You mean that we need use the nokia6212/nokia6131 NFC SDK to develop the NFC application for Nokia C7 except P2P, right? then if we want to develop P2P for Nokia C7 in J2ME, then how to do it? Thanks

  6. #6
    Super Contributor
    Join Date
    Mar 2008
    Posts
    1,481

    Re: NFC plug-in for the Nokia Symbian^3 SDK 1.0 available

    That is right (though I have not really developed NFC J2ME app extensively, only some basic J2ME app ).
    We can use the LLCP api (one of the JSR257 extensions) for peer to peer communication on C7.
    Since this is extension possibly there will be break here.

    You can try this in the mean time.
    http://www.developer.nokia.com/Commu...r-to-peer_Chat

  7. #7
    Registered User
    Join Date
    Jan 2012
    Posts
    5

    Re: NFC plug-in for the Nokia Symbian^3 SDK 1.0 available

    The plugin described in this thread is for Symbian_3_SDK_v1_0 and won't install with Nokia_Symbian_Belle_SDK_v0.6. Nokia_Symbian_Belle_SDK_v0.6 doesn't come, as well, with jsr257.jar (ie, the packages com.nokia.nfc.*).

    So the question: Is there an equivalent plug-in for the Nokia_Symbian_Belle_SDK_v0.6 ?

  8. #8
    Registered User
    Join Date
    Jan 2012
    Posts
    5

    Re: NFC plug-in for the Nokia Symbian^3 SDK 1.0 available

    The link in the previous post by Ron Liechty, and discussed in this thread in general is for the Symbian_3_SDK_v1_0, and the plugin won't install with Nokia_Symbian_Belle_SDK_v0.6. Nokia_Symbian_Belle_SDK_v0.6 doesn't come, as well, with jsr257.jar (ie, packages com.nokia.nfc.*).

    So the question: is there an equivalent plugin for the Nokia_Symbian_Belle_SDK_v0.6?

  9. #9
    Super Contributor
    Join Date
    Mar 2008
    Posts
    1,481

    Re: NFC plug-in for the Nokia Symbian^3 SDK 1.0 available

    Hi,

    OK, there is no plugin for Belle SDK 0.6 and the link was meant for Symbian^3 and I have heard that should work with Belle as well.

Similar Threads

  1. Series 40 Nokia SDK available for Symbian C++??
    By rohanwaugh in forum Symbian Tools & SDKs
    Replies: 13
    Last Post: 2010-08-12, 14:04
  2. SIP Plug-in SDK 1.0 and 2.0_CW no more available?
    By Paulour in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-12-13, 08:47
  3. Replies: 3
    Last Post: 2007-08-28, 16:58
  4. Replies: 1
    Last Post: 2006-11-29, 15:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •