×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Mar 2009
    Posts
    19

    UseBrushPattern 's problem in symbian^3

    gc.UseBrushPattern(bitmap);
    gc.SetPenStyle(CGraphicsContext::ENullPen);
    gc.SetBrushStyle(CGraphicsContext::EPatternedBrush);
    gc.SetBrushOrigin(rect.iTl);
    gc.DrawRect(rect);
    gc.DiscardBrushPattern();

    problem: there one pixel surround the rect don't paint .
    there is no problem in s60 v5;

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: UseBrushPattern 's problem in symbian^3

    never seen that, anyway I have never used the SetBrushOrigin.

  3. #3
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,671

    Re: UseBrushPattern 's problem in symbian^3

    Can it happen that you are looking for BitBlt? I am asking because you are positioning the top-left corner of the bitmap to the top-left corner of the rectangle.

  4. #4
    Registered User
    Join Date
    Mar 2009
    Posts
    19

    Re: UseBrushPattern 's problem in symbian^3

    Quote Originally Posted by wizard_hu_ View Post
    Can it happen that you are looking for BitBlt? I am asking because you are positioning the top-left corner of the bitmap to the top-left corner of the rectangle.
    no , it don't happen when use bitblt.

  5. #5
    Registered User
    Join Date
    Mar 2009
    Posts
    19

    Re: UseBrushPattern 's problem in symbian^3

    Quote Originally Posted by symbianyucca View Post
    never seen that, anyway I have never used the SetBrushOrigin.
    what do you use?

  6. #6
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: UseBrushPattern 's problem in symbian^3

    I would have used just as:
    gc.UseBrushPattern(bitmap);
    gc.SetBrushStyle(CGraphicsContext::EPatternedBrush);
    gc.DrawRect(rect);
    gc.DiscardBrushPattern();

    Though gotta say that I can not excatly remember whether I have any specific program using that at the moment.

Similar Threads

  1. Replies: 4
    Last Post: 2011-04-11, 11:51
  2. Problem in creating server in symbian c++
    By amit.mangal in forum Symbian
    Replies: 3
    Last Post: 2009-11-23, 12:53
  3. Problem in configuring the IAP table in Symbian CommDb editor
    By natarajuab in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2004-12-07, 15:47
  4. Replies: 4
    Last Post: 2003-10-08, 02:41
  5. Problem in defining a CLASSPATH in Symbian SDK for Nokia 9210
    By potro in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2003-05-03, 16:45

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×