×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Dec 2007
    Location
    Kharkiv, Ukraine
    Posts
    21

    Exclamation Device Not Supported with the latest QtSDK 1.1 release and 5800

    Hello,

    I waited till Qt 4.7.3 and QtMobility is finally released to use my app with smart installer. Unfortunatelly I still get Device not supported message. I'm trying to install it on 5800

    Here is the part of the log:


    Code:
    06/05/2011	2:34:46	* Processing 0x1028299F (0, 0)
    06/05/2011	2:34:46	FileCheck: c:\sys\bin\securewidgetregistryclient.dll (0)
    06/05/2011	2:34:46	Package 0x1028299F files present
    06/05/2011	2:34:47	Package 0x1028299F: v8.02.350 installed (v8.02.340 requested)
    06/05/2011	2:34:47	+ SetState(): 2 -> 3
    06/05/2011	2:34:47	Changes URL: 'http://dl.qt.nokia.com/smartinstaller/'
    06/05/2011	2:34:47	Downloading CHANGES: '1028299f_changes.xml'
    06/05/2011	2:34:47	DlSt=   13, PrSt=    0, L=0
    06/05/2011	2:34:47	Starting download
    06/05/2011	2:34:47	DL    3482/   3482 (0.2 s, 22.37 kB/s) (total: 89 kB, 3.8 s, avg 23.61 kB/s) OK
    06/05/2011	2:34:47	+ SetState(): 3 -> 4
    06/05/2011	2:34:47	+ ParseChangesFileL(): 'C:\system\adm\1028299f_changes.xml'
    06/05/2011	2:34:47	+ SM::RunError(): 4, 20
    06/05/2011	2:34:47	! Package 0x1028299F v8.02.340 (ClientPlatform) not available for 0x2000DA56
    06/05/2011	2:34:47	Exiting due to failure 4
    06/05/2011	2:34:47	+ SetState(): 4 -> 16
    06/05/2011	2:34:47	+ CADMAppUi::HandleFailure(): 16. err=4, m=3
    06/05/2011	2:34:47	- CADMAppUi::HandleFailure(): 0
    06/05/2011	2:34:48	+ SetState(): 16 -> 15
    06/05/2011	2:34:48	About to uninstall wrapper
    It looks like a bug, please help or comment.

    Thanks,
    Sergey

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: Device Not Supported with the latest QtSDK 1.1 release and 5800

    Quote Originally Posted by sergey.payu View Post
    Hello,

    I waited till Qt 4.7.3 and QtMobility is finally released to use my app with smart installer. Unfortunatelly I still get Device not supported message. I'm trying to install it on 5800

    Here is the part of the log:


    Code:
    06/05/2011	2:34:46	* Processing 0x1028299F (0, 0)
    06/05/2011	2:34:46	FileCheck: c:\sys\bin\securewidgetregistryclient.dll (0)
    06/05/2011	2:34:46	Package 0x1028299F files present
    06/05/2011	2:34:47	Package 0x1028299F: v8.02.350 installed (v8.02.340 requested)
    06/05/2011	2:34:47	+ SetState(): 2 -> 3
    06/05/2011	2:34:47	Changes URL: 'http://dl.qt.nokia.com/smartinstaller/'
    06/05/2011	2:34:47	Downloading CHANGES: '1028299f_changes.xml'
    06/05/2011	2:34:47	DlSt=   13, PrSt=    0, L=0
    06/05/2011	2:34:47	Starting download
    06/05/2011	2:34:47	DL    3482/   3482 (0.2 s, 22.37 kB/s) (total: 89 kB, 3.8 s, avg 23.61 kB/s) OK
    06/05/2011	2:34:47	+ SetState(): 3 -> 4
    06/05/2011	2:34:47	+ ParseChangesFileL(): 'C:\system\adm\1028299f_changes.xml'
    06/05/2011	2:34:47	+ SM::RunError(): 4, 20
    06/05/2011	2:34:47	! Package 0x1028299F v8.02.340 (ClientPlatform) not available for 0x2000DA56
    06/05/2011	2:34:47	Exiting due to failure 4
    06/05/2011	2:34:47	+ SetState(): 4 -> 16
    06/05/2011	2:34:47	+ CADMAppUi::HandleFailure(): 16. err=4, m=3
    06/05/2011	2:34:47	- CADMAppUi::HandleFailure(): 0
    06/05/2011	2:34:48	+ SetState(): 16 -> 15
    06/05/2011	2:34:48	About to uninstall wrapper
    It looks like a bug, please help or comment.

    Thanks,
    Sergey
    What do you mean by "I still get Device not supported". What did you expect to have changed? Compared to what? Qt 4.6.3 was deployable by smart installer to 5800 already, wasn't it?

    As you can see from the logs, the component that fails to install is 0x1028299F, the "Client Platform". Nothing to do with the Smart Installer. A lot to do with Client Platform. Which, as shown at http://nokia.ly/SmartInstaller is part of Notifications API's dependencies.

    The only way this could be a Smart Installer is if your application is not using and therefore not needing the Notifications API. Or if your device should be able to use that API but the Smart Installer does not deliver you the binaries despite you having the required firmware version (as documented at Supported devices). Now, which is it?
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Registered User
    Join Date
    Dec 2007
    Location
    Kharkiv, Ukraine
    Posts
    21

    Re: Device Not Supported with the latest QtSDK 1.1 release and 5800

    Hello,

    Thanks for your reply. I expected Qt 4.7.3 to be supported by smart installer. But still have problems with it. You are right, the problem in Client Platform for Notifications API.

    My application does use Notification API and I have the following dependency in my pkg file:
    ; Default dependency to Ovi Notifications API libraries
    (0x2002EAB4), 1, 1, 11106, {"Ovi Notifications API"}

    Unfortunately, smart installer fails to develiver all required components for my phone. Package 0x1028299F v8.02.340 specificaly. So the main problem, that not all dependecies for 5800 is available. Why? It definitely looks like bug.

    Second part of the problem: it seems that Package 0x1028299F: v8.02.350 installed but smart installer tries to downlaod and install older version v8.02.340. Why?

    Thanks,
    Sergey

  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: Device Not Supported with the latest QtSDK 1.1 release and 5800

    Quote Originally Posted by sergey.payu View Post
    Hello,

    Thanks for your reply. I expected Qt 4.7.3 to be supported by smart installer. But still have problems with it.
    You don't have problems with Qt, you have problems with Notifications API, which is a separate project, built on top of Qt.

    Quote Originally Posted by sergey.payu View Post
    You are right, the problem in Client Platform for Notifications API.

    My application does use Notification API and I have the following dependency in my pkg file:
    ; Default dependency to Ovi Notifications API libraries
    (0x2002EAB4), 1, 1, 11106, {"Ovi Notifications API"}

    Unfortunately, smart installer fails to develiver all required components for my phone. Package 0x1028299F v8.02.340 specificaly. So the main problem, that not all dependecies for 5800 is available. Why? It definitely looks like bug.
    Indeed, this has to be investigated and a bug report should be created against the Notification APIs. If that team claims that Nokia 5800 is supported by their API then them must ensure that the smart installer deploys it.

    Last time I looked through the Notification API discussion board the 5800 was said not to be supported. Now it is listed as supported but only starting with certain firmware version. I tend to believe that this means that the device is in fact not supported at all for distribution, but that is something that the team there has to clarify in its messaging.

    Quote Originally Posted by sergey.payu View Post
    Second part of the problem: it seems that Package 0x1028299F: v8.02.350 installed but smart installer tries to downlaod and install older version v8.02.340. Why?

    Thanks,
    Sergey
    As listed at http://nokia.ly/SmartInstaller the version of the package distributed to users is 8.2.340. You may have a newer RD version, and in that case SI should not attempt to download the package. Yet to know that, SI must find that that package is, and what version it should have, and at that point it is being told that the package is not supported on your device. Therefore the installation is cancelled.

    So, depending on the answer to the earlier issue, that of should the device be supported or not, we may discuss whether in this case we should ask SI to ignore the fact that the existing package is not supposed to be supported, or to ask you not to use SI on a non-supported device.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  5. #5
    Registered User
    Join Date
    Aug 2009
    Posts
    12

    Re: Device Not Supported with the latest QtSDK 1.1 release and 5800

    I have the same problem with the latest SDK 1.1, building my application with Qt 4.7.3 + Qt Mobility 1.1.3 + SmartInstaller 0.46 (all for Symbian^1), when I try to install on the 5800 Xpress Music I get a "Device not supported." message, but the important thing here is that my application doesn't use the Notifications API. Most interesting, is that if I install Qt 4.7.3 + Qt Mobility 1.1.3 manually on the phone, and then install the .sis (not smart installer packed), it installs correctly and my app runs perfectly.
    I'm assuming this IS a SmartInstaller bug.

  6. #6
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: Device Not Supported with the latest QtSDK 1.1 release and 5800

    My suspicion is that you have a similar, but definitely not the same problem. See Qt SDK 1.1 does not support 5th edition devices??? for what I believe is more likely your story.

    If you still suspect that the smart installer is faulty, show us the relevant logs.

    If you still do not understand what's happening, post here the content of *_template.pkg and *_installer.pkg
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. Problem with 5250 – Device not supported
    By daremax in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 3
    Last Post: 2010-11-04, 14:55
  2. 5800 is not compatible with office - problem in device description
    By awoywood in forum Feedback - Nokia Developer Services & Infrastructure
    Replies: 3
    Last Post: 2009-05-26, 10:44
  3. Replies: 0
    Last Post: 2007-06-08, 12:55
  4. epocrc.pl is not supported in this release
    By Sharmilasrjasthi in forum Symbian
    Replies: 0
    Last Post: 2006-05-19, 10:24
  5. What's the latest software release for Nokia 6220?
    By umesh_singhal in forum Digital Rights Management & Content Downloading
    Replies: 0
    Last Post: 2003-11-22, 12:05

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •