×

Discussion Board

Results 1 to 13 of 13
  1. #1
    Registered User
    Join Date
    May 2011
    Posts
    4

    corrupted Info.plsit file

    Hi, I did:
    a) create new basic web app project
    b) name my project, fill version #

    click finish.

    Tried to preview the project, I get:
    Error
    Corrupted Info.plist file

    plist content:

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Nokia//DTD PLIST 1.0//EN" "http://www.nokia.com/DTDs/plist-1.0.dtd">
    <plist version="1.0">
    <dict>
    <key>DisplayName</key>
    <string>holaMundo</string>
    <key>Identifier</key>
    <string>com.holaMundo.widget</string>
    <key>Version</key>
    <string>1.0.0</string>
    <key>AllowNetworkAccess</key>
    <true/>
    <key>MainHTML</key>
    <string>index.html</string>
    <key>MiniViewEnabled</key>
    <false/>
    </dict>
    </plist>


    I'm using version 1.2, any idea of what's going on?

    Thanks in advance,

    Fran.

    EDIT
    -----------------------------------------
    After packaging web app, I'm able to start the stand alone web simulator, and run the package from there.

    Not quite what I was expecting but at least can try it.
    Last edited by franito1; 2011-05-06 at 23:05. Reason: added information

  2. #2
    Nokia Developer Expert
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: corrupted Info.plsit file

    Hi Fran and welcome to forum!

    Are you still experiencing this problem?

    I have seen some transient problems with packaging, if http://www.nokia.com/DTDs/plist-1.0.dtd has not been accessible, but your case seems to be a bit different.

    Did you modify Info.plist or was it just as the wizard generated it?

    Br,
    Ilkka

  3. #3
    Registered User
    Join Date
    May 2011
    Posts
    4

    Re: corrupted Info.plsit file

    Hi, thanks for the welcome and your response.

    I didn't modified the Info.plist, it's the one the wizard generated.

  4. #4
    Nokia Developer Expert
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: corrupted Info.plsit file

    Hi,

    Could you test, what happens if you do the same steps again? I mean start a new project and preview it.
    Just to see if the file was actually corrupted during creation, because I cannot spot anything wrong in the Info.plist contents you posted.

    -Ilkka

  5. #5
    Registered User
    Join Date
    May 2011
    Posts
    4

    Re: corrupted Info.plsit file

    started another blanck project, same result.

    I think it has something to do with the Web App simulator, because when I start it stand alone, I get the same alert window "Error: Corrupted Info.plist file", but once I load a packaged .wgz it loads ok (stand alone).

  6. #6
    Nokia Developer Expert
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: corrupted Info.plsit file

    Thanks for the information. I don't think there anything else I can do than raise a bug report.
    Sorry for inconvenience.

    Could you tell your environment details:
    -Operating system
    -Web developer environment version (Help -> About)
    -Web App simulator version (from simulator toolbar select settings and current version is listen in the updates section)

    Br,
    Ilkka

  7. #7
    Registered User
    Join Date
    May 2011
    Posts
    4

    Re: corrupted Info.plsit file

    Sure:

    Os: windows XP service pack 2 (spanish language)
    Web app simulator: 1.2.0.201103190355
    Web developer environment: 3.2.0.201103190355

    Regards,

    Fran.

  8. #8
    Nokia Developer Expert
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: corrupted Info.plsit file

    Thank you. I'll let you know if I hear some suggestions how this could be fixed.

    -Ilkka

  9. #9
    Nokia Developer Expert
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: corrupted Info.plsit file

    Hi,

    There was a patch released for Preview issues. It is not directly targeted to solve this problem, but could be worth trying.
    http://tools.nokia.com/wt/notes/1.2/release.html

    Br,
    Ilkka

  10. #10
    Registered User
    Join Date
    Jun 2011
    Location
    Buenos Aires
    Posts
    1

    Re: corrupted Info.plsit file

    Very same thing happened to me. Same environment description as Franito1's

  11. #11
    Registered User
    Join Date
    Jan 2006
    Location
    Argentina
    Posts
    24

    Re: corrupted Info.plsit file

    Very same thing happened to me. Same environment description as Franito1's
    [URL="http://www.prosciuttoproject.org"]The Prosciutto Project[/URL]
    Twitter:[URL="http://twitter/mzorz"]@mzorz[/URL]

  12. #12
    Registered User
    Join Date
    Dec 2009
    Posts
    2

    Re: corrupted Info.plsit file

    Same problem. Patch didn't help. I have no idea how to resolve this problem. Nokia please help me.

    P.S. I'm ready give you all informations (Error Log, Computer Configuration etc.).

  13. #13
    Super Contributor
    Join Date
    May 2008
    Location
    Helsinki, Finland
    Posts
    1,098

    Re: corrupted Info.plsit file

    HI there HF-It,

    Please could you post similar info as below? Thanks.

    Os: windows XP service pack 2 (spanish language)
    Web app simulator: 1.2.0.201103190355
    Web developer environment: 3.2.0.201103190355

    What I have is :

    Windows XP Pro SP 3 English /UK
    Web app simulator: 1.2.0.201103190355
    Web developer environment: Version:3.2.0.201103190355

    And the plist works for me OK when I create a Symbian Web App (.wgz) / Basic Web App Project and use the information included in the plist.

    No errors in packaging, validating or running.

    Best,
    Marko
    [FONT="Comic Sans MS"][COLOR="Blue"][/COLOR][I]Marko Lumivuori
    Technical Support
    +358 40 8019330
    [email]marko.lumivuori@nokia.com[/email][/I][/FONT]

Similar Threads

  1. file corrupted?
    By mysilversir in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 5
    Last Post: 2009-01-20, 08:07
  2. File corrupted.
    By overdozen in forum Symbian
    Replies: 2
    Last Post: 2007-12-10, 17:18
  3. File corrupted
    By Scalc in forum Mobile Java General
    Replies: 0
    Last Post: 2006-04-12, 07:39
  4. File corrupted
    By MrJou in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 6
    Last Post: 2006-03-22, 08:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×