×

Discussion Board

Results 1 to 13 of 13
  1. #1
    Nokia Developer Expert
    Join Date
    Jan 2004
    Posts
    45

    Exclamation Installation with latest Smart Installer and Qt4.7 dependency fails on N8!

    My Qt app has these dependencies

    Code:
    ; Default dependency to Qt libraries
    (0x2001E61C), 4, 7, 3, {"Qt"}
    ; Symbian^3 HW/platform dependency
    [0x20022E6D],0,0,0,{"S60ProductID"}
    ; Default dependency to QtMobility libraries
    (0x2002AC89), 1, 1, 3, {"QtMobility"}
    I am using this 0.46 Smart Installer version (smartinstaller_0_46_0_ss_nocs.sis)

    Now it works on C7 but fails on N8. The installation fails apparently after downloading the 1/3 part of the Qt packages.
    The c:\Logs\ADM shows this error. I post only the error spot here:

    Code:
    09/05/2011	1:24:28	DL 6859956/6859956 (112.3 s, 59.67 kB/s) (total: 6745 kB, 115.8 s, avg 58.27 kB/s) OK
    09/05/2011	1:24:28	+ SetState(): 12 -> 13
    09/05/2011	1:24:28	DlSt=   16, PrSt=    0, L=0
    09/05/2011	1:24:28	Installing 'C:\system\adm\qt_473_symbian3_9.2.421_pu.sis' to C:
    09/05/2011	1:24:29	DlSt=   13, PrSt=    0, L=0
    09/05/2011	1:24:29	+ SilentInstallPackage(): 'C:\system\adm\qt_473_symbian3_9.2.421_pu.sis' to C:
    09/05/2011	1:24:30	CInstallManager: Install completed (-30483). 0
    09/05/2011	1:24:30	HandleInstallCompletedL(-30483): 13
    09/05/2011	1:24:30	Removing 'C:\system\adm\qt_473_symbian3_9.2.421_pu.sis'
    09/05/2011	1:24:30	Dependency installation failed -30483
    09/05/2011	1:24:30	+ SetState(): 13 -> 16
    09/05/2011	1:24:30	+ CADMAppUi::HandleFailure(): 16. err=5, m=3
    09/05/2011	1:24:30	- CADMAppUi::HandleFailure(): 0
    09/05/2011	1:24:31	+ CreateInstallationResumeInfo()
    Can you tell what possibly goes wrong?
    Or e.g. what is the error code -30483 (if that is the relevant error code here)!

    Thanks!

  2. #2
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,143

    Re: Installation with latest Smart Installer and Qt4.7 dependency fails on N8!

    interesting, not 100% certain, but if the error is the one from SW Installer API, it could be "30483 — The package is an invalid upgrade", thus is this some kind of developer test device, that could have some funny version of Qt installed there ? if so, could you just reset it and see that it works then.

  3. #3
    Nokia Developer Expert
    Join Date
    Jan 2004
    Posts
    45

    Re: Installation with latest Smart Installer and Qt4.7 dependency fails on N8!

    No it should have the "ordinary" Qt versions that has been deployed with either SW upgrade or with earlier smart installer. Of course it is hard to tell the exact Qt version numbers, since you can not find them anywhere. From the Qt app I can log QtCore and it seems to be 4.6.4 phone SW is 014.002 (this is N8). Does this tell anything?

  4. #4
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,143

    Re: Installation with latest Smart Installer and Qt4.7 dependency fails on N8!

    there is Qt project that shows the current versions: https://projects.forum.nokia.com/qtinfo/ its made with Qt 4.6.3, thus it should only update the Qt mobility via smart installer.

    I have not heard any single problem with N8 updating to Qt 4.7.3, as well as have successfully done that by myself as well.

  5. #5
    Nokia Developer Expert
    Join Date
    Jan 2004
    Posts
    45

    Re: Installation with latest Smart Installer and Qt4.7 dependency fails on N8!

    ... and just tried quickly to install the qt_473_symbian3_9.2.421_pu.sis separately and yes indeed it gives "Update error!" as you suggested. Hmm I wonder why!?

    It is a bit of a trouble if a "phone reset" is needed when upgrading Qt to 4.7.

  6. #6
    Nokia Developer Expert
    Join Date
    Jan 2004
    Posts
    45

    Re: Installation with latest Smart Installer and Qt4.7 dependency fails on N8!

    ... QtInfo seems to require Qt 4.7.2 "Note that Qt 4.7 needs to be installed for the application to work. The goal is to make QtInfo? work with Qt 4.6 as well, but currently this is not the case. " So does not install in this N8 which has only 4.6.4

  7. #7
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,143

    Re: Installation with latest Smart Installer and Qt4.7 dependency fails on N8!

    it should not be required, as well as I have not heard of any such problem before, thus can you really check that the device is "normal" user device, and does not have anything that could mess things up.

  8. #8
    Nokia Developer Expert
    Join Date
    Jan 2004
    Posts
    45

    Re: Installation with latest Smart Installer and Qt4.7 dependency fails on N8!

    Solved! There was apparently "manually" installed Qt4.6.4 on the phone which I was able to remove with Application Manager. After that the Smart Installer worked fine.

    Thanks!

  9. #9
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: Installation with latest Smart Installer and Qt4.7 dependency fails on N8!

    Would you be able to remember what was the source of that 4.6.4 package?
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  10. #10
    Nokia Developer Expert
    Join Date
    Jan 2004
    Posts
    45

    Re: Installation with latest Smart Installer and Qt4.7 dependency fails on N8!

    Could have been some version of QtSDK, not sure though :-|

  11. #11
    Registered User
    Join Date
    May 2011
    Posts
    2

    Re: Installation with latest Smart Installer and Qt4.7 dependency fails on N8!

    i've the same problem.got this issue while installing Nokia Trailers,Facebook Browser ..i'm unable to uninstall qt.it does not show in application manager...but i have an application "QMLViewer"...got installed with Nokia Bubbles.but this app also does not show in app manager.

    Also, i tried installing QTInfo,but i says i don't have qt 4.7..

  12. #12
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: Installation with latest Smart Installer and Qt4.7 dependency fails on N8!

    Yes, the Bubbles problem ... a fix is being worked on, you should look for info at the BetaLabs site.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  13. #13
    Registered User
    Join Date
    May 2011
    Posts
    2

    Re: Installation with latest Smart Installer and Qt4.7 dependency fails on N8!

    Issue solved..solution available at betalabs...thanks ltomuta.

Similar Threads

  1. smart installer fails with "unable to delete file"
    By Nesma M. Rezk in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 3
    Last Post: 2011-05-20, 14:09
  2. Sign SIS with Smart Installer on MAC
    By marek.sebera in forum [Archived] Qt Quick
    Replies: 0
    Last Post: 2011-05-05, 12:12
  3. smart installer fails with “Certificate error contact application supplier”.
    By jscurtis in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 2
    Last Post: 2011-01-16, 15:12
  4. Installation of smart installer fails on E72
    By andrevw in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 0
    Last Post: 2010-02-18, 12:06

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •