×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Sep 2006
    Posts
    51

    Problem in Playing Video file

    Hello,

    I am playing a video file using CVideoPlayerUtility class, it is getting played properly.
    But when screen dims out ,video disappears. Only sound comes but no video..
    Any idea??

    Thanks

  2. #2
    Registered User
    Join Date
    Sep 2006
    Posts
    51

    Problem in playing video

    Hello,

    I'm playing a video using CVideoPlayerUtiilty class.It is playing properly but when i select Option,which opens menu video disappears from screen.
    Although audio is coming but no video..

    Any idea why this is happening? how do i tackle this issue?

    Thanks

  3. #3
    Nokia Developer Champion
    Join Date
    May 2004
    Posts
    2,267

    Re: Problem in playing video

    Hi,

    One of the following changes may help you to resolve the issue:

    1. try not to clear the video playback view

    Code:
    //void CMyVideoPlayerAppView::Draw( const TRect& /*aRect*/) const
    //    {
    //    CWindowGc& gc = SystemGc();
    //    TRect rect = Rect();
    //    gc.Clear( rect );
    //    }
    or

    2. Try to draw the video playback view with transparent black, i.e. TRgb(0,0,0,0).

    Code:
    void CMyVideoPlayerAppView::Draw( const TRect& aRect) const
        {
        CWindowGc& gc = SystemGc();
        TRect rect = Rect();
        TRgb color = TRgb(0,0,0,0);
        gc.setPenColor(color);
        gc.setBrushColor(color);
        gc.setBrushStyle(CGraphicsContext::ESolidBrush);
        }
    Regards

    Ziteng Chen

  4. #4
    Registered User
    Join Date
    Sep 2006
    Posts
    51

    Re: Problem in playing video

    Tried the above code but no change.

Similar Threads

  1. Problem in playing video from memorycard
    By dreamsunlimited in forum Mobile Java Media (Graphics & Sounds)
    Replies: 5
    Last Post: 2011-01-18, 15:16
  2. Problem Playing FLV video files
    By tarun.WRT in forum Symbian
    Replies: 0
    Last Post: 2010-08-20, 07:52
  3. playing a video in horizontal mode but no video image!!!!!!
    By cxl_symbian in forum Streaming and Video
    Replies: 0
    Last Post: 2009-01-10, 03:15
  4. Problem playing 3gp video clip in 3650
    By marieG in forum Mobile Java General
    Replies: 0
    Last Post: 2003-04-24, 12:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×