×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jun 2010
    Location
    Chandigarh, India
    Posts
    17

    Question How to load *.wav files on Device (Symbian ^3) ??

    Hi,

    I am developing a game for Symbian 3 devices.

    Now, i am loading (*.jpg) images for texture from following path ::
    \epoc32\release\winscw\udeb\z\private\E000021F

    But i am not able to load the (*.wav) sound files to play from the same path.
    So i am loading the sound files from the following path ::
    \epoc32\winscw\c\private\E000021F

    Now with this implementation, Code is working properly on the Emulator but showing an Error(SYSTEM ERROR -1) on device.
    My .pkg file is a s follows ::
    Code:
    "..\inc\hill.jpg"                                                -"!:\private\E000021F\hill.jpg"
    "..\inc\king.jpg"                                                -"!:\private\E000021F\king.jpg"
    "..\inc\track.JPG"                                                -"!:\private\E000021F\track.JPG"
    "..\inc\button-image3.bmp"                                                -"!:\private\E000021F\button-image3.bmp"
    "..\inc\car.jpg"                                                -"!:\private\E000021F\car.jpg"
    "..\inc\side.jpg"                                                -"!:\private\E000021F\side.jpg"
    "..\inc\abc.wav"		-"!:\private\E000021F\abc.wav"
    "..\inc\xyz.wav"		-"!:\private\E000021F\xyz.wav"
    __________________

    Syntax to load the images::
    Code:
      
        _LIT(Kcar,"car.jpg");
        _LIT(ktrack,"track.JPG");
        _LIT(Khill,"hill.jpg");
        _LIT(Kking,"king.jpg");
        _LIT(Kside,"side.jpg");
    Syntax to load the sound::
    Code:
    _LIT(KSampleFile, "abc.wav");
    _LIT(KSampleFile, "xyz.wav");

    ISSUES ::
    • Why the code is working fine on Enulator but not on Device?
    • Why the code is not picking up the sound files from where Image files are being loaded?
    • What can i do now??



    Best Regards.

  2. #2
    Regular Contributor
    Join Date
    May 2010
    Posts
    362

    Re: How to load *.wav files on Device (Symbian ^3) ??

    Maybe the path is incorrect?

    The sound loading method is probably looking for the file in c:\abc.wav.

    Did you append the private path in front of the sound file path when loading?
    http://wiki.forum.nokia.com/index.ph...vate_directory

  3. #3
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,750

    Re: How to load *.wav files on Device (Symbian ^3) ??

    Something like
    Code:
    TFileName filename;
    CCoeEnv::Static()->FsSession().PrivatePath(filename);
    filename.Insert(0,RProcess().FileName().Left(2));
    filename.Append(KCar); // KTrack, etc.

  4. #4
    Registered User
    Join Date
    Jun 2010
    Location
    Chandigarh, India
    Posts
    17

    Re: How to load *.wav files on Device (Symbian ^3) ??

    Thanks guys for your support.
    Its working now.

    Path was the only issue.

Similar Threads

  1. using j2me to access system files on symbian-based device
    By thrashattack in forum Mobile Java General
    Replies: 1
    Last Post: 2010-08-31, 05:36
  2. How to play video files on Symbian 1.2 SDK (Symbian 6.0)
    By go4jas in forum Symbian Media (Closed)
    Replies: 1
    Last Post: 2005-01-20, 14:23
  3. How to play video files on Symbian 1.2 SDK (Symbian 6.0)
    By go4jas in forum Symbian Tools & SDKs
    Replies: 3
    Last Post: 2005-01-19, 07:44
  4. Replies: 2
    Last Post: 2005-01-19, 05:41
  5. How to load .png files in Symbian C++ proj??
    By amanjha14 in forum Symbian Media (Closed)
    Replies: 1
    Last Post: 2004-12-06, 09:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×