×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    4

    Deplyment Problem

    I have a game application, that runs fine on the 6310i NDS emulator. When I deploy it to the real phone, over serial cable, I get an "Application not supported" error. (The upload is successful).

    Any ideas what could be going wrong?

    Thanks
    Richard

  2. #2
    Regular Contributor
    Join Date
    Mar 2003
    Location
    UK
    Posts
    229

    RE: Deplyment Problem

    It's just a thought but what are the settings in the jad file (and manifest)?

    Have you got anything other than:
    MicroEdition-Profile: MIDP-1.0
    MicroEdition-Configuration: CLDC-1.0

    Maybe if you specify an invalid version you get the "not supported" error? Let us know if you find out what it is.

    Cheers,
    Steve

  3. #3
    Registered User
    Join Date
    Mar 2003
    Posts
    46

    RE: Deplyment Problem

    Hi,
    Application Not Supported error message occurs during the installation if the device profile specified in manifest doesn't match that of the device the JAR file installed onto. So, like a previous answer suggested, you should check the following lines

    MicroEdition-Configuration: CLDC-1.0
    MicroEdition-Profile: MIDP-1.0

    They should be like above.
    I hope this helps you to continue.

    regards,

    Petri/Forum Nokia

  4. #4
    Registered User
    Join Date
    Mar 2003
    Posts
    4

    RE: Deplyment Problem

    Thanks for that, much appreciated.

    Problem now sorted.

    I had the Microedition-Configuration set to CDLC-1.0 instead of CLDC-1.0, in the words of Homer Simpson, Doh!

    Infact I'm very impressed with the performance of the 6310i, it's faster than the simulator, and the simulator seems to accuratly simulate the real phone. Good job nokia.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×