×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jun 2011
    Posts
    2

    Problem with preferences.

    Hi,

    I get error when I try read or write widget preferences after OVI browser open external web-site (via widget.openURL or click HTML-link) and return back using soft-button.
    There simple code:
    Code:
    <head>
    	<script type="text/javascript">
    		function test() {
    			document.getElementById('test').innerHTML += widget.preferences.getItem('test');
    		}
    	</script>
    </head>
    <body onload="javascript:init();">
    	<div id="test"></div>
    	<a href="#" onclick="test();return false;">test</a><br>
    	<a href="http://www.google.com/m">google</a>
    </body>
    config.xml file contains:
    Code:
    <preference name="test" value="test_value"/>
    At first time when I run widget in device and click "test" link this code works properly. But if I click "google" link, then return back via soft button, the widget is broken: after click "test" link I see that widget starts GPRS-activity, but request breaks at middle and don't take result. Similar behavior I see when server-side javascript code raise an exception, but in this case placing script in try-catch block also doesn't take effect

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Posts
    115

    Re: Problem with preferences.

    Hello,

    Could you kindly provide the device model, firmware version (dial in *#0000# in home screen) and Ovi Browser version info (from Ovi Browser menu)?

    Thanks,
    Petro
    'petro
    @petrosoininen

  3. #3
    Registered User
    Join Date
    Jun 2011
    Posts
    2

    Re: Problem with preferences.

    Nokia 2700 classic. V09.80. 02-12-09 RM-561.
    OVI 1.0.0.11.8

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Posts
    115

    Re: Problem with preferences.

    Sorry about the delay.

    Thanks for this info. I will discuss this with R&D.

    petro
    'petro
    @petrosoininen

Similar Threads

  1. emulator preferences problem
    By yaront in forum Symbian Tools & SDKs
    Replies: 10
    Last Post: 2010-05-20, 12:54
  2. Replies: 3
    Last Post: 2009-10-02, 16:15
  3. Problem about preferences of emulator [S60 2nd FP3 MIDP]
    By dark_lkp in forum Mobile Java Tools & SDKs
    Replies: 4
    Last Post: 2008-05-15, 00:33
  4. Problem Network Preferences 3rd Emu
    By bherrera in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2006-02-15, 19:34
  5. Preferences store
    By urrg in forum Symbian
    Replies: 1
    Last Post: 2004-11-26, 02:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •