×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Jun 2011
    Posts
    3

    Mobility example: QtMultimediaKit not installed

    Quote Originally Posted by divanov View Post
    That would be good news, but careful reader will notice
    http://labs.qt.nokia.com/2011/05/04/...-1-1-released/
    that Maemo target has Qt 4.7.0 and Qt Mobilitity 1.0.2, which were there since Nokia Qt SDK 1.0.
    I’m sorry to be a nuisance but I'm developing for a Maemo5 device, so if I understand correctly I cannot work with the Qt SDK1.1(is that right?????).

    I didn't know the compatibility issues and downloaded the 1.1 version. After that I encountered some difficulties to test the declarative-camera's example. Someone has some suggestions to fix it?
    Excuse my english.

  2. #2
    Nokia Developer Moderator
    Join Date
    Oct 2009
    Posts
    4,326

    Re: Qt SDK 1.1

    Quote Originally Posted by Ita_student View Post
    I cannot work with the Qt SDK1.1(is that right?????).
    I see exactly no reason, why you would not be able to use Qt SDK 1.1 for Maemo 5 development.

    Quote Originally Posted by Ita_student View Post
    After that I encountered some difficulties to test the declarative-camera's example.
    Camera API is not part of Qt Mobility 1.0.2, you will have to upgrade to Qt Mobility to 1.1 or later. Search for post QCamera in N900 for the details how to do that.

  3. #3
    Registered User
    Join Date
    Jun 2011
    Posts
    3

    Re: Qt SDK 1.1

    Thanks for your readiness, I'll open a thread to explain the difficulties that I met. I'm relieved reading your reply.

  4. #4
    Registered User
    Join Date
    Jun 2011
    Posts
    3

    Mobility example: QtMultimediaKit not installed

    I'm working on LinuxMint 10 (64bit version) based on Ubuntu 10.10-64bit, Gnome 2.32.0, Dual Core processor.

    I downloaded the Qt SDK version 1.1.1 (containing: Qt libraries ver.4.7.3, Symbian and MeeGo simulators, Qt Creator IDE ver.2.2, Qt Mobility ver.1.1.3, Qt development tools, Remote compilers) from http://qt.nokia.com/downloads and followed the installation instructions (setting also LD_LIBRARY_PATH like it says, although it isn't persistent after reboot)

    I succesfully runned the quickstart example on a N900 (with Maemo 5 ver.20.2010.36-2 alias PR1.3), (although I switched the currentCountryCode method with currentLanguage because the country code results unsetted) but when I tried to test the declarative-camera example during the running I obtain this message:
    Code:
    qrc:/qml/decalrative-camera.qml:42:1: module "QtMultimediaKit" is not installed
    Can anyone help me to make it work properly?

  5. #5
    Nokia Developer Moderator
    Join Date
    Oct 2009
    Location
    Finland
    Posts
    327

    Re: Mobility example: QtMultimediaKit not installed

    I would suggest using the ready-made mobility 1.1 and 1.2 evaluation packages from http://wiki.forum.nokia.com/index.ph...ation_on_Maemo

  6. #6
    Registered User
    Join Date
    Apr 2012
    Posts
    3

    Re: Mobility example: QtMultimediaKit not installed

    I'm working on windows 7 with SDK 4.7 and I'm targeting symbian S60. I also have the same problem.
    Please help!

  7. #7
    Registered User
    Join Date
    Sep 2011
    Posts
    449

    Re: Mobility example: QtMultimediaKit not installed

    Hi harendra.wee

    Can you open a new thread for your problem in QT for symbian section, you might find an answer there,

Similar Threads

  1. Qt Mobility not getting installed
    By somnathbanik in forum [Archived] Qt SDKs and Tools
    Replies: 3
    Last Post: 2010-10-13, 11:47
  2. Replies: 1
    Last Post: 2007-12-21, 14:50
  3. Replies: 0
    Last Post: 2007-12-21, 14:37

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •